C7 zwave flakiness, ghost nodes

Ugh, the C7 is driving me crazy. I tried moving a bunch of devices from my C3 hub to a new C7 a few weeks ago. I had pairing and stability issues, and ended up with some ghost devices. I was able to remove all but one. After a week I gave up, reset the zwave radio, and started again from scratch.

I was more careful the second time. I moved the hub to a better location, and built up the mesh more slowly. It was looking good! After a couple days of settling, I tried to add a GE switch and it failed. I checked the Zwave device info and didn't see anything odd, so I tried pairing again and it worked.

A few hours later I tried pairing an Aeotec MS6. The sensor showed that it paired, but Hubitat did not. I tried excluding the sensor a couple times, but never got an acknowledgement from Hubitat or the sensor that it worked. That got me a bit worried, and I rebooted the hub. After the restart, the hub showed 2 ghost devices (one before and one after the GE switch).

I attempted to exclude the GE switch a couple of times, but the excuse never worked, so I ended up force removing it and doing a factory reset on the switch. I rebooted the hub and ended up with the two ghost devices and the GE switch again (even though I had removed it).

I disconnected the GE switch and the MS6 from power and tried to do the refresh+remove process in Hubitat, but none of the ghost devices would remove. Then I plugged the Nortek stick from my C3 into a computer, downloaded PC Controller, and tried using it to remove the ghost nodes. No dice. (I could see the ghost nodes, but trying to mark them as "failed" always, well, failed.) To top it all off, I couldn't exclude the PC from the mesh when I was done trying to remove things (I had paired and unpaired the PC once while trying it out, but couldn't unpair it the second time).

Is there any way to definitively clean up a mesh, or is trashing it and starting over pretty much it? Or is it fine to leave a few ghost nodes around if you're sure you've fully reset the devices in question? (I've read conflicting advice about that.)

I wouldn't leave the ghosts. Sometimes they are very difficult to remove using the hub itself, however it's pretty easy to do using PC Controller and a Z-Wave stick. Several write-ups on doing that in the forums.


I had a ghost mode for several weeks and it didn’t cause any issues. I finally spent several hours this past weekend to get it removed with a Zstick and PC Controller. It took many many tries clicking Is Failed for it to finally show failed. Super frustrating but persistence paid off and it’s gone now.

1 Like

I tried that using the HUSBZB stick from my C3. I was able to join the C7's network with it and see all the devices. However, I wasn't able to remove any of them. The devices in question aren't powered (and haven't been for days), but Hubitat insists that they're still there, so the "Is Failed" command hasn't worked yet.

I can work with that. I spammed the button a few times and eventually gave up. Knowing that hitting it more might eventually work gives me hope. :smile:

1 Like

But I'm getting oh so tired of seeing this:

Screen Shot 2021-01-11 at 9.17.32 PM

Yep me too and sometimes it would take 10 or so minutes to finish. Just let it finish and hopefully it will turn red.

It usually only takes 10-20 seconds for me, so at least that's something.

Woo, one finally turned red! Of course, "Remove Failed" didn't work, so I guess I'll just keeping hitting that for a while and see what happens...

1 Like

OMG I removed one of them. I just kept spamming "Remove Failed" on a device (not the one I managed to mark as failed, still haven't been able to removed that one). After some large number of attempts, it finally removed. Two more to go...

1 Like

Woo! Two down, one to go...

1 Like

I feel like the standalone Zwave controller isn't really doing anything that you can't do through the C7's interface, it just lets you spam "remove" faster.

Success! The ghost nodes have been removed after much "Remove Failed" spamming. Feeling bold, I also added several devices I'd been scared to try after the last inclusion debacle, and everything seems to be working great.