C7 to C8 – Z-Wave Network Woes

TLDR: Had a rock-solid Z-wave network for two years consisting of Inovelli switches, Zooz switches/relays, and Bali blinds. Transitioned to C8 and wound up chasing ghosts (now resolved?) and consistently having devises drop off the network. Currently struggling to have a reliable Z-wave network (i.e., functioning devices) and am lost on where to go from here.

Hey everyone,

Never had a chance to post on these forums, but have been a long-term lurker.

I’ve been struggling with my Z-wave network since transitioning from the C7 to the C8. Many of my devices appear not to be connecting (either to the C8 or each other), and are not operating.

My setup includes Inovelli Red Switches (10) across my house, a Zooz Zen32 switch (1), Zooz Zen16 relays (2), and Bali Z-Wave blinds (7). This setup grew over time (approximately two years), first with the switches and then progressively to the relays and blinds. It was working fantastically on my C7, never encountering any issues with the devices nor integrations/rules/buttons (e.g. Lutron Pico remotes to the blinds through the C7 integrated to the Lutron Hub; Inovelli and Zooz switches controlling physical and Hue lights through the C7 integrated to the Hue Hub, etc.). Every once and a while I would encounter 1-2 delays in switch button presses and Hue lights on/off but nothing systemic.

Upon migrating from the C7 to the C8, I found that none of my ZWave devices operated. This included physical interaction with the switches (outside of instances where they were directly controlling a local load) or by triggering actions through the respective device page directly in Hubitat. Upon investigation, I found that I had two ghost devices, which I subsequently removed through PC Controller and a Zooz ZWave stick. When I navigate to the ZWave page, I see that between one and all devices have no documented route (this varies day-to-day; see image below). Upon doing a ZWave Repair, I also get between one to many (3, 5, 8, etc.) failed nodes.

My house is a 2500 sq ft split level built in 2008. The switches and blinds are dispersed throughout the house. The hub is located in the center of the house in the lower level and is connected via CAT6.

Below is what I’ve tried to date (not necessarily in this order; most tried multiple times in different combinations):

  • Rebooting Hubitat (including removing from power for up to five minutes).
  • Removing ghosts via PC Controller (followed the instructions on this thread and successfully removed to ghost nodes - props to @danabw for a great guide!).
  • ZWave repair.
  • Removing/re-adding devices (experimented with each one Inovelli switch and one Bali blind as I didn’t want to have to recreate all my button mappings and automations).
  • Moving the C8 hub.
  • Updating the C8 to the latest release.

Any/all guidance and help is greatly appreciated. Sincerely apologize if I’ve missed something obvious.


P.S. I did let the Z-Wave network build for two days on the C8 before I started with any of the troubleshooting. I also let the Z-Wave network rebuild for two days after removing the ghosts.

@jordancoffey Have you done a full power cycle? Shut down hub from settings menu. Unplug power for 5 mins and power back up?

Anything in the logs?

Is your old hub powered down? or at least have the z-wave radio reset on it?

@rlithgow1 Thanks for the quick reply! To answer your questions:

Yes, did a full power cycle, including unplug for 5 minutes. Happy to try that again.
Nothing in the logs is jumping out to me. Lots of Sharptools errors. Anything in particular I should be on the lookout for?
Yes, my old hub (C7) is powered down (followed the migration instructions to a letter and have had the C7 unplugged and in a drawer ever since).

Again, really appreciate the quick reply!


Might also check your App and Device stats to see if one of them is logging a lot of time - I've seen a few instances where a rule gets corrupted in the transition and flood the mesh with traffic.


If those errors are consistent 401 errors, you'll want to reauthorize your hub starting from your SharpTools.io User Page → Manage Connections to make sure your new hub gets a new token.

You can also temporarily disable specific apps if you want to clean things up (eg. logging) or rule things out for troubleshooting.

1 Like

@thebearmay Good call - didn't think of that! Attached are my device and app stats. Not sure if these constitute a lot of time?

@josh Yep, you're absolutely right. Totally forgot to reauthorize my new Hub. That has resolved the Sharptools errors. Thanks!

Maybe related? Looks like Sharptools was the greatest time in the App log so my (boneheaded) forgetfulness to authorize the new hub was flooding the network? Not seeing a change in my Z-Wave network following the Sharptools authorization (and did a quick repair - pretty much all my nodes are failing) but maybe I would need to wait for the network to "heal"?


Failed Nodes

Once the repair is over and all the devices failed, the auto-recovery is unlikely to happen. Looks like your mesh network is in really bad shape. How it ended up in this situation is very hard to tell based on details provided. You may be dealing with a hardware malfunction, so you may not have caused this problem. Please send me a private message along with your hub id and we will further investigate.


No, it shouldn't. It might cause a slight increase in the per-event processing duration by a slight amount, but shouldn't impact your hub (other than the superfluous warning logs).

I would also note that apps like SharpTools will by their nature have a high Total time especially if you have lots of devices authorized as basically every event has a very brief execution within the 'app' and the total will of course keep incrementing and accumulating over time.

That in and of itself is not issue. What might be an issue is if you were seeing the app take an inordinate amount of your Total CPU Time. You can click the option to 'Show display settings' at the top of the App Statistics and check a few of the extra boxes to see what I mean. Ideally, none of your apps should show a significant '% of Total' and you'll likely see that SharpTools is processing a large number of events over time but at a low latency (Avg, ms).

That said, I'll leave it to the Z-wave gurus here to help you with that side of things. :slight_smile:

@bobbyD Thanks for the quick reply. PM sent. As I mentioned in my direct message, I'm actually hopeful that it's a hardware issue - that's to be expected when doing things at scale and is a luck of the draw!

@josh That makes a ton of sense! Included more detailed stats below - you're right, total CPU Time is low.

@rlithgow1 @thebearmay @josh @bobbyD I can't thank you all enough for the suggestions and quick replies. This is why I love products like Hubitat, SharpTools, Inovelli, etc: The communities are incredible!



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.