C7 to C8 Migration Z-Wave Challenges

3 days ago I migrated from my C7 to the new C8. Migration was very straightforward and most everything worked. My challenge is only with Z-Wave devices. Although I have reliable usage, I went from nearly instant response to a consistent 3-5 sec delay for all z-wave devices. After hours of troubleshooting and forum searching I can't find anything in terms of what next steps to take. Could use some advice on what to look at next, below are screenshots of my z-wave details pages. Appreciate any help or guidance.

can you re-post that all as a screen shot?

Apologize for the wrong format....here are screenshots for the page. Thanks.

Hmmm that's a big z-wave network!

I have had similar problems since migrating about three weeks ago. I had a solid, reliable, and responsive mesh on the C7 and on the C8 issues appear. Mesh looks good on paper but in reality some device are really slow to respond. I have also had devices eat batteries in a couple days. I have also targeted a few devices that now have a really strange route and a slow connection speed. I have had some luck re-pairing the problematic devices, and in one or two cases I just replaced them. That seems to have helped.

I suspect, though have no data to support this, that there are some devices in the mesh that do not behave all that well on the C8 - either because of the 800 chipset SDK or the firmware or whatever. And these cause issues. But honestly I am still trying to track them down as well.

I did learn RTT on a battery devices is not reliable on the z-wave details report so that may not be a good gauge - user experience is probably better.

You COULD try a full z-wave repair - that was one thing support recommended to me when I first encountered these issues. Also many devices just got better over time, and by time I mean a couple weeks.

Hope this helps.

1 Like

I'm not an expert, so take what I say with a grain of salt.

I noticed you have Jasco switches.
I had lagging problems on my C7 with my Jasco switches that were solved by selecting 'alternate exclusion' method on @JasonJoel 's driver.
I don't know how behavior would have changed from C7 to C8 for you though.
Did you go to the stock driver for the switches, or something?

Thanks, appreciate the advice. Sounds like I should let it run for some time and see if it improves. Will wait that out before going through the hassle of potentially repairing/replacing.

Kept the same drivers but worth a try. I'll try the driver you recommend, thank you.

I'd read the thread. Make sure the driver is for your device. If it's old, maybe not.

Keep an eye on anything with a crappy route or that sucks batteries. In fairness the ones I tossed were Zooz ZSE18s - never liked those things.

I too am having similar issues with my zwave network after moving to C8. I can see the commands being issued to a scene of devices and even with directly routed devices, the device responds about 43 seconds later. This seems to affect mostly my zwave dimmer devices from what I can tell but that may not be inclusive.

How long has it been since you did your migration?

My C8 has been running for almost 48 hours, and currently, my Z-wave experience is disappointing. The house woke up with both the upstairs and downstairs water heaters off. No way I could get them to turn on (Aectec Heavy Duty switches). I had to shut down the hub, remove the power and wait for 10 minutes before booting it again. After that, control of the Heavy Duty switches was restored.
I know of at least four more Z-wave switches that I can't control (they don't respond to any commands, although z-wave details show routes for these devices). Some of them initially worked but stopped working during the cause of the day. A further reboot of the hub did not help.
Apart from this issue, I have 7 Z-wave devices (it seems mostly sensors and remotes) that do seem to work but show no route on the Z-waive details page.
I do not have any Z-wave ghost devices.
Of those devices that do work, many more (compared to the C7) are now connected directly to the hub.

About 1 week ago now. I’ve updated some drivers today but still see sporadic slowness or lack of response altogether.

I'm about a month in post-migration. I had a similar experience though maybe not quite as dramatic. IEveryting working great on the C7 but once I migrated I had a number of devices that became very unreliable (Ring gen 2 keypads), a lot of devices that became very slow, and a number of Aeotec trisensors that started eating batteries. I'd also see devices sort of partially include where the device thought it had successfully included but HE did not. Or like the z-wave stick where it appeared to include but only a third of my z-wave devices showed up. I also had problems getting rid of devices that had failed. In my case then mesh looked gerally healthy with most devices connected directly to the hut at 100kbps.

My working theory (though have no data to support) is that there are some devices that just do not like the C8 and cause issues for the mesh overall. In my case I noticed a couple of Zooz motion sensors with really screwy routes (like 3 feet from the hub and going through 4 repeaters) and slow response times. I removed them completely and things SEEM to be improving. I also ended up excluding and re-including a lot of the devices that were sucking down battery. So far it seems to have made a difference but it has been a struggle for sure with a lot of grey hairs, a case of CR123s, and 3-4 devices I ended up tossing out of frustration.

For additional context this seems to effect the below types of plug-in dimmer devices using the inbuilt drivers. I have seen better response times since switching to user drivers found in package manager.

GE ZW3107
GE ZW3104
Leviton DZPD3-2BW

getting ready to swap a new C8 for my C7 with mostly zwave devices. Have these issues been sorted out? Would it be worth it to wait or is there really some compatibility issues with the new zwave chip?

Both my z-wave device issues and my zigbee device issues remain.

I don't know that anyone has narrowed it down to a compatibility issue with the 800 series chip. Could easily be something environmental or a platform firmware thing.

Most people have migrated without issues so it's really a risk/reward call on your part.

1 Like

If there were an easy way to go back to the C7, I would have done so already.I left my C7 as is, but I've migrated my Sharptools dashboards to the C8. So I'll have to redo all my dashboards if I go back. (The C7 is off and hasn't been turned on after I shut it down as part of the migration process). Idated wouldngs would improve after a while, but no such luck. (I have close to 70 Z-wave devices connected to the hub.)
My Z-wave network has been very stable the last few months with the C7. Not so with the C8. I have no ghost devices, and all devices show a route in Z-wave details (although sometimes one of two devices don't show a route. Often when that happens, things are fine and those devices will still respond to commands).
It's nine days since I installed the C8. I've had cold showers four mornings because the Z-wave network failed at night. There were days I had to reboot the hub 4 times to regain control of Z-wave devices. Sometimes a reboot is sufficient, other times, it would not help, and I have to shut down the hub and disconnect it from power for 10 minutes.
Yes, I would say about 80% of the devices are connected directly to the C8 and when they work, the response is instantaneous. Z-wave devices stop responding at random times. Sometimes none of the Z-wave devices would respond (only recovering after a reboot/reboot power disconnect), and other times only some of the devices stop working. Sometimes they recover and start responding again. without intervention. Distance from the hub doesn't seem to play a role. E.g. the Aeotec Heavy Duty switch that causes the cold showers is a mere 2 meters from the hub. A Fibaro Wall plug which is within a foot from the hub often drops off the network (not showing a route until the hub is rebooted.)
If power is removed from the hub during a reboot, all devices work fine for a while. One moment a device would respond, the next moment it fails to respond. Right now, I'll have to reboot the hub again (the third time today) because a few devices are once again not responding. Curtains didn't close, lights did not come on, to name a few.
I'm close to going back to the C7, even if that means I'll have to rebuild the Sharptools dashboards.

You can go either direction with the SharpTools Hubitat Migration tool. The main things it's doing is updating the location ID (hub ID) in all your dashboard tiles and rules from the source to the target.


Might want to try upgrading to the latest release


Download the Hubitat app