C7 to C8 - All Z-Wave missing

Hi, I followed the instructions to migrate.
On first attempt no z-wave devices have migrated.
Should I do a new backup and overwrite the C8 or do a soft/hard reset of the C8 first?

please advise.

I just had this issue this morning. First thing is to make sure both hubs are on the latest firmware update if they both are on the latest firmware update, what did the trick for me was rebooting my old hub and doing another back up and then restoring it to the new c-8.

no need to do a hard reset on the new hub just rerun the restore process

I had the same problem. The C-7 was updated to the latest (I did a update check before starting the migration). The new C-8 was behind a revision after I completed the new restore, so I updated the software and re-initiated the cloud restore, but still nothing in the Z-wave table...

Do I need to power up the C-7 and still do a new backup? It was at

Edit: Being very impatient when troubleshooting, I powered up the C-7, verified it was, did another cloud backup, swapped hubs again back to the C-8 restored the new cloud backup, and the Z-wave Details page is now full again.

I presume that restoring the backup on the previous software version that came on the C-8 hub caused the z-wave mesh to be empty, and no amount of restores of that initial backup was ever going to get it back..

But, I guess I still can't figure out why the new backup (which should be identical to the first C-7/ backup) managed to restore the z-wave... IT seems the 2 backups should be identical...

Maybe there was some error in the initial backup file.. that a new C-7 hub backup somehow corrected... (?)


i think the the old hub needs to be rebooted after the update and before you do the backup

That shouldn't be necessary, as rebooting is part of the update process.

1 Like

It sounds more like a local backup was restored and not a cloud backup. Running another cloud backup would overwrite and previous data stored in the local database as well as radios.

1 Like

If no devices were migrated, please be sure that a cloud backup is restored and not a local backup.

If the cloud backup was generated after the hub was updated to version, you can restore the same cloud backup. To confirm what version the cloud backup was created, check "Platform Version" column. Be sure to select "Migrate from another hub" symbol in the "Actions" column:

1 Like

that's what did the trick for me. both of my hubs were on the latest update and no z-wave devices came over. i tried the restore process 3 times. i finally got it working by rebooting the c-7 and doing the backup and restore process again


Mind sending us a private message at @support_team along with your hub IDs? We are interested in learning more about what went wrong, so others don't have the same experience, which is unusual...

so on second attempt it worked, my zwave devices showed up.
I did a zigbee, zwave and soft reset on the C8 just to be sure...


@bobbyD @support_team I just migrated from my C-7 Main hub to my new C-8 hub. Everything went well except I too have no Z-Wave devices. Zigbee and everything else was good. I have rebooted and still have no Z-Wave devices showing. Both the old and the new hubs were updated to the latest release and I did a cloud backup per instructions and that is the back that I restored. What should I do next?

@bobbyd @support_team FYI: I restored 3 times and they are still now showing up. I double checked the cloud backup that I restored and went step by step with the instructions. There was no indication of a problem until I check Z-Wave Details. Here is a screen shot of the completion screen before it rebooted:

Don't want to waste your time, but have you done a full shut down of the C-8 after the migration? Shut down, wait for red LED, pull power, wait a minute or so, power up again?

LIkely won't help, but won't hurt.

Yep done that no change

Exact same thing resolved it for me too...

1 Like

The C-8 hub wouldn't have any local files to restore from, and I definitely did not select a file from a windows file manager dialog on a restore.. so, I'm 99.9999% certain it was a cloud restore..


Make sure the C-8 is running the most recent version.
Shut down the C-8
reboot your C-7 (everything on it should still be working).
Make sure the C-7 is running the most recent version.
Do a fresh cloud backup of the C-7
Shut down the C-7
Boot back up the C-8
Do a cloud restore from the latest C-7 cloud backup onto the C-8.

That's what ended up getting mine to work.

I still think it was some issue doing the restore to a C-8 hub that was still back revved... but.. that's just a theory.


If you ever power this back up make sure you change it's Zigbee channel to one different from the C8.

I'm seeing some related z-wave issues, but mine seems to be different.

Everything restored from the cloud backup just fine, though every now and then the z-wave devices will stop working. It seems a power down, unplug, and power up gets things going again but they have dropped off a couple times and I've had to power down just to fix.

Everything else went smoothly, some wifi cloud devices needed logging back into, but nothing as extreme as I expected honestly.

I have tried running z-wave repair and I believe this helps after a while, but it's annoying for my z-wave devices to be down for any extended period of time.

Has anyone experienced this, or am I alone on this one? Hoping to rule out if its an issue with the z-wave radio in my hub or not. Everything was fine on the C7, and I understand there are growing pains when adopting new tech. Otherwise, the hub has been rock solid. When z-wave is up, it responds very quickly, and zigbee has been very responsive as well.

Any advice would be appreciated!

This is what it looks like when running a z-wave repair:

1 Like