C7 not setting up

Ok I’m new to this so be patient. I received my c7 and hooked up like it said. Light stays blue. I can find it in portal but when I select the hub it goes to another page and then says the page Connor be reached.

Ok, let’s try a few things.

Have you set up your router to reserve a DHCP IP lease for your hub so it is at a known IP? If not, do that.

Have you tried a network scanner (Fing, etc.) to see if your hub responds to pings on the network?

Have you tried a different port on your switch or router?

Once you find the IP, can you access the Diagnostic Tool at

And Welcome, sorry things aren’t going well.

I can find the ip of the hub. No I have not reserved a ip yet. Just getting started and trying to get it setup and updated. Not to worried about a dedicated up yet. We are moving and changing internet providers in 2 weeks. Just trying to get hooked up and figure this thing out.

Also no I haven’t tried a scanner yet. Actually totally forgot about using one to check for it.

Ok, then go to the Diagnostic Tool page at
log in using the MAC address in form
Report the version of the diag tool.

Ok will try that later today when I’m off work.

Ok. Diagnostic Tool should be 1.0.75. First step will be to get it there, if necessary, then we can move forward. It should already have that version if your C-7 is new.

Ok just checked and yes it is 1.0.75
firmware is ver if that helps

Ok, then log in to the Diagnostic Tools page using your MAC address. Do a Soft Reset, then try to restore a firmware version (if any versions show). I doubt you will find a version on there to restore, and it looks like yours is one of the rare ones that didn't get a platform installed at manufacture. The good news is that you can get to the diagnostic tools menu, so it will be able to be fixed without sending it back.

I suspect that your Hub, which appears to be working, doesn't have a valid platform software installed. There's a process documented at the link below, but you may want to contact support (tagging @bobbyD) because it might be best if they walked you through it. It's a bit scary:

Send an email to support (click the support link at the top of this page) and they will contact you and walk you through the factory restore process for a C-7 with blue light out of the box.

On second thought, don't do the above. If the diagnostic tools menu shows that a platform is installed, then try the soft reset and try to restore a firmware version - several versions are kept on the hub. If that doesn't work, then email support.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.