C7 Hub. Cannot pair/control Fibaro Switches

I have purchased a C7 hub with the intention of moving everything from my C3 to the C7.
Unfortunately I've fallen at the first hurdle.
I loaded the backup from my C3 onto the C7 OK.
I then followed Bruce's guide to migrate Z-Wave devices.
The first device I tried was a Fibaro Motion Sensor and this migrated OK.
I then tried a Fibaro FGS-212 device.
It was found OK but went in as a 'Device'.
I changed the driver to the correct one but I could not control it though the device page.
I then thought I would try a Fibaro FGS-223. This did not even get discovered.
I tried several times but no joy.
I have had to revert back to how things were.
Has anyone else tried discovering these Fibaro devices with any success?
BTW I could pair them back to my C3 again with no issues and they are working just fine.
There must be an issue with the new z-wave radio on the C7.

Interesting, I have a few Fibaro devices so I am interested in this. As I understand it, the Z-Wave chip in the C7 can be configured for the different Z-Wave frequencies. Perhaps you need to configure it for your region first ?

Thanks for the reply but I'm in Europe and it is set to Europe.
I'm seeing comments in other threads about selecting S0 through to S2 when pairing. At no point did I get an option to select.
Not sure if this is correct or not. I have asked this question in another thread about which one to use but didn't really get a satisfactory answer.

1 Like

I still don't know what answer you are looking for there. :man_shrugging: There is no one right answer.

IF you need/want secure pairing, use S2 whenever possible. S0 can be used, but it uses up 3x more messaging/mesh bandwidth - whether that is a bad thing on your network depends on how heavily loaded it is.

IF you don't care about encryption/secure pairing, pair without it.

I only tried a Fibaro motion sensor and a Fibaro Switch module.
The sensor paired OK but the switch module did not. It does pair OK with my original C3 hub.

At no point was I 'offered' a preference of what method to use. No big deal I suppose but when I have read the Hubitat document about pairing z-wave devices it does show in the screen shots.
Should it appear or not? I've no idea as I gave up after the Fibaro switch. I could not control the device through the UI. That's the main point of the thread and why I was asking if anyone else was having issues with these Fibaro devices on the C7.

I believe that if you are not offered any security options, then the device does not support S0 or S2 security, and always pairs non-secure.

I paired ~20 devices today that I know do not support S0 or S2, and did not get the security dialog on any of them - so I think what I said above is correct.

Unfortunately I don't have any Fibaro devices, so can't contribute there.

1 Like

Thanks. Makes sense I suppose.

I only have one Fibaro device, the fgk-101 contact sensor which is a zwave non plus device.

There are issues with adding zwave devices. I fought through it. On some devices I didnt get the prompt for security and I think its because they didn't support them.

Try to reboot the hub, exclude the device, reboot again, then do an add. When it shows up in the list of discovered devices wait until the inclusion times out. If its stuck at the initializing screen, I would reboot, then go into settings zwave and click on discover for the new device that should show up there at the bottom of the list. Then kick off a discovery again and see if it shows up. You shouldn't have to put the device into discovery again. It should already be included in the network.

This solved it for me, as much as a pain it was, after the first 15 devices I didn't have to do it again for some reason.

You really have to pay close attention to the zwave network. The first time I added all my devices the mesh was a mess for some reason. I had to wipe it all, and did it slowly and now the zwave devices are working perfectly.

Hi @mike.maxwell
I've been pairing Fibaro devices y]to my shiny new C7 hub.
While I can Unpair/Pair and control with user drivers on my C3 hub, these same drivers to not update the status of the switch when used on the C7 hub. They do on the C3.
There is no built in driver for the FGS222 or 223 devices but there is a Fibaro Switch.
Are these devices going to be supported by HE?
Is there a reason why they would work on the C3 OK but not on the C7?
Thanks.

They should work correctly so long as they were included with all the S2 security grants unchecked.

Should I have seen an option?
I go into zwave pair and off it goes.
It either finds and pairs the device or it doesn't.
I'm also having problems with Fibaro Motion sensors. They pair ok but lux reporting is hit and miss. Some devices do, some don't.

Can you tell me how I can check/ensure these devices are joined correctly.

The device will work as expected, other than that there shouldn't be any security related entries in the data section.

Hi @mike.maxwell
I've looked at one of my fibaro motion sensors and I can see that it has joined securely.
How do I stop this from happening?
I never get any choice when I pair the device.

is this an S2 capable device?

It's a ZW5 Fibaro Motion sensor.
Is it a secure device? I have no idea.
If it is, and everytime i join it it shows up as securely joined, shouldn't I be offered a choice of how I wish to join it or have I misinterpreted the zwave joining document.
Thanks.

It sounds like it is S0 only, you can tell by the in clusters 0x98 is s0, 0x9F is s2.
Is there no way to include this without security?

1 Like

It has cluster 0x98 showing.

image

On my C3 there is an option on the Z-wave page to have secure pairing for locks only.
No option for this on my C7 so I'm afraid, unless an option appears during the pairing stage, it just pairs.
The funny thing is it is now working OK.
I'm still seeing no status updates on a FGS-223 and on an FGS-222 I have to do a refresh to see it update when turning off and on.
I am using work rounds to get these devices to work but it just seems strange they worked OK on my C3 but not on the C7. I suppose that's because of the different radios.
Thanks again.

1 Like

Hi, what driver are you using for the fgs223?
I can install it no problem and it creates the child device but won’t respond. Using the new C-7 hub. It works perfectly on the C-5.

I’m using ericm driver btw. Thanks