C7 Blue Light blues

New to HE, long time with ST. Plugged in the hub and got the blue led of death. I see it's a fairly common topic here but I can't find any solutions.

Plugged HE into the same switch path the ST is on, replugged, repowered etc. with same results. Contacted support and got a reply with the customary questions. Replied and updated, after I plugged into the router directly with a new cable and got the same. Router (Asus) picked it up with the right mac.

Problem is, after the first email support has gone dark (3 days) so I came here. If someone can point me in the right direction I'll make every reasonable attempt before packing it in. This forum seems very active but I'm a little concerned the company doesn't have a similar sense of urgency.

I'm OK with ST (except for the outages) but would like to add HE as an adjunct to my existing alarm system to maintain local control.

Thanks in advance.

Are you replying to the e-mail support sent you? This is critical for the ticket tracking system to keep track of you.

Is this a brand new hub? Were you able to register it or has it never booted up?

Assuming you can't reach the "regular" web user interface . . .

Can you reach the diagnostic interface on :8081? Here is more information on that tool:

https://docs.hubitat.com/index.php?title=Hubitat_Diagnostic_Tool

If you can access that tool, check what software release it thinks is on the hub and also what release of the Diagnostic Tool is on the hub. It should show that it is picking up the IP from your DHCP - is that reserved? Just checking.

5 Likes

Did respond Tuesday & Wednesday, ticket 20722.

New hub, never booted.

Platform Version:
hub-2.2.4.158
Hardware Version:
Rev C-7
IP Address:

Diagnostic Tool Version:
1.0.75

FWIW I looked at the set clock on the diagnostic, it has a time from 2015. Didn’t try anything else.

Address not reserved.

Thanks.

EDITED by Support to remove personal data.

The issue sounds like the platform isn't loaded. I'm tagging support here so they are aware of this issue, because I think it can be fixed with their instructions.

Tagging @bobbyD

2 Likes

The diagnostic tool is an older version (1.0.81 is the latest). You may wish to try this URL and see if it updates the tool (which may also load the platform - not sure about that)

http://172.24.1.146/hub/cloud/updateDiagnosticTool

1 Like

If that does not work to update the diagnostic tool (I experienced that on a hub) you can try this (this worked for me):

If hub is not running, then it will be a little more complicated. Using cmd line, run the following to get the latest platform update, and after the hub is back online, then update the Diagnostic Tool using the above page:

curl -s -X POST [http://hubs.ip.address.here:8081/api/getLatest]

Replace hubs.ip.address.here with actual IP.

2 Likes

Thanks Eric and aaiyar. Went with the curl command first. It responded "success" but the platform, as reported in the tool, didn't change; 2.2.4.158.

Then went to aaiyar's line and got a refused connection, with :8081 got a 404.

With nothing to lose I pulled a reboot through the tool but it's been spinning for way too long. Router is showing no traffic.

OK, that curl just updates the diagnostic tool, not the platform.
If you can get to the diagnostic tool menu it should have an option to download the latest platform version . .

If reboot doesn't work. After you run out of patience, try a power down, let it sit for about a minute, then power up again. Remember - don't unplug the micro USB as it is fragile - unplug the other end.

I don't know why but the C-7 must do something different when you unplug it and that seems to solve some problems that rebooting alone does not.

1 Like

The tool didn't update either, still 1.0.75. No option for the latest version in the tool, only a previous version.

Will try the power boot but, other than the tool, it doesn't look like the hub is responding to anything.

That's odd about the tool - success should indicate it completed the update.

What I ended up doing was a platform downgrade from the diagnostic tool. Then shutdown and unplug for a minute, then restart. If you get to a green light, update the diagnostic tool with the link aaiyar provided. If that works, then try to update the platform to the latest from that diagnostic tool menu.

More odd. Did the power up, no green. Refreshed the tool page and got a brief blip of "download latest" then it cycled in a few seconds and removed that option.

On the rollback, the dialog comes up but doesn't offer any versions to switch to.

Just for kicks I checked the clock and noticed it reverted back to Jan 1, 2015 after I had reset it to current.

Feels like this hub isn't having any of this.

It sounds very similar to my experience a few weeks ago. My C-7 had been sitting on the shelf since last summer as I waited to feel more comfortable with the new Z-Wave and for some of the platform issues to be resolved. It had a very old platform version and an old diagnostic tool. I was ready to throw in the towel and ask @bobbyD to send me a replacement but I stuck with it (and he stuck with me) and we got it going. It hasn't as much as hiccupped in two weeks and I have moved all my Zigbee devices and several automations over to it - it is in production. I got another C-7 and it fired right up with no issues. Go figure!

2 Likes

It almost sounds like the download of the new version worked. It's pretty fast. What platform version is the diagnostic tool showing now? Still the 2.2.4.158?

Sorry for the delays. Please check your email. I also edited your post above to remove your Hub ID, which is a unique identifier associated with your hub and can be exploited.

4 Likes

Thanks bobbyD, email instructions worked.

4 Likes

Could I please have the instructions as well. My brand new hub is also stuck with the blue light:(

@bobbyD I have a brand new C7 and blue light stays on. Doesnt go to green. Please help

Did you send an email to support.hubitat.com? I would do that, bobbyD doesn't always see the tags here in the forum.

2 Likes

Yes I did. Thanks.

I'm just chipping into the conversation here to say that if you have a blue light that stays on, and you're within warranty period, then keep at support to fix or replace it for you.

Once you're out of the 90 days and the unit bricks itself due to an auto update, you're on your own.

My C7 was running just fine and then it did an update (release channel, nothing 'beta') and it went to blue on permanently. Reverting firmware from the diagnostics screen achieved nothing... all the tricks you read in this forum did not work. A few weeks of back and forwards with support email and they're basically "not our problem - you're out of warranty" and won't do anything.

Hence I've moved back to Home Assistant. The C7 was great... until Hubitat's firmware seemed to brick it. And 90 days wty and then not covering your own firmware releases? That's crap corporate behaviour and they've lost a user... I won't be recommending Hubitat from this point forward - due to their attitude, not just because the C7 died.

Download the Hubitat app