C7 and Z-Wave - Disappointed again

Just a quick note that I got a C7 to see if that could help me debug/fix my many months of message storms.

Right away I have issues with including my first four devices: HomeSeer WD200+ Dimmers about 3-9 feet away from the C7 hub. I have included hundreds of Z-Wave devices by now and know the drill. I excluded them from old C5 hub AND reset factory reset the dimmers.

First try included for completeness:
I start the include and get a dialog box asking for input S2 and S0. I leave it as default and is asked for 5 digits. I take off the dimmer and input the code.

Hub then moves on and find the dimmer but hangs at Initializing. I try a bunch of things but decide to bail out. I reset the Z-Wave radio, restart the hub, and start over.

Second try:
I try to add it again but this time unselecting the S2 authenticated option. I'm then not asked for the five digits, which is great since I really don't want security on my lights anyway and don't want to chase down the S2 codes for each switch.

Still... HE hangs at Initializing. This is in the same room where all switches and hub have line-of-sight. I try a bunch of refresh and find out I can jiggle the process by hitting the "Discover" button on the Z-Wave page. This fixes one switch so it gets past Initialziing but the others are still stuck.

So what is going on here? This is an awful regression from C5 that just worked at this point. I'm really worried that my low-ID main-powered devices are in a strange state since the mesh starts here.

Please advise. So tired of this...

You already know there are issues with pairing on the C-7 right now. There are 4-5 threads about this on the forum already.

Posting that you are having pairing issues, when many others have already posted that, and Hubitat has already acknowledged that they are working to resolve, seems non-productive.

Why don't you wait until the next update / future update comes out that fixes the pairing issues before proceeding?


Hi @JasonJoel
I must have missed this. Would you mind pointing me to the thread about this.

If I have time to search later I will post links. Until then you'll just have to take my word for it.

I'm pretty sure Bryan posted in the inovelli pairing thread multiple times though...

Fairly sure Mike posted somewhere too...


That's probably why I missed it. Don't have any of those. :wink:
Just seeing some strange issues with Fibaro devices. I'm gradually getting them working but state refresh is an issue and I'm bodging to get round it.
Thanks again.

1 Like

No worries. I do know they are actively working the S2 pairing issues.

Not sure if that will specifically help your fibaro problems though. I was reading through that thread earlier, and it wasn't obvious to me whether that would have been affected by the same issue or not.

Hopefully we will find out sooner rather than later though!


You get the S2 popup only when the device is S2-able. If you turn off the S2 options, you're left with S0 and that's actively discouraged since the C-3/C-4. Not news, in other words, because it's the one with 3x the packets and is one key per hub. So.. not so secure and not so nice on a mesh.

The answer is then, to turn off all the S2 popup options and join insecure.. aka 'normal' -- exactly like we've done on the C-3's-4's and 5's

It doesn't test the S2 feature if that's what you are looking for.. but for that, yea, @JasonJoel advice is correct... known, being worked on.


I don't know this. I searched for "C7 pairing S2 initialize" and some other things. An official C7 issues thread by HE would be cool.

I did, as I explained up top, and it hangs on Initialize. Hence this thread.

As explained up top, I just want to add my first four dimmers, unsecurely like before, without hanging on Initialize.


Ok, well not sure how you missed all the other threads on this topic. But that said, now you know.

I would suggest waiting until a fix is released before trying to pair more devices. No ETA on a fix yet from Hubitat.

Otherwise your alternative is to keep rebooting, excluding, rebooting, and trying to pair again until it pairs correctly - which often it will after enough tries.

There are a number of suggestions in the other pairing issue threads of sequence of events that worked better for some.

But there is no one set of directions that will make s2 pairing work for all right now. Thus the need for a fix from Hubitat.


The whole point of me purchasing and replacing a working C5 hub is to try to create a more stable mesh. Retrying and hoping for the best at the core of my mesh is counterproductive. I'll just wait for the public beta to end. Yes, I'm tired of this.

Good decision, in my opinion. Hopefully it will be 'soon'.

I wouldn't characterize it as that. They did not see this during testing, and it was discovered post-release. They didn't intentionally release it with a known pairing issue.

It is unfortunate that it didn't get discovered in testing before release though. It is definitely frustrating for those experiencing the issue (I did, luckily I only have a few S2 devices anyway).


I didn't interpret this as turning off the S0 option at the bottom as well. The top 3 are S2 (If I remember the popup correctly) and the bottom is S0. There's been discussion about S0 offered as a fallback for cascaded devices (associations). So it's usually selected in the popup.

If that's what you meant, then yea, sorry for misinterpreting. :slight_smile:

You're right, I was unclear, and I apologize.

I've tried leaving as-is, unchecking S2 authenticate, unchecking all S2, and unchecking all (no S2 or S0). Still hangs on initialize.

1 Like

That post is the definitive word on S2 coupled with S0.. so far. :slight_smile:


Good info but shouldn't unchecking all work though? No keys exchanged, no security used.

I have an Inovelli Red Dimmer that was the first device I tried to add to the C-7.

I never did get it to join even though Mike had the Inovelli Red Switch that worked. At that time, he didn't have the dimmer to test so I moved on. The Aeon Range Extender 7 joined S2 just fine. Other than the joy of trying something new, I can't see the point of a Range Extender on S2. I've since moved it too. :smiley:

I thought so too but all my S2 devices are otherwise occupied (aka Joined to my production system) and therefore I have no way to cause the popup. I have another Range Extender and Inovelli Switch due to arrive on Friday and I can watch via Zniffer.

Perhaps @bcopeland wants to clarify this, just like he did with Grants. :smiley:


Fair enough. Public beta is hyperbole. Really frustrating though to deal with all these Z-Wave issues for months on two C5, only to run into a simple pairing issue when upgrading to a C7. I'm a huge fan of HE still. Unlucky yes. Frustrated yes...


I get that - and don't disagree. Here's hoping you have better luck after the C-7 gets updated!

1 Like

I have asked for this (in a forum post I put in Getting Started, and directly via PM to HE support) but nothing has appeared yet. That is a mistake, IMHO, as it makes unfortunate 'adventures' like yours more likely. I get the frustration, you just don't expect something as basic as pairing a switch to have a significant problem.

I hope HE not putting up a post indicates they believe they are very, very close to releasing a fix. If not, I can't imagine why they would not put up an official post named/tagged to make it very obvious to find.


I know they saw this message, at least certain people did.

They have been diligently working on it, they have said as much in other threads. I will speculate that they are waiting until they are sure they have it fixed to post something.

There is nothing worse for all parties involved for them to say "it will be fixed tomorrow" or promise that it will be fixed and then something happens during testing and throws a "broomstick into the bicycle spokes" so to speak.

It might seem like an eternity, but it hasn't been all that long, less than a week. You never know the scale of what might be involved with this fix. It could be anything from a simple easy to fix typo, up to and including some flaw in a 3rd party source code.