C7 and S2 security

I am trying to figure out what is going on with my Hubitat C7 when I try to pair S2 enabled devices. My hub is on the latest version of the platform (

I have been adding a few S2 enabled devices to the mesh and all of them (GE Enbrighten Switches and Dimmers, ZooZ ZEN30, Honeywell Dimmers - made by Jasco) had the same issue during pairing. Basically the pairing seems to get locked in a state before showing the screen to choose the security level to use. At this point, I had to wait for the Z-Wave inclusion period to end (1 min) and then go to Setting/Z-Wave Details and I see an unknown device at the end of the list. In order to complete the pairing I have to press the 'Discover' button on that unknown device and put the device in pairing mode again and this time will go through but the pairing happens with no security. I tried the process with the hub in place or bringing the hub close to the device with no difference in behavior.

Now, I do have a device with S2 security that works as designed (it shows the security level screen during pairing) and let's me pair it at S2 level. This one is a Ring Extender Gen2.

I would love to be able to pair all my S2 enabled devices properly but as I said, there seems to be a glitch somewhere. I would appreciate your input on this.

First, I'd suggest, and many here will agree, that pairing light switches/dimmers, plugs, contact sensors, etc., with security is not really needed. I only pair barrier devices like locks and garage door openers w/security. Any extra overhead/complexity required by pairing w/S2 security just isn't worth it.

However, your pairing process should go as expected and the security dialog should appear for S2 capable devices. I'd try:

  • Shut down your hub (from Setting menu) and when you see the red light on the hub, pull the hub power (at the wall plug, not at the hub) and wait 30s and then plug it in again and wait for it to boot up.

Then you can try to pair one of your devices again. If the security dialog appears, and you're not paring a lock or garage door opener, I'd recommend uncheck all boxes so it looks like below and then hit OK, then OK on the next dialog. If you want to use security w/devices like switches that's your call of course.

I have had times when the security dialog times out (doesn't appear) when I've paired S2 devices, may be caused by mesh issues...you should be pairing mains powered devices before battery devices, and pair devices closest to the hub first, and then move outward. Rebooting every few devices can help.


I am of the opinion that pairing non-security devices S2 is of limited value.

That said, it is a red herring in this discussion. Pairing S2 is the DEFAULT pairing method for devices that support S2, and it needs to work basically 100% of the time - which it does not on this hub. To be fair, it works a lot. And works even more often if done right after a hub reboot. But not close to 100%.

I highly encourage people to report every time S2 pairing doesn't work. It is the only way it will continue to get attention, and hopefully get fixed someday.

Or at least get a fool proof workaround/set of steps that users can be pointed to that will make it work every time. For example, if users need to reboot the hub every time before attempting an S2 pair - they need to be told that.


I would suggest, if you really want secure S2 pairing, that you try using SmartStart through the mobile app. That’s the only reason I use the app, and it makes the pairing more automatic.


Does anything work 100% of the time on the C7 yet? :wink: Def still in the forming/storming stage....


Thanks for the tips about rebooting the hub. I actually did all that and more. I tried rebooting, shutting down etc. I also reset the devices multiple times in between attempt. It actually took me a while to discover how to actually pair the devices period. With the method I outlined in the initial post it works every time. But this is not cool honestly. I should be getting the dialog with the security level every time instead and it just does not happen. Things get foobar right before it.

From the Terms of Service:

c. Customer acknowledges that the Hubitat Platform is under continuous development, is not complete or otherwise at the final stage of development and that Hubitat makes no representation that the Hubitat Platform is error or bug free. Customer acknowledges and agrees that the Hubitat Platform may experience unscheduled downtime and agrees that Hubitat shall not be liable for any harm resulting from unscheduled downtime. Customer acknowledges that Hubitat has no obligation to provide support for the Customer's use of the product.

Surely you don’t expect it to work?


So if I was in your position, and still had more devices to pair, and was having trouble w/each device I try to pair, I'd sit it out for a couple of days to let your existing mesh settle in and adjust itself/routing as it sees fit. Z-Wave Plus devices should be able to do that best on their own.

No guarantees, but that might help reduce the mesh issues (which are likely driving the pairing issues) that are currently affecting you.

Also, I have had intermittent loss of the S2 dialog when pairing, and in some cases even though the device often showed up in my Z-Wave Details page and looked OK, it turned out to be a poor pairing and went south (taking my mesh w/it). Waiting while may also bring any issues like that to the fore.

I am embarrassed by my innocence and wide-eyed naivety. [Blush]


I did that too. What I described here has been going on over the last 2-3 weeks. Ike I said, it took a few attempts and time to figure out how to pair them period. Lots of trial and error.
My mesh has been pretty stable after the pairing. I do not have a lot of issues with it outside of the battery powered devices glitch that will be fixed in 2.2.5 from what I understand.
I can definitely wait a few more weeks and try again with one of them and see what happens.

OK, good, sounds like you've been taking the right steps overall. :slight_smile: If you aren't inconvenienced waiting a few days before restarting pairing should be more than enough, no need to wait weeks.

And you might try @672southmain's suggestion about using SmartStart to see if that makes a difference. I've actually never used it so have no experience w/it.

Good luck!

1 Like

Don't know what to say...

I've paired new GE Enbrighten dimmers w/S2 at least 30 times by now between my production and dev C7 hubs.

For me - I've seen exactly what you describe, but only maybe 2 times total. And I couldn't figure out how to make it happen on-demand, so it is pretty hard to report/reproduce as a bug.

If yours does it consistently you should definitely submit a support ticket or get a hold of @bcopeland and see if there is anything they can learn from it.


I will be glad to help with fixing this. In any case, I sent an email to support with the same contents as this thread. We will see what happens.


Does pairing a device without security have any effect on that device serving as a repeater for other devices paired with security?

Repeaters will forward all traffic regardless of security. Some repeaters, notably Ring Extenders, do require S2 to operate correctly.


Actually they will repeat fine without S2 inclusion, they just won’t report battery and mains status (from what I have read)

They are the only device other than my Alfred that I have paired as S2


That matches up w/what I remember seeing as well, from @bcopeland on those devices.

1 Like

I agree completely with disabling security on S2 devices that are not security devices.

Some S2 devices I've found do not always show that security dialogue when they should. I've been able to resolve the by excluding them (factory reset if they have it) and then power cycle <- important step!

If they have SmartStart, use that instead. You don't have to do anything but wait and then once they're available in the app, you can change the security level from there any time you want.


Huh?! I've never seen/been aware of this. Can you share a couple screen shots?

1 Like

I actually had a bunch of trouble out if a couple ring v2 contact sensors that dropped off. I tried to pair them back with no security I almost couldn't get them deleted to add them again with s2. I also had trouble with a zoos 25 plug. I paired it with the work around with no security and turning off reporting and still crashed my mesh.

Definitely need some s2 work.