C4 to C7 Zwave Woes

I finally completed the migration from C4 to C7 (latest firmware). What a process! I have about 100 devices (Lutron switches, Zigbee sensors, and Zwave plugs and switches) so the process was over a month and hours of pairing and long patch cables (side note, why the heck is the C7 not allowed to plugin to a POE port per their manual....that is annoying as all my switches are POE). My C4 was a rock star, but I wanted to upgrade as I was fearful of it crashing at some point and there is no backup for the radio, only the settings. I used the bravenel migration method (Migrating a Z-Wave Network).

I had to bring my hub to every zwave device to pair it. I never had to do this with the C4. I ended up getting a repeater to use to make the process easier.

I have no ghost devices in my hub and everything seems to be communicating, mostly.

Overall, I wish I stayed on the C4, but there is no going back now. The C4 had almost no issues. There are a few things I am hoping someone could give me some insight on:

  1. My Inovelli Red Series Dimmers are not performing well AT ALL. Yes they turn off and on, but the delay is unbearably slow. Dimming takes forever (I checked the dimming speed settings in the device already). Also, I use the notifications all the time and those are no longer working consistently. I removed and re-added these dimmers as I could not use the bravenel method above so these are newly paired. My first thought was to upgrade the firmware, however when going through this process (https://support.inovelli.com/portal/en/kb/articles/how-to-update-your-dimmer-switch-firmware-hubitat) I am unable to get them to update. It just says "Please wake up your sleepy device". The lights are on and working, so not sure how to get past that. Aside from this fixing the issue hopefully, could anything else be causing these Inovelli's to no longer work well on the C7

  2. This one I realize is a known issue, however my OG Schlage locks are just bad now on the new C7. States do not update and commands occasionally work. I gave up and ordered some newer Schlage Zigbee ones and one Zwave Plus version (sorry, I like the design so am sticking with Schlage) in hopes to fix this. I tried using repeaters to fix this, but the issue remains. I had the original locks that came out, so I am guessing the newer ones will hopefully work better.

  3. My Zigbee sensors (motion and water) throughout the house don't see to be reporting as well as they used to. I have a mix of Iris v1/v2. I use the Device Monitor app by erocm123 and they mostly show as "Not reporting events". This was never an issue on the C4. My Zigbee devices repaired well so not sure if there is some cleanup needed on the Zigbee side of things to get these working better.

Thanks in advance!

It is too late now, but there is no reason that you could not run both the C4 and C7 hubs at the same time. Many people use dual hubs. They might have their Z-wave devices on one hub and put Zigbee devices on another, for example.

It might take a few days or even a few weeks for your new mesh to settle down. The devices will try to find the most stable routes of communication to the hub and through any available repeaters. You have a lot of devices that have to adjust.

2 Likes

I have the same issue on my C7 - notifications will typically take the new value, but the “return to normal” is often ignored. Not sure why, but I do have a lot on my Z-Wave mesh and typically send the signal to update to all of them at once, so this may be the cause. (The app I use doesn’t add the option to have a delay unfortunately.)

On the C7, the re is a built in app “Device Firmware Updater” to update the firmware. You can give that a try to see if it works better. That said, my experience has been that it only works when the switches are paired with no security.

1 Like

I would also make sure nothing is paired at s0, especially if you have any zooz devices (4-in-1, and zen25 in particular). A lot of s0 will slow down and or crash your z-wave mesh. The only things I would pair with security are locks and garage... Can you do a screen shot of your z-wave settings page(s) for us?

4 Likes

I hope I'm not intruding here and hijacking the thread, but I have had a very similar story, only with much fewer Z-wave devices. Now my Z-wave is breaking down on a regular basis.

I do have some devices paired as S0 and was unaware this would cause an issue, but I did not choose how to pair them, nor would I know how to change that.

Here are my devices.

Summary

Summary

Summary

Take care with labeling S0 as 'defective' or 'broken'. It's not. What it does is triple the conversation size for any device using that security scheme. If you have a no-hop, 100k "mesh" (Mesh for zero hops is not accurate...) then triple the packets is probably not noticeable.

In my house, I have hops, I also have devices joined at 9.6k and 40k. (Not many, thankfully,) resulting in me choosing to reduce the number of S0 devices to a minimum. I also have Locks and a Garage Door Opener, which have a mandatory S0. I can't avoid those and because the Locks are FLIRS, I need a repeater in the vicinity.

Thus the advice is to eliminate S0 where you can. For a 'strained' mesh, with devices that are just barely in range, there will be retries. You don't want those to be delayed/timeout due to S0 traffic eating up all the bandwidth.

You hear this S0 advice in response to anything that sounds like a mesh issue. Along with equally sage advice to have well placed repeaters. :slight_smile:

4 Likes

Once I get my Hub working consistently, I am going to try to use a Group to get all my notifications together for what I need so I am not turning on/off the notification, but instead the group.

Thanks, I did re-pair a couple devices and they are now showing "none" for the security.

I posted a portion of this on the Inovelli thread and got a pretty detailed response on some possible fixes for the Inovelli issues. I am working through them currently....fingers crossed....

2 Likes

If you are on the original firmware and have power reporting disabled it could be flooding your network. There was a bug in the original firmware of the switches and dimmers and was fixed.

Scroll to the bottom for 1.41 as an example. It was fixed in a few of their switches

Just throwing that out there in case you did try to disable the power management. It hit me before and caused slowness on my network.

Thank you. I am on v1.35 of the firmware. I checked and I did not have this set at all so I believe mine is set to 10 currently which is the default.

1 Like

Upgrading the Inovelli firmware via the Hubitat app is at best hit or miss IME. An external Z-stick and PC Controller software is much more reliable and much faster.

1 Like

Unless you need power reported often, changing those to 99 would be a good idea. The periodic report time can be set to 32000.

1 Like

I just did the same migration last weekend, about the same mix of devices. Took me a couple days and I never moved the c7 through the whole process it stayed on the top shelf of my network closet. I even paired zwave and zigbee in my barn without moving it. Hardest part was moving the c4 around closer to exclude.

There will be a few dropped zigbee devices and missed zwave commands until the mesh settles down. Mine has now and is way quicker and increased reliability from the c4.

All my zwave switches are the older inovelli, and 2 zigbee schlage locks which are flawless (buy them)

I successfully updated the red series using the below method. I can't believe I spent a day messing with the Hubitat built-in utility. This was so much easier. The hardest part was finding the software!

Fingers crossed if this improves the performance!

2 Likes

Things are back to normal! It seems the firmware update fixed it. Now just need to get my locks working =)

4 Likes

Put a beaming repeater as close to the lock as you can get it...

1 Like

Any recommended products? I have the Aeotec v7 repeater, but it doesn't seem to help with those. I was curious also that since the Schlage locks are using S0 if the repeater is able to transmit those if it is not set to S0.

I second the recommendation on the repeater. A lot of communication goes on with the lock during the locking and unlocking processes. Thus, a reliable connection is required. I have a Schlage Z-wave lock that I never could get to work properly until I installed an Aeotec Z-wave range extender/repeater into the outlet closest to the lock. It sill only gets a 40kbps data rate, but the lock works.

The aeotec is a good repeater and will repeat s0 just fine. Put the repeater as close to the lock as possible then power down the lock (disconnect battery) Shutdown the hub from menu and disconnect power at the wall (not the hub) for 5 mins. Bring the hub back up. Plug the lock back in run a repair on just the repeater then just the lock. Then install the Reliable lock app from hubitat package manager.

Download the Hubitat app