C-7 setup: Stuck on Accepting TOS

Thanks for the suggestion. I have tried that too. Unfortunately the only firmware i get listed there is the original one that the hub came preinstalled with. And when i set it up this way and update it again asks me to accept the TOS and i get stuck.

When i go to the revert the version from the old/original firmware it only shows me the newest version available (which is very strange)

Also the tool at port 8081 is outdated in my unit, it’s 1.0.75 and i am unable to update it to latest version too. When i try to update it says that there i now new version (when ran on the old firmware) and it just sends me to accept the TOS on the new firmware

So i am begging you - please provide files and instructions on how to update this via a USB or UART connection as this seems to be the obvious working solution here

When you get to port 8081, what version does it show for the diagnostic tool?

1 Like


In your web browser go to http://your.hubs.ip.here/hub/cloud/updateDiagnosticTool endpoint to force diagnostics tool update. It will take a few minutes with zero feedback but will come back with a simple meaningful text response eventually. Just let the browser sit...

1 Like

Thank you! I have tried that too!
When i do it in the preinstalled (old) firmware it says:
"success": true,
"message": "No Update for Diagnostic Tool Available."

When i do it in the latest (new) firmware i am redirected to the accept TOS page again

Restore to the original platform version. If you get into the main screen, set up some virtual switches. Once you do that, then do the platform update.

1 Like

I have done that too - i added a virtual switch and set some parameters in it. An update after that sees to have no effect. Furthermore i read that a soft reset should just install a fresh copy of the database with settings and everything ( as i assume that a setting must be ticked off that the TOS have been accepted ) but that didn’t make any difference - both soft and full resets

As i said i have made quite a research on this forum and have tried everything suggested i could find but without success. It’s not like i’m just whining because i’m lazy and unwilling to try things. I just want to make the device work as intended

1 Like

Hubitat has never done that. The only way to update is through the UI.

BobbyD is the primary support contact. They don't have paid support, everyone receives the same level of support.

1 Like

I'm left wondering if the eBay seller sold you a hub that is defective. And if that is the case, your recourse would be to get an exchange/refund from them.

FWIW, there are official Hubitat resellers in Europe, including:

There may be others, but I know both of those sites have been used by many European users.

1 Like


Depending on your version of the Diagnostic Tool, this may work ....


I don't know if this works with 1.0.75. It does work with 1.0.97, but I don't know about earlier versions.

It is also possible that your hub has a bad/corrupt eMMC, in which case, none of our suggestions are worth a damn, because the only solution is a replacement. To be fair, in my 4+ years on the Hubitat community, I can recall only one other instance when the eMMC was corrupt.

1 Like

thank you for the replies and suggestions.

I don’t believe the unit is defective because on the original version it does save state to emmc i create devices and save settings - also the update process works to some extent - ie the firmware is downloaded and written to the partition.

i have just tried to open the suggested ip:8081/api/getLatest but unfortunately it shows ‘Not found’ on my version of the tool

If you send me your hub's MAC address I can try to see if the hub is connected to the cloud. That might be the problem (without cloud connection you cannot update the hub).

Got it, and removed your post, because MAC address is unique to your hub.


It's connected. What happens if you go to the hub's IP address directly?

that’s my home address and several machines are behind a router there. Please don’t post that publicly :joy:

1 Like

Oops, corrected it...

1 Like

when i open the ip of the hub i get this

when i click on agree i get redirected back to here with an error in the javascript console of the browser stating that a regular expression does not match anything

Can you do it from a PC?


Can you use a different device to access the hub, like a desktop? What mobile device are you currently using and what browser?

1 Like