C-7 setup: Stuck on Accepting TOS

I just purchased my Hubitat C-7 and am having troubles setting it up.
I connect it to my network, login via the IP and see a notification that there is a firmware update.

The version proposed is 2.3.5.146. I install the update and after the hub reboots i am presented with a Terms of service screen. I am unable to go past through it - when i click the Accept button nothing happens and i am redirected back to that screen.

I searched the forums and found a user with the same issue on a prior version of the firmware. The topic there did not propose a solution - they just received update and the bug was not present there (its an old version - i think 2.3.4.119 or similar).

Does anyone have a working solution of that problem? Its very frustrating because i have waited for this hub to arrive about 40 days and am unable to get it to work.

I have tried full reset and it didnt help at all.

@gopher.ny @bobbyD - i see in other topics that you seem to be resolving most of the issues. Could you please help with this one?

Hub version before update was 2.2.4.158

Some more info, that might help:
When i click the button and open my browser console i see the following javascript error:

Unhandled Promise Rejection: SyntaxError: The string did not match the expected pattern.

Have you tried a different browser?

Yes i have tried both Safari and Chrome on a Mac, as well as Edge on windows - same behavior on all of them.

go to yourhubip/hub/edit and start filling in stuff and see if it stops doing that

That doesnt help too. No matter what URL i enter (be it IP/hub/edit, IP/hub/acceptTOS, or anything else) i am always being redirected to IP/hub/termsOfService and presented with the same screen. I have tried soft and full resetting the hub using the diagnostic tool with no luck.

@gopher.ny This is up your alley

Has none had such problems when updating? This is very frustrating - i practically can’t use this black plastic bo for anything at the moment - except for admiring the glowing green LED on it..

@bobbyD

can you try this in your browser?
http://myHubIpAddress/hub/acceptTOS

I have tried it. Unfortunately it just redirects me back to the IP/hub/termsOfService page

Have you tried it using an "incognito" browser window? By it, I mean the URL linked to by @mike.maxwell ( http://myHubIpAddress/hub/acceptTOS ), replacing myHubIpAddress with the actual IP address of your hubitat.

Yes! I thought it might be related to cookies so i tried the whole setup process in incognito mode without success. The result is the same!

I have then tried to run the setup via the hubitat app on iOS - absolutely the same result. When i find the hub and click the accept TOS checkbox and click Claim button - nothing happens.

I work at the web dev field so i have tried pretty much everything that a user can do in order to overcome this bug without messing with firmware.

What is even more frustrating is that no one from the hubitat team seems to show the slightest interest in that problem. The issue here is now 4 days old a nothing. I have emailed them at support@hubitat.com also 4 days ago - no reply, not even an auto reply. I’m really sorry but that’s just not how you place your product on the market :disappointed:

I don't think that email works, that changed a long while ago, probably a year now. Everything is now handled through the https://support.hubitat.com portal, or getting direct assistance on this forum.

I see Mike Maxwell responded to you, and both BobbyD and GopherNY were tagged earlier in this thread. I am certain one of these staff members will follow up with you shortly.

2 Likes

We have not sold hubs with platform version running 2.2.4 update since December 2020. We usually perform regression testing for versions up to a year old, sometimes 2 years. Have you purchased your hub as used? If you continue to have problems, I suggest returning it, and purchase a newer hub that is running a more recent platform version.

1 Like

@bobbyD you are kidding, right?

I have purchased the hub as an ‘open, never used’ from ebay. And i can clearly see that it matched the description. Everything was min in the box. I have waited for that thing to arrive in europe for 40 days and your best advice is to return it? I’m sorry but this is not an option for me!

The device wants to update to the latest firmware - which it does - it downloads the firmware and installs it. Furthermore the C-7 officially supports this firmware - it’s not a hardware limitation that prevents the hub from working!

I am open to undergo a procedure as complicated as requires - even uploading firmware from UART if needed, but returning it is simply not an option!!

Please direct me to someone that can help with this issue - someone capable of providing real tech support - do i have to pay extra for tech support? At that point i am willing to, because otherwise i just have to throw this thing away and continue using homebridge - which is something that i don’t want to do!

I just can’t believe that i saw so many youtube videos where people were so pleased with the device and especially with the support they received and all i am getting i ‘return it and buy a new one’. This is just not acceptable!

It could have been "new" meaning it was never open, but it was from 2020

Ok but that doesn’t make it incompatible?

I understand that the firmware is old and not tested - Ok - send me a year old firmware that i can upload then, and update from that one? That should be an option and a working option for sure

Can you go to yourhubip:8081 and roll back the firmware to it's first version. Boot up and see if you can then accept the tos and get to the main screen. Pick what ever is oldest.

1 Like