C-7 and S0

Thanks, @bcopeland.

So is it advised to include the S0 option when parining an S2 device "just in case" so that it can communicate directly w/S0 devices?

1 Like

It doesnโ€™t hurt.. The majority of device communication will be from / to the hub which will always be on the highest granted key and tech

@mike.maxwell or @bcopeland, can you explain the differences between the different types of s2 and what you might use which device:



If this pops up during inclusion it means the device supports S2 security, and can use any of the checked security classes.
Access control is for doors.
Authenticated requires you to supply the dsk (the underlined part of the tupple supplied with the product), unauthenticated does not.
Security 0 is the old encryption and should be avoided.
Class 1 and class 2 use the same level of encryption just different keys, this allows both to be in use within the same network.

When multiple are offered and selected, they are used from the top down.


I have several light bulbs and z-wave sensors that have paired at S0. Is there a way to get them to pair at none?

I thought that maybe I could just unpair them from another hub and then re-pair them and I would not select S0 as an option, but apparently, it is not popping up for just S0, leaving me to wonder what to do next...

Since I have moved from my C-5 to my new C-7, my Z-wave mesh is having lots of issues, and I suspect the 14 S0 devices are a good part of the issue. I had 0 issues on my C-5 prior to migrating...

If S0 is the max security supported, then no you can't do anything from the hub to pair then unsecure.

If you have a secondary controller paired to it, you can pair it from the secondary non-secure though with the pc controller software.

1 Like

Thanks @JasonJoel. I have a z-wave stick on order, so I will have to wait for it to arrive.

Until then, I will endure my erratic mesh...

1 Like

Working on something that I hope will tame S0 a bit, will be in a short beta run tomorrow hopefully.


Awesome! Thanks @bcopeland. I love how responsive the whole Hubitat team is. :smiley:

Your hard work is really, very much appreciated!

1 Like

I'd love to hear recommendations on how best to pair devices using Security: None.

I received my UZB stick and now I want to pair some devices to Security: None instead of S0.
With the "Z-Wave PC Controller" software, I can pair the device using the "Add" button and it gets added to the mesh. I can then add its node ID to the existing device and control it via Hubitat.

However, when I go to Hubitat's Z-Wave Details screen, I do not see the device in the list.

I'm certain that I must be doing something wrong... I have very limited Z-Wave knowledge... Enough to be dangerous...

Also... I see in "Z-Wave PC Controller" an option to change the "Security Scheme". I can make the change in the software, but it still says "S0" in Hubitat under "Z-Wave Details"... So in my mind, it didn't work... I don't know how to confirm if it did...

So I wish I had a better answer but I paired the device through the PC Controller software and then on the Z-Wave details page did some combination of discover/refresh/repair also a reboot and it came up. I've done this with 3 Aeotec recessed door sensors so far.

1 Like

Thanks! Sounds a lot like what I do most of the time. Interestingly enough, I was trying to see if I could just change one of my bulbs from S0 to None and it would magically take... And the bulb that I had added with "Z-Wave PC Controller" appeared in the list! Just like magic!

No, you donโ€™t pair the device to the USB stick first. Think about it, that puts the device on a different Z-Wave network from the Hubitat hub.

Search the forums. Itโ€™s been a while since I did it, but, as I recall, the trick is to add the USB stick as a secondary controller to the Hubitat, that puts the USB stick on the same network. Then, pair the device to the secondary controller (USB stick) as none, that puts it as none on the Hubitat Z-wave network.


I forgot to mention that... Yes, that was the first thing that I did. :slight_smile:

Thanks! I was finding that doing that didn't add it to my Z-Wave Details list, but after a little while, it showed up. So it seems that problem fixed itself somehow... And it has Security: None! Yay!!!

1 Like

Great! And glad to see, from another thread, that you successfully passed the initiation rite of deleting a ghost node using a USB stick. You are now a master with great powers. With that comes great responsibility.


Haha! Yes indeed! I banished the ghost! Now I am expecting that everything will work perfectly! :wink: Until I break something...


Remember to exclude the USB stick before you shut it down. Otherwise, you are creating another problem node.


I read in one of the threads that I could just disable it in the device view... Can anyone confirm that this will work?

I would rather not create a new ghost!!!

I went the exclude route. My fear with just disabling it is that there could be a hub database floating around without that USB stick device disabled. Exclude and include happen in the Z-Wave radio and are also tracked in the database. I believe that merely disabling the device leaves it included in the radio. Bryan Copeland (@bcopeland) might be the best one to answer this point.


that's what I did, disable, no ill effects yet in several weeks

1 Like