Cannot include z-wave devices. Help!

Newb moving from Wink to HE here. Everything was going fine at first. I excluded my devices on Wink. Included them on HE. I was able to add multiple Leviton Z-Wave switches and dimmers and a GE fan controller without a problem. Now, all the sudden the HE won't include any additional Z-Wave devices. Sometimes it just times out, and other times it starts the inclusion process and just hangs with an "Found Z-Wave Device with id ##. Initiating". I've restarted the hub multiple times, updated the software, reset the switches back to factory default. I've tried everything that I've seen mentioned on the boards.

On the Z-Wave Details page, I see five devices listed with no given name that show as either "NOT_REPSONDING" or "FAILED". Clicking on refresh, or repair does not seem to do anything. One device has a Remove option but that does not seem to do anything either. I've got screen shots, but not sure how to post them here.

Any suggestions?

Have you shut down the hub. That usually fixes it.

This doesn't sound good. Rule of thumb with z-wave please please please get one thing working at a time. If it doesn't work don't start a new thing, take a break and come back to MAKE it work. Never factory reset the device if there is ANY chance that it MIGHT be joined, your make a rod for you own back if you do. If it not working try a shutdown, power down and repower. Then excluded the device again, confirm that it has been excluded in the logs. Then and only then you can try the factory reset of the device again if needed. If the devices are z-wave remember that they may need to be joined next too the hub. If there z-wave plus and you have other z-wave plus devices already joined you join them in place.

This is exactly what the above would have avoided, you now have ghost devices stuck in limbo.

Do the shut down (disconnect the power for 2-3 mins once it's shutdown) turn it back on and go too that page and screen shot it.

1 Like

Update: I've tried every suggestion from this forum and the Reddit HE forum. I've done everything that @bobbyD has recommended. Reset the hub multiple times; waited patiently. Removed polling. Software is current. Still, I cannot add any additional Z-Wave devices to my network beyond the first 20 devices. All my nodes are Z-Wave Plus, no more than 25' from the hub and no more than 10' from another node. I just tried to add a Leviton Smart outlet (3' from the hub) after successfully removing it from Wink, but the HE7 never saw it. Hub froze up again and had to be reset.

I do seem to have some ghost devices which show up on the Z-Wave Details page (see screen shot). I'm not sure if this is the problem or not.

I'm at my whit's end. Is there a way to nuc the hub and start all over? Do I need to replace it? @chuck.schwer @mike.maxwell

Ghost devices are always a problem. Your hub likely won't work 100% correctly until you are able to get those removed.

1 Like

I noticed one of your devices says S2. I'm assuming that's the security level. Have you tried including your switches at Security Level 0?

OK. How do I remove them?

@mebejedi I'm not sure what the difference is or how I would even change it.

When you include the switch, there might be a pop-up with 4-5 checkboxes. Security Level S2 is usually checked (depending on device). If it does come up, uncheck the S2 and check S0.

If the device isn't recognized after that, turn off Z-wave discovery, wait a few seconds, turn it on again, and set the switch for discovery again. (On my Zooz, that meant pushing the switch up 3 times.) You might consider doing this to all your switches.

This is bad advice and will slow down your network. S0 requires 3 times the traffic, and is an older protocol.

Here is from Mike Maxwell in another thread:

Sounds like you want no authentication (uncheck all).

1 Like

As @672southmain said don't do this, this is incorrect and will cause you more issues. If the device can join with S2 you should let it. It's if they join with S1 that is a problem as it's much more data.

Your issues are your ghosts, usually because you have rushed and not completed a join.

That's the issue you actually have joined more there the ghosts. In the situation of the ghost you can click discover then click the device but you need to know which device it is. Obviously because you have more than one ghost you can struggle here. The only real solution is to get them removed and start again on them device's. Do you have a spare z-wave stick?

The S2 must be a lock or something like it.

Actually, that's what I meant to say... Trying to recall from memory. I have a Zooz switch and Version 1 Inovelli switch that only join like this. (In fact, the Inovelli joins as a "keyWe Z-Wave Lock" with any authentification). I just figured it was worth a try to see if it would work.

@BorrisTheCat, what do you mean by "spare z-wave stick"?

When you shut down the hub, have you then removed the power to the hub for 1 minute, then powered back up.
This will cause the zwave radio to reboot.
This has worked for me in the past.

@bobbles Yes, I have powered down and waited a few minutes many times. It doesn't help. Thanks for the suggestion though.

1 Like

Literally that do you have a another z-wave device? I have a hubitat C4 so I used the USB stick from that. If you have a z-wave usb device you can join it as a secondary controller and get access to more advanced features that can be used to remove the incorrect devices.

Well... I have my Wink Hub, but I assume that is not what you mean. What kind of USB device do you recommend?

Wouldn't have a clue I just used the HE one and upgraded it :slight_smile: . There is a thread here somewhere that talks about it and the ones they use. See if you can find it, if not I'll try and find it.

Unlikely that they have advanced z-wave tools on that?

I guess what I'm hearing is that Hubitat used to offer a USB stick? I just have the standard HE C-7 freestanding hub. That appears to be all they offer now.

There are several, search these forums for USB Stick, you will see complete instructions for using.

Here is one (I have the SI Labs one):

Here is another: