C-5 to C-8 hub migration failure "Internal error occured while restoring backup"

I am having the same problem today. I tried to roll back to 2.3.5, But got a message it failed. I also tried to do a local back up. It also failed.

A local backup failure is not part of the issue, so it sounds like you have something else besides just this known issue going on.

I would try to shut down the hub and power off for 10+ seconds then reboot.
Try doing a regular local backup again.

1 Like

Hello @bobbyD can you please let me know if this issue is fixed in 2.3.7 ?
I tried to migrate yesterday from C5 to C8 and I'm getting the "Internal error" issue when migrating on the C8.

Thanks in advance for your help.

@erwan.dano 2.3.7 Fixed the issue for me. Both your C5 and C8 are on 2.3.7?

Yes, both Hub are running latest available version

Hello @bobbyD

Can you please let me know if fix deployed with 2.3.7 is solving the migration issue ?
If so, how can I get support facing this "Internal error" when migrating from C5 to C8 ?

Thanks for your help

Yes the migration issues were supposed to be fixed in 2.3.7

Do you have both the Zigbee and Z-Wave radios enabled on both the C5 and C8? I think if the radios are shut off it can cause issues with the migration.

When you take the backup on the C5 do you get any sort of backup errors?

If you are not getting sufficient support here you could put in a warranty claim on their support site: https://support.hubitat.com/

Thanks @jtp10181
Old C5 is turned off during the migration
New C8 is out of the box (or soft reset).
I'm always getting the same "Internal Error" message when migrating from cloud backup.
I'm Hub Protect + Remote admin subscriber
I've logged a ticket to Hubitat team on Support site

You did not answer any of my questions. Are the Zigbee and Z-Wave radios enabled on the C5 before you took the cloud backup? Not the hub itself being on, but in the details pages for both Zigbee and Z-wave, the radios need to be enabled even if you are not using them.

When you take a cloud backup on the C5 do you get any errors?

Also, are both hubs updated to 2.3.7 platform? I think it is most important for the C5 to be updated, since the issue that got fixed was occurring during the backup (leading to an error on the restore).

I understand the "Internal error" comes from the C8 when trying to load the backup, but this may be due to a bad backup from the C5 to begin with.

Oups sorry, Will try to answer all questions:

  • Both Zwave and Zigbee are activated when taking backup (I'm using both)
  • No error reported when taking the C5 back up
  • Both hubs are

Ok well that basically just confirms that I am out of ideas then. You will have to see what the devs think about it.