C-5 to C-8 hub migration failure "Internal error occured while restoring backup"

Thanks. I'll give that a try when I get another chance to play with it.

Thanks, that worked for me. Migration completed and all zigbee and zwave devices appear to be working.

Do I have to downgrade the C8 firmware as well? I downgraded the C5 and created a new migration file, but the C8 keeps starting up on 2.3.6. It does accept and complete the migration, but none of the devices respond.

I only downgraded the C-5, however my C-8 was on when I did the migration.

The firmware is separate from the backup, so yes it should be fine if the C8 is on the latest firmware. Did you do a cloud migration backup and have Zwave and Zigbee selected when doing the restore? Check your Zwave and Zigbee details pages, did the devices load in there? A local backup will not restore the radio data, has to be a cloud backup (hub protect or free migration backup).

1 Like

Yeah I used the C5-C8 cloud migration option from within the C5. I did not specifically check the details of the radios, I simply went to the devices and tried to see if any would respond.

Let me try again. I did soft reset the C8 and it did ask me to upgrade the firmware, but I backed up from that option and selected the migration option. It's entirely possible I missed or borked some step, but it did migrate instead of giving the error that it had been, so there's that.

Alrighty, success! Either I just didn't wait long enough for things to settle down so devices would respond or it was just simply trying the migration again. Either way, the migration to C8 is complete and everything, as far as I can tell, is working as expected. The firmware downgrade on the C5 side appears to be a valid work around.

The ZWave topology map is pretty dang cool too!

I'll give it a few days to make sure there are no surprises and then power the C5 back up and wipe it clean.

Check your Zigbee devices out, those have a higher chance of being problematic vs Zwave. Good thing if they did not carry over you can just include them again and they will drop into place.

For C5 make sure the first thing you do when ready, is to reset both radios, then do soft reset.

Details at the bottom of the docs:

1 Like

I only have one zigbee device (contact sensor) and it was listed under the devices and zigbee details.

Thank you for the link as well, I forgot about resetting the radios.

Thanks for this tip, just downgraded my C8 to 2.3.5 and successfully completed the migration off my C5. Thanks for making this migration so effortless, so what if we had to jump a hurdle just the ease of this platform keeps me hooked.

I finally got a chance to downgrade and migrate. Everything is working well (Zwave, ZigBee, all rules and apps including the API to connect with Home Assistant).

Just to see if it would work, I didn't remove any custom device drivers, I didn't deactivate any apps and I only downgraded the C5 to (the C8 is running 2.3.6). For me it wasn't necessary to downgrade both to migrate.

Thanks for your help @jtp10181 !

Far from a smooth migration process but I appreciate the support from the community.

Update: I wrote this too soon, multiple zigbee devices worked immediately after migration but dropped off shortly afterwards. Specifically some Hue motion sensors and Aqara contact sensors. Interestingly, some Hue motion sensors and Aqara contact sensors are working fine others reported a couple of times after migration then dropped off....These were rock solid on the C5. I've rebooted the Zigbee radio and will go around and repair everything when I get some time.


I downgraded to platform that was stored on my C-5 and the "Internal error occurred".
so mark one down for the downgrade migration FAIL column using a downgraded platform on a C-5 method.

C-8 came with 2.3.6. I'll try downgrading the C8 next so both are on 2.3.5 and retry.

update: I downgraded the C-8 now—> Migration succeeded this time. So seems the problem is with the C-8 running 2.3.6 as well.

1 Like

I downgraded tonight to 2.3.5, didn't disable any apps, backed up to cloud, clicked the migrate on the c-8 and was successful. Thanks everyone for making this happen.


Sorry that only the C5 downgrade didn't work for you @alex1. I wonder if the version of 2.3.5 is important? I downgraded my C5 to and I noticed that you started from Hopefully, a new version of 2.3.6 will be released soon to avoid this issue!

1 Like

Yes, we have identified the root cause and a fix for this is being released in the next 2.3.7 update.


The fix has been released to the beta channel. If you'd like early access, please join the Beta Group .

1 Like

great! congrats team!

It might be possible that vs may make a difference. However, it's also possible that the downgrade of the C-8 from—> fixed something as well. Sounds like the root cause was found, maybe we will get a hint of the root cause in the release notes for 2.3.7.

I can tell you the root cause if you'd like. The cloud backup process for C-5 post 2.3.5 is broken for Z-Wave and the C-8 restore notification pre 2.3.7 is misleading. The "internal error" should say partial restore completed. Both have been fixed in the latest release.


thanks for sharing! Glad the team figured it out. Onwards!

1 Like