C-5 Hub frequently dropping off network

Hi, I need some help debugging why my hub frequently freezes and becomes unreachable on my network.

The hub crashes seemingly randomly, sometimes staying up for a few weeks and other times just days. When it's crashed, the device has the green light on but does not respond over the network, not even the diagnostic page. The only thing I can do is pull the power to reboot, then it works for a random period of time until it crashes again.

I have removed all automations and custom code/apps, and the only thing I have active are a few z-wave light/fan switches and the google integration.

Things I have tried:

  • Updating hub firmware. Currently on, but it's been problematic since at least
  • Update router firmware. Tried Netgear firmware and FreshTomato.
  • Soft reset and restore from backups
  • Swap out different ethernet cables, usb cables, and power supplies
  • Connect to different ethernet ports: on the router and going through a switch
  • Connect to different power sources: UPS battery backup, UPS surge only, and wall
  • Set the hub's Networking "Ethernet speed" setting to fixed 100mbps
  • Set the hub's Networking "Auto reconnect" setting to 300s
  • Holding down the hidden reset button on the bottom of the hub when it's crashed. The hub's LED color stays green.
  • Change DHCP lease time to infinite

Current setup:

  • Netgear R7000 router running FreshTomato 2023.2
  • Hubitat C-5 hub on
  • Hub directly connected to the router's ethernet ports
  • Hub setup with a DHCP reservation
  • Hub's "Ethernet speed" set to auto
  • Hub's "Auto reconnect" set to 300s

I'm completely out of ideas and would love to figure this out.

Set the hubs Ethernet speed back to auto.

Do you have anything on the network with jumbo frames enabled. Your symptoms seem to suggest this may be your issue.

The reset button gets held for 7 seconds. That is the network reset button and simply clears all the network settings and resets it back to dhcp

Before pulling power, try to unplug the ethernet connection and plug back in. Mine does something similar but can't pin it down to anything and its so random I gave up hunting it down. But I can unplug the ethernet and plug in and its all back to normal for some random undetermined amount of time


The hub's ethernet speed has been set back auto for the past few crashes.

I've checked both my routers (one in AP mode) and they're not set to use jumbo frames. None of my computers have it on either. Is there a suggested way to find if any devices are sending large frames over the network?

I've also tried manually reconnecting the ethernet cable while it was crashed yesterday and it didn't seem to help. Though I suspect something like that (rebooting my router) did bring a dead hub back to life once, but I haven't been able to reproduce that fix. Though I'd hardly call that a viable long-term fix.

What does this mean? The same power adapter plugged into 3 different power sources? Have you tried a different power adapter?

What does this mean? The LED is off, or it’s always the same color - red, blue, green, whatever?

I've tried connecting the same power adapter to three different power sources and it's crashed on all of them. I've also tried a different power adapter on those same sources and it didn't stop the crashing.

The LED always stays green when it's dead. Holding down the reset button did not reboot the hub and stayed green. I know that button is for resetting the network IP settings, but the documentation states it would also reboot the device so I gave it a shot.

It does?

It sure does, though I didn't verify if the behavior is different for the different hub revisions.

... turn the hub over and use the point of a pen to press the small button just beneath the surface of the hub casing for at least 7 seconds.
The LED on the front of the hub will blink, then the hub will reboot (at which point the LED will turn blue as part of the normal boot process before again turning green once the hub has fully booted).

1 Like

Do you have jumbo frames enabled anywhere on your network?

That means it's still up and running. Or at least the platform is. When this happens can you use a web browser to go to yourhubip:8081 ?

The hub is completely inaccessible when I get this issue. No response on 8081, no ping replies, and shows up as offline in my router's devices list.

FYI it died on me again overnight, after it renewed its IP at around 3am.

What @rlithgow1 said. Jumbo ethernet frames (sizes larger than 1518 bytes) are known to knock the hub's network interface offline.

I do not have jumbo frames enabled on my network

Hmm - try a soft reset with a database restore. Corrupted databases are also known to cause the hub to hang.

When the hub's LED is green, and it is inaccessible, do automations still run? Meaning if you activate a motion sensor or change the status of a contact sensor, does a z-wave/zigbee switch turn on/off?

I've done soft reset and restore multiple times (every time I have to pull power because of this issue) and it still crashes.

I don't believe automations run when it dies. I first noticed this issue when lights I had set to turn on/off based on time wasn't working.

When it locks up can you get to port 8081?

No I can not access the hub on port 8081

Maybe it's your router DHCP Lease Time. If it's on the set no time limit or turn it off for your Hubitat. I did have this problem with my C5 a while back.

1 Like

Thanks for the suggestion, I'll give it a try.

Though my previous message about it dying after renewing IP could have been misconstrued as it dying immediately after the renewal - I just don't have any logs (in my router or the hub) beyond that point to know exactly when it went offline.

Oh, another important data point to mention is that when the hub dies like this, it even fails to perform its nightly backup. That makes me think that the whole hub is frozen, not just its network interface.

That's a good data point. My hub usually run out of memory when I don't have network connection after a day or two because I have quite a few apps needed network connection. I am guessing because of the amount of logs generated. Doesn't mean this is also your case. Just throwing it out there and hoping it could help.