Button Controller not letting me create an Action

When trying to create a new Button Controller (or edit it), when I click new Action it doesn't let me actually do anything. Just brings up an empty Delete Action box. Is it broken or how do I add an action?

It may be broken and you will have to delete and start over.

However, you can try selecting keep sorted and then deselect keep sorted. Sometimes changing that setting has worked for me.

I tried deleting and starting over. Tried Deleting the entire Button Controller app and starting over. Tried changing Keep Sorted. Tried different buttons. Tried 3 different browsers. Still same thing. No matter what I do, I cannot actually define an action. There is no drop down for available actions.

I will ask something maybe not quite obvious. But do you have devices to act upon? For example, I have a couple buttons on my test hub, but no switches or other items that can be controlled. I get the same behavior as you do.

You also could try this in Rule Machine, it has a built-in button controller, but not quite as easy as the dedicated button controller app.

The other advice I give with Button Controller is that you should try the community based Advanced Button Controller. It is much nicer and easier to use. Maybe see if that works for you?

I do have a bunch of switches and lights to act upon.

Go to "Devices" in the admin UI and find this button device there, then click into its page. Look in the upper right (or top-ish on mobile) and look under "Current States." You should see something like "numberOfButtons: 4" (or some number, but crucially "numberOfButtons" with some value). If you don't, you'll need to figure out a way to get that there. "Configure" or "Save Preferences" may do this for some devices if it didn't happen on installation for some reason, though this will depend on what kind of device this really is. If this isn't there, Button Controller (and many other apps) will not work well with the device.

If you change the device type to Generic Z-Wave Plus Button Controller, this will allow you to set the number of buttons. Then change it back to the correct device type.
I did this and still no luck. I think the code is broken. Who is the author?

Did any of that result in "numberOfButtons" appearing under "Current States" on the device page? @bravenel wrote this app and might have more ideas, but this is the most common problem I've seen in the forums.

Is your Upstairs Hallway Switch a switch or a button device?

Button Device. I've tried all my other button devices and same thing.

Yes, changing it to a Generic Z-Wave Plus Button Controller allows you to set the number of buttons. numberOfButtons now shows up with the number I specified and stays there even after I changed it back to a different device type.

What brand and model of device is this, and what driver are you using for it now?

The particular device shown in image above is a Cooper RF9500. However this is an issue with all of my buttons. I have 2 Iris Button Controllers, 2 Aeon Minimotes, a Fan switch, and a virtual button controller. I have tried all of them and none work.

Download the Hubitat app