Button controller app bug?

I created a button controller rule that initiates a bedtime routine.
The rule is supposed to turn of the main light (_HB_Lotte Plafond), and turn on a night light at 10% (_HB_Lotte balon) and dim that light to 0% over 15 minutes. When initiating the rule, it should send me a message on my phone.

What I see is that if I push the button, I get three messages, the main light goes off, but the nightlight does not go to 10%. Instead it remains at current lvl, and starts dimming by 1% every 10 seconds.

In the logging, I'm seeing an java error:

Environment: Both lights are HUE lights, controled by CoCoHue. the button used is an Ikea shortcut button.

When I manually give the dimmer command on the nightlight to fade, it works as expected, without any errors.

Is this a bug, or am I doing something wrong?

What do you see in the events for the Ikea button? (Obviously this only relates to the 3 runs of the rule)

I see three pressed events on one physical push.

edit : Note, if I delete this button rule, the events of the button is displaying one pushed event on a physical push again.

That sounds like part of the issue, what driver are you using?

Interesting about the impact of the rule.


Hmm, When i push the "run actions" button in the rule itself, it seems to work as expected.
So it must be something with the button, or the driver.

That would make some sense given the three triggers of the rule. The setLevel error would still need to some investigation though.

Is there any debug logging available for the device?

You may also want to look at the Zigbee Details page for the number of messages from the device, to see if it is the device sending 3 or something else in the driver.

Think its the driver somehow.
Replaced the button with another Ikea shortcut button, same issue.
Replaced the button with another brand button, issue is gone.

Strange... There doesn't appear to be any duplicate events in the code, at least that I can see... certainly no expert...

Ordered a new shortcut button. When it arives i'll test it to see if it is the button or the code.

I thought you said:

Wouldn't the new one behave the same?

The buttons I have are the same age, same FW version. (about two years old)
So I’m hoping the new button will work.

Ah, got it. I know with some of the other Ikea stuff the firmware version was important for some of the community drivers, so hopefully it is something like that here.

Still, weird for it to only report one event when not included in a rule....

Have you tried updating the firmware? Also, there was discusion over the multitap issue on the driver thread as well (specifically for the 4 button press events from a single press). It turned out to be a Strybar and not an E1812. But, the issue was resovled with firmware if I recall. In the firmware release notes, they aren't too descriptive. Just "stability improvements"

Firmware Updates for Ikea
[GUIDE] IKEA Firmware Updates?

Start of multi-events registered on the driver page:
[RELEASE] IKEA Zigbee drivers - #298 by jasonbalsor?

Firmware release notes (Ikea)

1 Like

Have tried firmware updates with Hubitat multiple times. So far, it is a big no-go.

Just checking, as a few users had issues updating. Did you try changing the divide driver for the updates?
I had no issues with mine using the Ikea driver (once I realized the update takes a really long time to update). But, most had to switch to the "device" driver to run the update. Also, as I recall, the second biggest issue was walking the device up then IMMEDIATELY clicking the update button while the device is close to the hub.

I want to say it took something like ten minutes before the logs showed that the update was starting. You might try posting on that firmware thread. The developer is pretty darn responsive to those with questions.

Got the new ikea button in today. Works like a charm.
So I guess there is something wrong with the old button.