[BUG REPORT] Clock sync not working on Honeywell T6 Pro

I have six of these and clock sync worked at one point.

I did a several hour maintenance on the boiler earlier in the year (all six are powered by the boiler) and I have not been able to get the clocks to sync from the hub since. Due to travel and other priorities I have not been able to dig into this until now.

When this first happened, I was using a C-7, I've since updated to a C-8 (in March) with the same result. I'm currently running,

Using the Advanced Honeywell T6 driver I can hit the syncClock button and see a transmission

and see a scheduled job to sync the clock

however the clock never updates.

Using the built-in Generic Component Thermostat I also see the pending syncClock job, but the time never updates.

On another thermostat that just tried to set the clock (this one is using the Advanced driver):




Might try hitting Configure followed by Save Preferences…

I tried that then and again now. No change to the clocks.