[Bug] Mode Manager -- Set mode based on earlier of two times is failing

In Mode Manager, I have the Evening set like this:


Sunset tonight was 4:45pm, (confirmed on the Location page)

But the mode did NOT change at 4:15, as it should have. It changed at 5:00pm.

Others have reported issues with Sunset-30 as well in other threads. I also had my outdoor lights fail to come on tonight at Sunset-30 in Simple Lighting. I believe @bravenel is investigating this issue. My guess is the time change caused the failures.

FWIW, this happened today (Monday), the day after daylight savings stopped.

Could you take a screenshot of the app detail page for Mode Manager, capturing the part where it shows Scheduled Jobs.


Sure thing!


If it helps, here are my scheduled mode changes...

Is 4:15 sunset - 30 minutes? Appears to be scheduled for each of the times you specified.

Yes, sunset is 4:45 tonight. I would expect to see Evening triggered at 4:15pm (beating out 5:00pm) and Night triggered at the actual sunset time (4:45pm)

Let me know if that happens or not as expected today.

1 Like

Yep, I had a switch to Evening happen at both Sunset-30 and 5:00pm, not the earlier of the two. Night happened at sunset as programmed.

So net net, it changed modes as you wanted? I will have to look into that "earlier" of two issue, because it doesn't know a priori which is earlier. It should set a flag or something so the second one doesn't happen, although I suppose it's harmless.

The rule is specifically asking for it twice, shouldn't that be fulfilled? :slight_smile:

No, it isn't, and it isn't a rule. It says it will change the mode on the earlier of two times, not upon two different times.

1 Like

Not as I wanted. The mode change resulted as Day --> Evening --> Night --> Evening

For now, I just pulled the 5:00pm Evening time option, since sunset will be before 5:00 until spring.

So I'm good. But this is clearly a Hubitat bug. :slight_smile:

Yes indeed, a bug for sure. Fixed for next release.

I discovered a related bug. I REMOVED the 5:00pm trigger by changing to "Certain Time":

But, I still got the switch to "Evening" at both 30 minutes before sunset and again at 5:00! So changing this doesn't appear to clean up the old setting.

Yes, I encountered that issue. It will be in the fix. Thanks for your patience! You can clear it out by going back to Earlier of Two Times, and erasing the second time. Then change to Certain time. The second schedule will go away at that point.

Just did that. Thanks!

I thought I had this figured out by removing the 5:00 time and leaving the sunset - 30. But Evening mode kicked in again at sunset -30 and 5:00 last night!

So I went back to the Mode Manager to try and see if there was something I could do to override anything but I am unable to. If I go to set any time to "No Selection", it resets back to the time previously entered. I can't clear anything... :frowning:

So just to be specific: I select "No Selection" from this screen, and it refreshes and returns to the same settings as before. (A specific time/5:00pm)

The steps are this:

  1. Select Earlier of two times
  2. Delete the entries for the second time
  3. Hit Done
  4. Select A Specific time
  5. verify that the time is what you want
  6. Hit Done
  7. Hit Done to exit the app.