Bug: Advanced Zigbee Bulb driver - Set Level doesn't change the state

This is a bug in the driver that is always reproducible.

  1. Type a number between 1 and 100 in the Set Level command field.
  2. Hit the Set Level button.

Expected result: The bulb changes to the desired level AND the level variable is changed in the Current States.
Actual result: The bulb changes to the desired level BUT the level variable doesn't change in the Current States, even if you refresh the page.

As a result of this bug, when the preference Power Restore State is set to Last state, it won't work properly.

Also apps connected via Maker API will not be updated, since, obviously, the variable wasn't updated.

The only way to change the level variable is by hitting the Configure button after a Set Level or a Preset Level command. In this case the variable is updated in the page, you don't even need to refresh.

This works for me, so it's not a universal problem, and it likely depends on the specific device you're using. So, the most important question: what brand and model of bulb are you using with this driver? A related question: did the device pair with this driver, or did you switch to it afterwards? If your device is not noted for use with the "Advanced..." driver in the compatible device list, I'd suggest the "Generic..." driver (or a manufacturer-specific driver, as Sengled has, and possibly others) instead, though the "Advanced..." driver may work with more than what is noted.

Finally, if you do employ a workaround until this gets figured out, I'd suggest a "Refresh" instead of "Configure": it's almost certainly a less intense operation with the "Advanced..." drivers than a "Configure," so it will likely finish faster, have less impact on your Zigbee network (and hub), and -- unique to this driver because it runs some tests as part of this command -- won't leave the bulb in possibly an odd state afterwards. (It's also a better match for the intention behind each of these commands--"Configure" is normally necessary to run only once manually, if ever, often after switching drivers, and for Zigbee normally tells the device what to send back to the hub.)


First of all thanks for the prompt and comprehensive reply. I really appreciate it!

I'm using the GLEDOPTO GL-SD-001. Currently I have 35 of those paired.

They didn't match any driver upon pairing. I chose the "Advanced..." myself for lack of knowledge and because I wanted to use the "Minimum Level" option.
Those devices are controlling different types and brands of LEDs, some of them can be dimmed 1-100%, others 30-100%, but there are some odd cases, like 31%, 29% and 24% as minimum.
An open number field instead of a dropdown for the minimum level option would be great.

I have tested with the "Generic..." driver and the level variable updates as expected.
I'll use it for now, hopefully the device can be supported as "Advanced..." in the future.

1 Like

The bulb drivers wouldn't be appropriate for a device that has a physical control input. Probably should use the generic zigbee dimmer driver.


Hi @eduardo ,

Are your GL-SD-001 dimmers updating the brightness level in HE when changed locally?

I don't have any with local connections, but if I press or hold the level button on the device, it does update on HE. I'm now using the "Generic Zigbee Dimmer" driver.

Hi @eduardo ,

Can you try this driver?

1 Like