Brand new device can't link Alexa or Google Home

Hi, I just got a Hubitat yesterday, and am so far pretty unimpressed. Many problems immediately. The "find hub" feature hung forever without ever finding my hub. After a couple hours I figured out I didn't need you to find it, I know what its IP is and could continue set up. I made an account and everything. Tried to link to amazon and google home and both fail miserably.

Enabling the skill takes me to login with Hubitat page so I enter my credentials. I copy them so I know they are correct and regardless I get a different error message when I enter the wrong password.
The error I get with correct credentials is "unable to link Hubitat with Alexa"

Adding Hubitat asks me to login which I do. Then it just goes back to the linked services page without Hubitat being a linked service. I can search for it and touch it again only for the same sequence to repeat itself.

I am assuming you mean on Amazon's side of things here.

Did you install the Amazon Echo Skill app on Hubitat too?

No idea about Google, but I think it is similar to Alexa where you have to enable it on both the hub, and within Google.

yes I have. I don't know whose fault it is, but since the google linking fails too it would suggest the problem is Hubitat.

Not 100% sure, but I think that one is on Google's side. I was adding a different service (not Hubitat) to Google the other day and the exact same thing kept happening. After 7 or 8 tried it finally "took".

Make sure you are using the same login that your hub is registered under for the Hubitat portal.

You can find documents for the Alexa Skill App and Google Home App at

1 Like

tried your shotgun approach. No luck after 10+ adding Hubitat attempts.

Just so we are on the same page, are you in USA or elsewhere? That might make a difference depending upon location.

In any case, try this. Uninstall the Alexa app on Hubitat, and the Hubitat skill in Alexa. Reboot the hub using the Settings tab, reboot. Reinstall both starting with Hubitat.

I have Google working OK.
Not sure if this is what you have done but this is what I did.
Installed Google Home by using the "Add Built-In App" button.
In the app on HE select the devices I want to control.
In the Google Home app on my phone I selected settings -> works with google.
From here I added Hubitat.
I can now control these devices by asking Google to "Turn On/Off Switch" and it does it.
You've probably done all this but thought I would mention it.

Yes, USA.

I'll give it a go. The Hubitat skill was never added. It fails every time I try to enable it. I have about 1% confidence this will change anything.

Please clarify. It wasn't added in Amazon or Hubitat? None of it is automatically added.

1 Like

Tagging @bobbyD.

@pauliankline - is your Hubitat registered? I think that the Amazon Echo Skill (on Hubitat) and the Hubitat skill (on Alexa) will not work if it isn't registered.

1 Like

Hi there, sorry for the troubles. Last Chrome update broke the "Find Hubs" page. If you could use MS Edge Chronium for the time being, that may help. While you are logged in the portal, do you see your hub on "My Hubs" page? Also, have you connected any compatible Alexa/Google devices to Hubitat? Both Amazon and Google integrations can add Hubitat devices to the voice control service, but none of your devices connected directly to Alexa/Google will be made available to Hubitat.


I registered the hub before attempting linking, but after going through the process a second time, the Alexa skill worked. Thank you!


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.