Bizarre issue with Motion Triggers with Alexa

For the last few days I have discovered that my Alexa routines based on motion stopping are not firing. The bizarre thing is routines based on motion starting work just fine..

For example I have two routines for my office air filter. One turns on the air filter when there is motion in the office. The other routine is configured to turn off the air filter when there is no motion for 30 minutes. Right now the air filter turns on, but won't turn off.

Up until the time I installed update 2.2.6.140 (or maybe 139), these worked fine. Now none of my tiggers fire on motion stopping for x period of time. This is true for both physical (real) motion sensors and virtual ones.

Don't know if the update is what broke it, or if the the timing just happened to align. These automations had been working fine for many months, until now.

I did check the routines themselves by running them manually in the Alexa App. They just aren't being triggering automatically.

Anyone else having the same issue?

If motion sensor state shows up accurately in the Alexa app, which must be occurring for your routine based on motion active to be triggered, then this is an issue at the Alexa end.

Delete and recreate the routine.

The Alexa app doesn't show motion state of the sensors, at least I can't find a place that shows it. All I see when I pull up the device in Alexa is the temperature. As such, I can't tell if the motion sensor is going inactive from Alexa's perspective.. It's clearly picking up the active events, but not clear on if it goes inactive.

I don't know how Alexa internally triggers on motion, aka does it have to have a state change to trigger a motion start event? Or can "re-triggers" also cause them to fire.. Aka like the behavior some switches have when even if they are off, if you press off they still will fire an off event.

In any case I had already tried deleting and recreating one of the on motion stop routines and it had no effect.

If you know of a way I can confirm on the Alexa side that both active and inactive states are being registered please let me know and I will check.

Presumably, the active event is picked up as a state change. Therefore, it has to be picking up the inactive events.

Edit: Going to test this with a Virtual Motion Sensor right now.

Here you go - using a virtual motion sensor, I can see both motion active and motion inactive events accurately in the Alexa app.

So, this isn’t something at the Hubitat end. I agree with @SmartHomePrimer - I’d wait it out in case the Alexa cloud is misbehaving (selectively)

I really think that any Alexa problems people are seeing right now is cloud on their side. I’m having a ton of issues that are not centered around Hubitat. All of my skills are misbehaving on all of my Echos. Rebooting my devices and re-enabling skills is only helping for a little while and then the problems are coming back again. Prior to this I have had zero issues for many months.

So I would caution against taking any configuration action and changing a bunch of things. This really seems likely an Amazon cloud issue and that’s the reality of cloud services to be frank. We have very little control over the outcome, despite what they would like us to believe. It will probably clear up in a few days, so I would recommend just let it sit for now.

1 Like

Weird, my motion sensors do not show up the same as they do for you.. I could have sworn they used to show up like they do in your screenshots prior to things going haywire though. Right now all it shows is the temp reading from the sensor, nothing related to motion.

I'll leave things be for a few days to see if it sorts itself out. These had been working like clockwork for well over four months and that they broke right around the same time I applied the updated seemed like they might have been correlated... Looking like that was just happenstance. If anything changes I'll post an update to this thread..

Thanks to those who have tried to help!

Yeah, I have not updated my main hub and things have still gone sideways with my Logitech Skill, my Delta faucet skill, and my Hubitat skill. That to me says there’s something not right in Amazon’s side.

Maybe the people responsible for Alexa skills are not fixing it as efficiently as they normally would in support for their coworkers, and it’s a big middle finger to Amazon for fighting so inappropriately against worker unionization. :thinking::man_shrugging:t3:

I use my own virtual motion sensor driver that doesn't have the capability "Temperature Measurement".

1 Like

That's the key. Any sensor with a temperature attribute in the driver is only displaying temperature in the Alexa app. For me, Alexa routines still trigger correctly, it's just a display issue .

2 Likes

The hubitat skill was rewritten to use temperature as the default capability -- not sure why when switch is available.

Download the Hubitat app