[BETA] A Z-Wave Mesh Tool [C7 and 2.2.4+ Only]

All good. Back to the Sunday beer, you've earned it :grinning_face_with_smiling_eyes:

1 Like

The newest build fixed the problem that I was having with the dropdown arrows too.

1 Like

Hi @tony.fleisher, I'm seeing that enabling Save Table State causes the Active Active Time column to not be displayed. Is this intended?

@dennypage not intentional. I will see what i can do about that. Thanks for the report.

Thanks @tony.fleisher all my devices now show as Z-Wave Plus. :+1:


Added this to the Wiki collection topic;

Thanks @tony.fleisher

@tony.fleisher, found an edge case bug with a hub migrated from a C5 and nodes 02-05 are actually devices and not the reserved nodes. If you scroll up on this thread you will see the screenshots of the neighbor table.

1 Like

It has been a crazy year for me, but I am finally getting back to this (and finally picked up a C-8, too). If all goes well, I am expecting to have a new release hopefully before the end of the year with a few bug fixes and maybe even a few new features/wishlist items as well.


Awesome... Looking forward to it...

That would be nice.

Hmmm appears my app is not picking up the devices anymore, any suggestions? I am on C-8 Beta Any one else?

He is aware. I notified him on the last beta and he has a fix to do.

Ahhh ok thanks! @dnickel


  • Support updated zwave details ui
  • Fix bug with some zwave devices wrongly being labeled as HUB
  • Bug fixes

Hey @tony.fleisher

I have a weird ghost issue that I think is affecting the loading of device details page.

I was trying to kill a failed outlet ghost by using a z-stick. For some reason, the hub would not pair with the stick and after a few attempts, it created three ghosts for the stick...

After getting the stick to finally pair, it does not show the ghost nodes in PC Controller... I'm having a hard time getting rid of them and I believe they are causing an issue with opening your app.

I'm getting this error:

TypeError: Cannot read properties of undefined (reading 'deviceNetworkId')

I don't see a way to remove the ghosts as of right now, but I'd like to get the app working...

Any ideas?

How you powered off the hub fully removed power for 10+ seconds?
The zwave radio could be in a weird state, and the ghosts may be already gone.

Yes sir. Have done that twice. No change…

Weird you mention them possibly being gone. When I first go into z-wave settings, and the devices are lined up in order of nodes, the three ghosts do not show up. When I sort by name, the three show up at the bottom… a-z with the ghosts being at the bottom because they have no name. I’m guessing. With nodes assigned to them.

I thought about the idea maybe they really don’t exist and not worry about them, but they or something else is preventing me from opening the z-wave details app.

The errors in opening the app only happened after the ghosts and failed pairings, so I’m fairly sure they are what’s causing the error.

If you can provide a screenshot of the logs, it might help me track this down.

My guess is that you authorized z-wave devices in the app and then removed one of the devices. I will try to make this more resilient in a future releases. You can check if this is the issue by going into the authorization page, and reselect the devices.

Hey Tony,

I tried going in and re-authorizing the devices... Still get the error. Here is all that is put into the logs.

I really think its picking up those ghosts. This started when they happened.

app:23942023-12-06 18:40:12.344errorzwaveInfo: Error getting zwave Info: TypeError: Cannot read properties of undefined (reading 'deviceNetworkId')

app:23942023-12-06 18:39:53.409errorzwaveInfo: Error getting zwave Info: TypeError: Cannot read properties of undefined (reading 'deviceNetworkId')

Hey Tony,

I tried removing the app and adding back. I then went in and authorized all of my Z-Wave devices again. Still getting the error.

I believe this error is being caused by the z-stick ghosts created when I tried to add my Zooz ZST10 stick to remove another ghost. That ZST10 would not pair and every time I tried, it created a new ghost... I was able to add the ZST39, but that stick when added doesn't show the ghosts created by the ZST10.

In any event, I can't use your app because it thinks those ghost nodes are there and it throws the error.

Trying to get rid of those z-stick controller ghosts has been a real pain and nothing has worked so far. I'm relying of your app to help me with some devices on the edge of my mesh. Seeing their neighbor routing will help me with repeater placement... However, I can't use your app with this ghost issue.