Best Fibaro Dimmer 2 driver?

I'm trying to get my Fibaro 2 Dimmers working with Hubitat to be able to locally and via Hubitat switch them on and off, I'd also like to be able to use the second switch to switch other devices on/off via Hubitat and finally retreive power readings from the device.

I've tried the integrated one, Erocm123 and Robin Winbourne's with different results with each, so wondered what most people are using for the aboe and then I can use that one and work out my issues from there.

I think you are referring to the Fibaro DOUBLE Switch 2 ( FGS-223)

The Fibaro Dimmer 2 ( FGD-212) doe NOT have a "second" switch.

he means 2nd input

This is the best one by @ericm , everything works 100%. I use the button events created from the 2nd input to control my zigbee lamps and send the house to night mode and stuff.

hoping to do a bit more work on it so it shows physical and digital events if possible to fit even better with HEs apps.

Yes I did mean 2nd input :slight_smile:

I'll take a look at that driver.

Thanks :-):smiley:

I've created the driver from the above link.

I can turn the light On/Off using the On/Off buttons in the device page and using the light switch, however if I use the light switch the status of the device does not update to reflect the change. The power status does change to show power being used irrelevant of how the light is switched On/Off.

If I use the light switch to try to turn light off when it is On then I get the following in the log:

Any help gratefully appreciated :grin:

have you set what switch type you have connected and clicked configure after you clicked save?

This particular switch is a Toggle switch, I have saved and clicked configure many times but still the same issue. I've also tried setting momentary and just doing a quick toggle of the switch but same result. I've unassociated and added again as well.

If I click Refresh from the device then the device and dashboard update correctly.

Did you pair it in secure mode?

If not exclude it, switch to secure mode for all devices and add it again.

That's how i got mine working.

Mine is unsecure paired and it's best to not pair securely if not needed.

Try clicking save but don't click configure

There is some differences in some of the firmware I know @ericm had some issues with his at first because he had extra settings than mine, but that was corrected in the hub a while ago. What firmware and hardware are you on for the device.

Just to put my 2 pence worth in, some time ago when I was getting some errors and inconsistencies with my hub, it was recommended by support to re-pair my Fibaro dimmers in 'unsecure' mode. (They were in secure mode).
This was several builds ago though so this information may not be current.
Just thought I'd pass the info on. :slight_smile:

1 Like

I've just tried it in Secure mode with the same result :frowning:

Tried that but unfortunately still the same.

What firmware and hardware are you on for the device

Hubitat Elevation® Platform Version

Hardware Version

Rev C-5

not the hub the device, it will say on the box if you still have it

I don't have the box as been installed for a while, just removed one to take a look.

Just to throw some more info out there.
Turn logging on for the device.
Set the configuration settings of the dimmer to what you want in the device on the UI.
Open another log window at the same time.
Press the B button 3 times to get it in configuration mode and then press the configure button on the UI for the device.
Do you see the config being set in the logs?

mine are all 3.5 so maybe there was some issues?

When I toggle the light switch 3 times I get the following in the log except for the top line which appears when I press Configure Button.

I'll try and find out how I can update them then :slight_smile:

Is this what you mean by 'the light switch'?
I cannot see any config messages.