BE469 & Notifications

It's definitely the lock because the lock doesn't even update whether it's locked or unlocked until I refresh it using the refresh command.

  1. Open the lock device driver details in a tab and turn on debug logging.
  2. Open the log in a separate tab.
  3. Go to the device details tab for the lock and select the Lock button.
  4. Go to the log tab and click on the lock driver name or label in the top of the log so only the log from the lock shows.
  5. Clear the log
  6. Go back to the lock tab and select the Unlock button.
  7. Go back to the log tab and take a screen shot of the results, labelling it "Digital Unlock"
  8. Go back to the log tab and clear the log again
  9. Go back to the device details tab and select the Lock button
  10. Return to the log tab and take another screen shot, labelling it "Digital Lock"

Send those screen shots to @bobbyD and @mike.maxwell

Tried this. FYI nothing comes up on the log unless I press the refresh button. Then it logs the following.

Same thing happens with BE369. I had to move the locks back to my old system.

Debug logging is turned on in the lock driver?

Yup turned the debug logging on.

Hmmm, well maybe

Lock, Refresh, copy the log then clear.
Unlock, Refresh, copy the log then clear.

Send both to @mike.maxwell

Hey, did this get resolved? I am having the same trouble. All locks and codes work and I have some notifiers set up via the generic Notifications app, but when I use a code, nothing shows up in the logs, even though I have debug turned on for the devices.

Notifications are working? Is encryption enabled?

No notifications for locks, though for other things. The locks work and I am able to set codes, etc. via Lock Code Manager, though it is always tenuous.

Enable Lock Code Encryption is not enabled, though the codes do not show in the clear in the device screen - they are ????.

I am reasonably happy with everything except not being able to get unlock or lock code notifications.

The ???? are the two factory preset default codes that are in the lock after a factory reset/initial install, Lock Code Manager will show all codes entered and/or stored in the lock itself. as ????, As I don't think it has the ability to read stored codes from the device....if you create the codes VIA Lock Code Manager you should be able to view the actual codes numbers in the notifications.

The ???? are in all 19 codes (2 included plus my 17). It seems to work though. I am a little snakebit to turn on encryption on the HE device options.

Just looking for why I am not seeing notifications or even debug messages in the logs.

Were the 17 lock codes added using HE Lock Manager? If not HE has no way to retrieve existing lock codes. I had a BE469 on Wink and initially had the same issue. In the end it was easier to delete all of the codes and add them again in HE.

Forgot about the Schlage issue. OK. read this post and then two posts later in the same thread.

Schlage locks do not allow the export of any codes resident on the lock, this isn't a Hubitat issue, this is what schlage decided to do.
All codes exported will show as ????, each one must be deleted and then entered again if you intend to do any type of code reporting or rules based on the entered code.

1 Like

I reset the locks, then paired them with HE. On pairing, the two built-in codes were there after I paired. I then left them there and added the other 17 (mine) into all three locks. this worked eventually, but I did wind up having to retry several.

Now all the codes are in and work. They show up as ???? which is a minor pain but understandable if it is for security. This is not my issue unless it is a symptom of something else not configured correctly.

The trouble I am having is that the locks do not let me know via notifications or even logs that there has been a code entered (I would prefer to know the person, not the code).

I have a Lock Notifier that should let me know open/closed events and I have a Lock code Notifier that should let me know when any code has been used. It is these two things that are not working.

I did create the codes via Lock Manager, but they all showed up as ????.

I wasn't implying that this is an HE issue. The point I was trying to convey is that the lock codes must be deleted then re-entered in HE for them to show in HE.


This works for the BE469. For the FE599, any codes entered via Hubitat still show up as ????.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.