Backup scheduler stopped since 2.3.0.116?

2.3.0.118 (just out) has a fix for this issue.

7 Likes

I updated and tried this, the manual backup to cloud seems to work but the window that opens up saying the backup is in progress never goes away. If I use the back button the backup does show up (hopefully its good) but still that pop up window does not close

I've changed the time for auto backup to 7 mins from now so will see if the auto backup works

I can confirm that the backup is on the cloud, and its size is consistent with earlier backups.

I can confirm that the auto backup does work for both local and cloud. Thanks

3 Likes

I have a variant of this exact problem. My daily backups stopped running in early November, but I never noticed. Until today. I started experiencing 500 Errors on my main production hub so I did a soft reset. Then when I went to restore, my last backup date was November 8th under 2.2.9.146. I keep my firmware update, usually within a day or two. None of my other hubs have this problem.

Any ideas? I think I'm completely hosed (all the changes from the last 7 weeks I have to redo). @bobbyD, any idea how this could happen?

P.S. Yes my local backup schedule was and is set to daily.

This was fixed in 2.3.0.118. I saw it, too, prior to that, but it was fixed for me with 2.3.0.118.

I saw that too, but then why did my backup schedules not restart? And, more importantly, do I have any way of accessing an updated backup -- I assume not.

Unclear what you are asking. Automated backups are stored on your hub, accessible on Settings, Backup and Restore.

From what I read of the 2.3.X fix, the backup schedules should have resumed on their own once one updates firmware (which I did). Given that was the case, I am:

  1. confused about why mine schedules never resumed ever since early November -- weird.
  2. desperate to find if in fact they did resume, but the UI is wrong, in which case I'm praying I don't have to rebuild 6-7 weeks of changes.

If you are concerned you can always take a manual backup…

Still unclear. See above screenshot. You can always make and download a backup at any time, as you should before and after making changes.

But there is no way to have backups appear from the period where no backups were made.

Yes, I am completely clear about that. What I'm scratching my head about is why the regular scheduled backups didn't resume, as they appeared to for everyone else?

And secondarily, is it possible that they did, and the UI is wrong?

I fully acknowledge the second question is a total reach out of desperation. But mostly my confusion pertains to the first question.

:man_shrugging: Check the Settings at the bottom of the Backup and Restore page, try slightly changing the backup time, click Update. There’s a remote possibility that you have some database corruption, in which case downloading a manual backup, Soft Reset, then re-load the saved backup could fix that.

https://docs.hubitat.com/index.php?title=Soft_Reset

No.

1 Like

Yeah that's what I was afraid. You can appreciate why I was trying to avoid reality. :hot_face: :crazy_face:

1 Like

Something to try, may or may not work, but could try altering the scheduled time to something else and see if that kick-starts it.

I don't think you'll need to even change the scheduled time, just saving it again should be enough.
But yeah, it should have started on its own. Please PM me your hub id if you want me to take a look at the engineering logs on the hub.

One of my hubs still won’t backup automatically no matter what I’ve tried. Will PM you thx.

@gopher.ny, this problem--where the local backup doesn't happen as scheduled--is reoccurring. Here are two examples, one where the backup is happening twice each night, and the other when it is only happening every few days. So confused. And concerned. What would you suggest?


How do you have the automated local backups configured?

Mine have been running properly on schedule for years.

The hub that is running two backups per day… do you have any external systems that are automatically creating/downloading a backup in addition to the normal local automatic one?

1 Like

Yes, I have local backups configured, or at least I've set them up using the interface you pasted above.

I do reboot a couple of my hubs daily, so that might (?) explain the double backups. But regardless, I'm way more worried about the pattern of missed backups. Stumped.

Download the Hubitat app