Axis Gear Does the Right Thing!

For the past year, I have been trying everything to get my Axis Gear (zigbee shade controllers) working. Thanks to @mike.maxwell, we got the generic zigbee shade driver implemented late last year with explicit support for these devices. I thought that might solve it. Nope. I have factory reset and re-paired the Gears more times than I can count. I have reached out to Axis (now branded Ryse), only to have them say it's a Hubitat issue. Thanks.

I'm embarrassed to admit that I am so desperate that I purchased another Hubitat hub recently for the sole purpose of having a hub with just the Axis Gears on it -- to remove any other dependencies. Still, no joy.

In the room where my new shiny single-purpose hub is located, I have 5 blinds. One of the 5 works consistently well. This is the device data on the device details screen:

  • endpointId: 01
  • model: Gear
  • application: 15
  • firmwareMT: 1262-0013-03000800
  • softwareBuild: 03000800
  • manufacturer: AXIS

The other four that don't work all look like this:

  • endpointId: 01
  • model: Gear
  • application: 8C
  • firmwareMT: 109A-0013-01000000
  • softwareBuild: 01000000
  • manufacturer: AXIS

Logs show no warnings or errors. It just reports that the shade is opening and closing in response to commands (but they don't move, except when controlled manually at the device itself).

I am going absolutely batty with this and my WAF is going down the tubes. I'll take any theories or ideas anybody has. I'm all out of 'em. TIA.....

My first thought is the 4 that don't work may benefit from a firmware update (if possible).

I suspect the same but I have no idea how to do that. Assume that’s a manufacturer question?

I was thinking firmware is likely too. Why are there different firmwares?

The question for Axis is above, why or what changed between these firmware? Which one is newer? Is there an even more recent update than these you currently have? Maybe even a complete changelog would be nice to see.

The trouble is that users cannot update Zigbee device firmware using a file on Hubitat. In other words, if Axis did send you a file, it would be mostly worthless. At the moment, Axis (or someone) would have to send Hubitat the firmware and it would have to be added by staff, presumably Mike.

Also that whole updating idea might not work at all if the working one (1262-0013-03000800) is the older firmware, and the non-functional 109A ones were the newer firmware. Hard telling which is which, but my wild guess is that the 1262 is newer and that you need an update.

1 Like

I would look here.

1 Like

Can't offer anything meaningful or useful, but nice to see someone "heavily invested" in their new passion :slight_smile: Albeit while working through a problem....

The first element in the firmwareMT tuple is the manufacturer, as you can see they are different and so are completely different firmwares.
I would point this out to AXIS and ask them for an explanation.
If they can provide the firmware file for the working GEAR we can add it to our Zigbee firmware repo, assuming the device supports OTA, another question for them...
Your only other option would be to send one of the non working units to me, and I can try to see what's up with it.

5 Likes

You guys are ridiculously over-the-top helpful, seriously. Let me go another round with them before I impose. Will revert here soon.

2 Likes

Axis gear (ryse) has an Android/iOS app for firmware updates over Bluetooth. Its the best place to start to ensure you have the latest FW.

1 Like

Thanks to all for the suggestions. A couple updates:

  • I have been using the Axis iOS app, and all the devices are updated, at least per the app. Thanks @sidjohn1 and @JohnRob.
  • I have reached out to the manufacturer. I asked them for an explanation of the differences in firmware, which versions are more/less recent, a changelog (if they'll share it), and clarity on how to get the latest or best firmware, including whether it can be OTA. Waiting for a response.

More soon....(I hope)

1 Like

One thing I just noticed: in the Axis iOS app, you can go into device details and see the firmware version. In the app, all my devices show 5.3.5.1125. Both those that don't work, and the one that does. All indicate they are up-to-date at this firmware version.

How does the 5.3.5.1125 related to the "firmwareMT" (the 1262... or 109A... in the screen shots above)?

I have no idea, but i might guess that the firmware shown in the app is the Bluetooth firmware version, not the Zigbee firmware version...

1 Like

Okay, well if YOU don't know, then.... :wink:

I have a call with one of their engineers tomorrow. Stay tuned.

2 Likes

Ya if one works and not the others it is
Not the hubitat driver it is their issue.

1 Like

Quick update. I spoke to RYSE (fka Axis) engineers this week. They tried some light troubleshooting by phone, but threw in the towel pretty quickly. Afterwards, they asked me to send them one of the units that doesn’t work, so they could analyze and hopefully remediate in the lab.

If that works, we’ll repeat the process with the rest of the units.

Regarding the above firmware dialogue, here’s what I learned. The firmware upgrade in the app appears to keep the Bluetooth firmware up-to-date. But the Zigbee firmware is static to the hardware, at least via the standard user interface.

We’ll see what happens. In the meantime, I have to give them credit. My devices are all out of warranty so they aren’t obligated to do anything. At least they are engaging which I appreciate.

More soon….

2 Likes

Another update and a question for @mike.maxwell or other Zigbee experts….

They sent me a couple units with the newer Zigbee firmware. As soon as I installed them, they worked perfectly. No issues.

Once I reported the success to the Axis/RYSE folks, and told them I had five more non-functioning blinds with old firmware, they asked the following:

May I ask if your Hubitat has the ability to push Zigbee updates?

Do we? Suggestions on how to respond?

Yes, they just need the firmware file and @mike.maxwell can add it to the zigbee repo

3 Likes

@mike.maxwell, I have an .ota file courtesy of Axis/RYSE that is purportedly the zigbee firmware update for Gear. What’s the best way for me to get you the file? Want to DM me an email address? TIA….

4 Likes

This thread has absolutely nothing to do with me or any of my hardware... I still think it's the best thread I've read in a long time. Great vendor assistance as well as the usual level of help from the forum.

Good stuff.

1 Like

Agreed. While I am used to Hubitat being very helpful (dev's and community), normally getting vendors to provide firmware updates (especially zigbee ones) is damn near impossible. Nice when they backup their own product.

1 Like

Download the Hubitat app