August Z-wave lock not pairing

I’m in the process to (slowly and painfully) migrate my smart house from ST to HE.
On ST one of my lock was the Gen 1 August Z-wave lock (with the firmware frozen at 1.59.0-1.8.15, the last “good” Z-wave version). Lock worked as expected, and fully controllable through Z-wave.
However, I have not been able to pair the lock on HE. The lock is discoverered quickly, but the process get stuck at “The device is completing bootstrapping…”
So far I have tried the following (with a proper exclusion or Zwave reset before each attempt):

  1. Pair with S2
  2. Pair with S0
  3. Move the lock within few inches of the hub
  4. Perform a full lock factory reset

Below are screenshots of the (failed) process. Each attempt triggers a ghost device in HE that has to be removed by exclusion or forced deletion, and the August app indicates that the pairing as completed in S0.

I’m out of ideas on what to try next, and would appreciate any feedback, guidance or advises.



HE screen where the process gets stuck:

HE ghost device created:

August app screenshot:

As you've probably already surmised, the bootstrapping is referring to the security pairing. From the lock message it looks like the hub isn't recognizing the S2 challenge. I seem to recall that @bcopeland may have posted something on this previously. (Searching now.)

1 Like

Make sure you remove the ghost the lock created. Otherwise you will have problems pairing anything. Next use the QR code to add the lock through your phone app. Even if it stalls let it sit for 10 mins, the lock will show up in the device list.

1 Like

It could also be a couple other things.. Such as wrong DSK entered or Secure inclusion being skipped.


For clarity, I’m also not able to pair in S0, where no SDK is requested.

an SDK only will be needed with s2 not s0. Do you have the s2 qr code?

1 Like

I’m not seeing the QR code on the device but I may still have the box it came in. I’ll take a look.

That been said, once the device is discovered, HE ask me if I want to pursue with S0 or S2. When I choose S0, I got the screen above right away, and when I chose S2, I’m asked to enter the SDK, and then got the same screen above.

Do you think using the QR code (if I can find it) will change this behavior? If not, what else can I try?

I think you need to use S2, I don't think S0 will work. Are you entering the DSK code when prompted during this step, or does it never prompt you for this?


I think where Rick was going with this was to use Z-wave Smartstart in the Hubitat app. You need the QR code to use that method. I have seen Smartstart work where adding a device via the normal pairing method failed. It is certainly worth trying.

I am also curious if you hit "Discover" on that ghost device, and put the lock back into inclusion what happens. Also, maybe use another hub or Z-stick to exclude the device (Don't exclude using the Hubitat) then hit Discover and see if it will include that way, like a failed device replacement?

1 Like

Thanks for the feedback and suggestion. Much appreciated!

It does prompt me and I’m entering the DSK when asked.

Although the pairing failed from the HE side, the lock believes it is paired in S0 (see screen above), so I have no opportunity to put it back in inclusion mode.

I’ll try the following:

  1. try to use the QR code if I can locate it
  2. once pairing failed, and create a ghost device, exclude the lock with another hub, put the lock in pairing mode and hit discover on the ghost device

I’ll report in a bit.

Remove any ghosts, and try moving the hub closer to the lock, or vice versa, during pairing.

You shouldn't have to move them closer, but the key exchange is one of the trickiest parts of pairing a lock, so a better signal couldn't do anything but help.

1 Like

Most of the attempt described above were done with the lock few inches away from the hub and with all previously ghost removed….

1 Like

Gotcha. I have no more suggestions then, other than maybe power down the hub from the menu, remove power for a minute, power it back up and try again.

Powering it down that way completely reboots the zwave radio in a way that simply rebooting the hub does not.


Thanks, good advice. I’ll give that a shot.

Curious.. Because the DSK is usually printed with the QR code..

I just looked at mine.. And you are correct they have the DSK printed but not the QR on the device.. Odd..

They have a QR code there but it's not smart start

Found the original box, but no QR code seems to be included.
Info are present on the lock cover. See picture below. Im assuming the DSK is the 5-digit number located under the Zwave plus logo, correct?


1 Like

Success! Try few things at once so not sure which one did the trick.

  1. ensure no ghost devices were present
  2. shut down and power hub back up
  3. perform a factory reset on the lock
  4. install fresh batteries in the lock
  5. move the HE hub away from other hubs and place the lock few inches away

Paired without issue on the first attempt.

Funny, as I was already looking a new locks.

Thanks all for the advices and support!


Did you get the commands working? I am trying to pair my August Pro on a new C8 (migrating from Vera) and I find while I can pair it (using S2), none of the commands work. I saw this described in another thread, but supposedly there was a firmware fix long ago that fixed this.

Answering my own question, just got it working on the 3rd try.

1 Like