Arm/Disarm Arlo using Node-RED

Hi Peeps

With IFTTT going the way of subs, I've been trying to get my Arlo's armed and disarmed using Node-RED instead. Finally got that working (there are literally no docs on this node that I can find, and I cannot get other aspects working whatsoever). If anyone find a way to get motion, audio etc sensing working, please add to this thread for the benefit of all!

First, here is the node to add to your system:

node-red-contrib-arlo

I'm then using a flow like this:

code export

[{"id":"54f070ca.968a2","type":"group","z":"f71252f3.64cdf","name":"Arlo Arm/Disarm","style":{"label":true,"fill":"#dbcbe7"},"nodes":["88e87db9.6036d","302e3e13.546a92","65f031ce.4d58f","d4ee3ab9.9df418","82b11283.63dfd","906ee695.771aa8","be306369.67f42","52c15de5.10ad74"],"x":214,"y":519,"w":812,"h":202},{"id":"88e87db9.6036d","type":"arlo-out","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Baan Amphur","service":"ecda60b9.a359c","device":"4RD1777BA00BD","x":920,"y":620,"wires":[]},{"id":"302e3e13.546a92","type":"inject","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Arm","props":[{"p":"topic","vt":"str"},{"p":"payload.mode","v":"arm","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"mode","x":730,"y":560,"wires":[["88e87db9.6036d"]]},{"id":"65f031ce.4d58f","type":"inject","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Disarm","props":[{"p":"topic","vt":"str"},{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":0.1,"topic":"mode","payload":"false","payloadType":"bool","x":730,"y":680,"wires":[["88e87db9.6036d"]]},{"id":"d4ee3ab9.9df418","type":"hubitat device","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Everyone is in bed","server":"a626e778.3c46e8","deviceId":"2580","attribute":"","sendEvent":true,"x":330,"y":620,"wires":[["82b11283.63dfd"]]},{"id":"82b11283.63dfd","type":"switch","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"on/off","property":"payload.value","propertyType":"msg","rules":[{"t":"eq","v":"on","vt":"str"},{"t":"eq","v":"off","vt":"str"}],"checkall":"true","repair":false,"outputs":2,"x":550,"y":620,"wires":[["906ee695.771aa8"],["be306369.67f42"]]},{"id":"906ee695.771aa8","type":"change","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Arm","rules":[{"t":"set","p":"topic","pt":"msg","to":"mode","tot":"str"},{"t":"set","p":"payload.mode","pt":"msg","to":"arm","tot":"str"}],"action":"","property":"","from":"","to":"","reg":false,"x":710,"y":600,"wires":[["88e87db9.6036d"]]},{"id":"be306369.67f42","type":"change","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Disarm","rules":[{"t":"set","p":"topic","pt":"msg","to":"mode","tot":"str"},{"t":"set","p":"payload","pt":"msg","to":"false","tot":"bool"}],"action":"","property":"","from":"","to":"","reg":false,"x":720,"y":640,"wires":[["88e87db9.6036d"]]},{"id":"52c15de5.10ad74","type":"hubitat device","z":"f71252f3.64cdf","g":"54f070ca.968a2","name":"Everyone is out","server":"a626e778.3c46e8","deviceId":"173","attribute":"","sendEvent":true,"x":320,"y":660,"wires":[["82b11283.63dfd"]]},{"id":"ecda60b9.a359c","type":"arlo-config","z":"","name":"Arlo"},{"id":"a626e778.3c46e8","type":"hubitat config","z":"","name":"myHubitat","usetls":false,"host":"192.168.0.167","port":"80","appId":"2628","nodeRedServer":"http://192.168.0.185:1880","webhookPath":"/hubitat/webhook","autoRefresh":true,"useWebsocket":false}]

Arm:

Disarm:

It works absolutely reliably.

However, I cannot get the other options to work (motion, audio etc). Here is what's available but I'm getting no messages through at all because it seems impossible to select a camera...

When i select that node, instead of displaying the cameras in my account, it instead displays the Basestation only (you refresh it by clicking on the little rectangle next to the field).

But I can't find a way to get it to return the cameras attached to the basestation instead of the basestation itself. So i'm getting no motion triggers at all :frowning: boo. Maybe someone smarter than me can check out the code in the github repo (GitHub - HendrikRoth/node-red-contrib-arlo: Node-Red Arlo addon) and see how those nodes work. I was only able to work out how to make the arm/disarm work.

Cheers.

2 Likes

Thanks for info! I assume it works with 2FA turned on?

Are you running 0.0.3 or the new 0.0.4?

I didn't apply 2FA to my Arlo system yet. So give it a go if you have it and let us know if it works or not.

0.0.4

Just installed the node, it requires the username and password, so I guess 2fa will break it

(I also understand that 2fa for arlos will become mandatory by the end of the year - at the moment it can still be turned off in the app).

Yeah, I deliberately haven't activated 2FA because I suspected it will break it. Worth a try tho'.

Okay, I am trying to set up the Arlo node and I am using my username and password (I know it is good, copying and pasting into another window to log in and it worked) but not returning the information for my base station. Is there a token I need to obtain somehow or something similar?

No token required. I remember I had to click on the little rectangle to get it to connect to the basestation and it said refreshing devices or something like that in a pop up message in Node-RED but then never listed the cameras.

I clicked the rtangle. That is when I got the pop up message. It's not even seeing the base station. Is there a path or anything?

(Edited to add - Just looking to add the base station so I can switch modes)
Are there other items that need to be installed in Node Red besides hubitat and arlo? (Hubitat is working fine in NR)

Do you have 2fa turned on?

No, I do not

It works fine in the Arlo App, the Arlo site, and IFTTT (for now) Copy and pasted the same username password accross all the apps just to be sureit was not a typo thing.

*****Got it - Permissions issue on the Node Red install on my PI. I deleted everything down to factory and rebuilt. Now it's working!!

Just noticed an exclamation in the palette after I install. I bet I am missing some library or something.

Cool. Now we need to find a way to get the motion detection etc working too. Did you try that? I can't get it to see the cameras in the device list. Plus I do wonder what will happen when we are forced into 2FA :frowning:

For 2FA, if it is like any of the others, it should honor log ins that existed prior to upgrade. Usually 2FA is only for a new log in from an unidentified device. That said, I am crossing fingers and not deleting my IFTTT integration just in case.

For the cameras, I am thinking they need to look deeper in the device search. I am thinking it should be a 2 tiered search, once for the Arlo Hub (Which it already does) then the second for the discrete devices. Not sure how to do that one. Might try digging though this post here for some insight (I was actually trying to get access to my other custom modes, but so far no luck):

Yeah, I was looking through the code on github but couldn't figure it out yet. Limited time due to other things right now.

1 Like

Worked for me! 2fa disabled.

Many thanks!

Has anyone experienced Node-RED instability while using these nodes? It seems that my Node-RED crashed a couple times when deploying these nodes.

No problems thus far.

I was having permissions issues with my Node-Red install. It wouldn't save the arlo credentials and would error out when trying to add the arlo hun device. I reinstalled using the script and all got better. Since then, no issues.

Download the Hubitat app