Application State is missing for newly added Lutron dimmers

I recently installed two new Lutron Caseta dimmers and added them to my Devices. They are items "17,Kitchen Kickplate 1 d,18,Kitchen Kickplate 2" in the screenshots attached. It seems like these devices have been correctly added to the file textarea of Settings for my Lutron Integrator, but it does not seem as though they have been added to the Application State devices and/or reverse settings. I'm unable to determine how, or even if, I can make changes to add those. I'm hoping there is a way to correct this without having to remove and rebuild the Lutron Integrator (as I've seen others do in similar cases).

Perhaps worthy of mention is that I have a number of other Lutron dimmers configured and they are still working fine.

I've also attached the Lutron Telnet logs. I can see Lutron seems to be sending the data, but I'm guessing that since the devices don't appear to be fully installed and listed in the database, that info is not getting to my Device. Of course, I am also unable to control the dimmer from my Devices area.

Any help would be appreciated.



I noticed your Use Telnet Direct is false. Mine is true. I have no idea if this matters or not.

Yes, it does matter. The integration between Lutron and Hubitat relies on telnet. In the Lutron app, go to the Integration settings and make sure Telnet is turned on.

Also run an integration report in the Lutron app and send it to your email. Then check to make sure that each of the devices listed in the integration report is properly added to your list of devices in the Hubitat-Lutron integration app in Hubitat.

1 Like

Telnet Direct is a recently added feature to the Lutron integration. If enabled, the Parent App is taken out of the data processing loop. This is a slight optimization. However, it is not required to be enabled.

3 Likes

I have not tried the Lutron integration without Telnet since I got my 7 hub fairly recently. However, I must say that the integration works extremely well with telnet activated.

Just to make sure it is clear… Hubitat’s Lutron Integration always uses Telnet to communicate with Lutron bridge.

“Telnet Direct” is a recent optimization feature of how Hubitat’s Lutron integration uses Telnet.

2 Likes

Thanks. I was not aware of that distinction. The only thing I see in my Lutron integration is a switch to turn Telnet Direct on or off, so I turned mine on.

It’s recommended to turn it on. Any new instances of the Lutron integrator app created since the telnet direct function was released will have it turned on by default.

4 Likes

Thanks to all for the replies. I've turned on the "Telnet Direct" switch, but it made no difference in the immediate problem. I'm guessing I'll have to delete and rebuild the Lutron Integrator app, right? If I do that, will I lose the Devices that are Lutron-driven?
..will I lose the Scenes capabilities that use those devices? ...does that mean I'll need to re-work my Scenes to point to new Devices built under the new Integrator? As you might be able to tell, I'm concerned about having to rebuild my Lutron stuff each time I decide to add new Lutron devices. Thanks in advance for the help.

Can you remove 17 and 18 from the configuration list, save, and then add them back again?

@mike.maxwell ...I did as you suggested but to no avail. I still get the below error showing in the logs when I attempt to control #17 from Devices:

dev:2312021-07-07 10:27:21.269 am errorjava.lang.NullPointerException: Cannot invoke method off() on null object (off)

Also, still not seeing it added to the Application State block.

can you post a screen shot of the configuration list in the integration app?

Config list from Integration app
image

Those last two entries are the only ones with a numeric digit in their name field. What happens if you remove them, click done, then re-add them but without the numeric suffix. Maybe replace "1" with "One" ?

Just a guess.

I personally do not use the "Configuration List" option. I just added each Lutron device manually, as I added them to my house over the course of a few months. I completely understand the advantage of using the list for an establish Lutron installation, though.

@ogiewon I did as you suggested...changed the names both in the Configuration list as well as in the Device definition. I removed them from the list and pasted back in...to no avail...still not being saved to the database (that's what the Application Status indicates correct?).

I'm not sure I follow you completely re: "...not use the Configuration List option". I think I have to do that now that I've done it, correct? I can't go back I think, unless I delete the app and rebuild. But that's where the Configuration List shines I think...makes it easy to cut and paste the list of devices back in to the newly built app.

I'm starting to think that's what I'm going to have to do...build a new app. But that can't be the best way to approach the addition of new devices can it?

1 Like

Any chance there are logs deep in the system that might help figure out what is failing in the app build when adding these devices?

As a test, can you install another instance of the lutron integration using the same bridge IP, then just add those two devices and see if they work?

2 Likes

Well, things are totally berserk now. Before I had attempted to create another instance of the Lutron Integrator I noticed that the connectivity to all of my lights from Hubitat are not responding. They are not responding from the second, newly-created instance either. Could it be that enabling "Telnet direct" disrupted things?

dev:2462021-07-05 05:56:47.331 pm errorTelnet connect failed, trying again in 60 seconds...

dev:2462021-07-05 05:56:47.325 pm infoLutron Telnet went offline

UPDATE: I have no idea why, but my Lutron bridge IP address changed. The newly-created integrator works, and it works for the new devices too.

its best to assign a static dhcp reservation for all your ip based lan devices, that way you never need to worry about these things.
so two ways to go forward, totally remove the first instance and start over, or add all the lutron devices to the second instance, then update all your apps to use the second instance devices, then once completed, remove the first instance...

2 Likes

Download the Hubitat app