App Geofence not talking to hub, but sometimes if open app and go to Geofence map, IOS

iOS 14.4 with the latest HE app ver 1.1.1 (Feb build). Was hoping the latest mobile app advanced motion and network settings would make this work. But it doesn't work at all by itself. I can get it to send presence to the hub sometimes if I go into the app and open the Geofence map which kinda kick starts it to send to the hub. Its like it goes to sleep forever.
I have the app open in the background and phone Location services set to "While Using", also tried "Always".

Under settings, advanced, turn on validate location on network change and high accuracy presence

1 Like

High accuracy presence seemed o help a lot. What exactly does it do differently? The HE app is now 55% of my battery usage running in background which is concerning. I noticed with that setting on I have the blue oval location Icon permanently on in the top right of my phone which links to the HE app.

Yeah high accuracy keeps it running in the background and it is very battery heavy

Yeah, will see so how it goes but probably not gonna like it running constantly.

Two things would make this better if its possible:

  1. Another option, check location and send in selective intervals; 5min, 15min, 30min.. So its not constantly running the GPS or whatever its doing.
  2. Another option maybe on the HE "Mobil App driver" side, If you don't hear from the app geofence in a certain amount of time (5, 15, 30min..) them declare Not Present. So if I accidently close my app and away it will show not present.