Anyone Successfully running the new Sonoff ZBmini Extreme No Neutral

I've been using the original ZB minis for a few years with good success. The smaller size made me want to give a few of them a try. I have no problem connecting the device to habitat however I cannot get them to function via Hubitat.

Once paired the driver just comes up as "Device"

Tried 'Generic ZigBee Switch's and 'Sonoff Switch's

Flipping the switch or hitting the device button does toggle the light however nothing shows up in the logs.

The debug comes up in the logs but the device doesn't.

"Luke's Closet A" should be showing up no?

Is it possible you have the Lout and Lin reversed? Just a wild guess.

Assign temporarily again the inbuilt HE driver named 'Device' and click on the "Get Info" button.
Please copy and paste as a text the fingerprint log that you will see in the live logs, so that @mike.maxwell can add this new device model into the next HE platform update.

Then, assign the HE inbuilt "Generic Zigbee Switch" driver. Switch on the Debug logging preference.

Pair the device again to the hub (without deleting it), with the "Generic Zigbee Switch" previously assigned. Anything in the live logs showing that the device is sending messages to the hub?

What is your hub, C-8, or older model?

So this worked for one out of the two switches I installed. Thank you.

I'm going to keep trying to get the first one to commit.

Here's a screen grab from the 'get info'

I'm running to c7 hubs.

The device fingerprint should appear in the live logs like this

dev:39862023-09-02 21:47:25.356infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0003,0004,0402,0405,FC57,FC7C,042A,FC7E", outClusters:"0003,0019,0020,0202", model:"VINDSTYRKA", manufacturer:"IKEA of Sweden"

dev:39862023-09-02 21:47:25.276traceZCL version:08

dev:39862023-09-02 21:47:25.269traceSoftware Build Id:1.0.010

dev:39862023-09-02 21:47:25.264traceModel:VINDSTYRKA

dev:39862023-09-02 21:47:25.260traceManufacturer:IKEA of Sweden

dev:39862023-09-02 21:47:25.194debuggetting info for unknown Zigbee device...

dev:39862023-09-02 21:47:24.994infoZigbee parsed:[raw:C8F901042A0E0000390000A042, dni:C8F9, endpoint:01, cluster:042A, size:0E, attrId:0000, encoding:39, command:0A, value:42A00000, clusterInt:1066, attrInt:0]

How about this?

Somehow the other started working after about 3 or 4 re-pairings and seem to be stable.

The relay is quite loud and I can definitely see it bothering some people if they're sensitive to that kind of stuff. That aside, it's incredibly small compared to the original ZBmini. Much much smaller than a Shelly 1 also.

1 Like

I got a few of these and they seem to work fine for me. The device fingerprint is still not in version on my C8 Hub so it pulls up as "Device" as the driver type (@mike.maxwell see below) So I needed to manually change the Driver Type to Generic Zigbee Switch. The built-in driver seems to work fine for both control and monitoring status. I have read a lot about people complaining about the relay click but I don't find it an issue. Simply operating the wall switch makes just as much noise.

[dev:1364]2024-01-11 01:13:23.440 AM[info]fingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0001,0003,0006,0007,0B05,FC57", outClusters:"0019", model:"ZBMINIL2", manufacturer:"SONOFF"

[dev:1364]2024-01-11 01:13:22.688 AM[trace]ZCL version:08
[dev:1364]2024-01-11 01:13:22.686 AM[trace]Software Build Id:1.0.14
[dev:1364]2024-01-11 01:13:22.683 AM[trace]Model:ZBMINIL2
[dev:1364]2024-01-11 01:13:22.680 AM[trace]Manufacturer:SONOFF
[dev:1364]2024-01-11 01:13:21.930 AM[debug]getting info for unknown Zigbee device...

I got a few of these today and came across this thread while looking for info to help set them up. As is always the case, for someone new to a system it can be difficult to navigate exactly what experienced users are referencing. As a beginner myself on HE I thought I'd note the required steps to set this up on the C8 as I figured it out. Maybe it helps someone.
I'd some minor issues setting them up but they're working now. I'm using a 230v 10W led on the output for test purposes and I notice a fair amount of current leakage, some of the time half the LEDs in the array will glow, and for one of the devices the glow is constant.
To set them up - firstly, because there's no neutral it needs a load on the output in order to power up, so trying to pair it without a load connected wouldn't work, which makes sense. I wasn't seeing the pairing LED until I connected the load.
After powering it up it enters pairing mode and the LED is flashing. I opened "Devices", "+ Add Device", "Add device manually", "Zigbee", "+ Start Zigbee pairing", it finds the device and asks for a name and room. Then I opened "View Device Details", and scroll to "Device Information" . The "Type" is listed as "Device". At the top of the page under "Commands" there are no ON/OFF commands. I changed the "Type" to "Generic Zigbee Switch", as mentioned earlier in this thread, and "Save Device". At the top of the page again, "Commands" now have ON & OFF commands and they work. (When I figured out that the Driver Type mentioned elsewhere is assigned as the "Type" in the "Device Information" it got easier.)
Under "Device Information" I assigned "Dashboards", and then in the relevant Dashboard window, added a new Tile to that Dashboard. Selected the new Device for the Tile, used "Relay" for a Template and it worked straight away. It is a little slow though (maybe 0.5-1sec response time).


Report back in a few days and let us know how they do.

Mine are completely unreliable. The OG ZbMinis are still trucking along, I've had 1 out of 20 fail which is decent but Id like to try to find another brand/device to start using, something thats not $40/device.

I use all dumb switches backed up by a smart relay.

UPDATE Feb 2024
I have two of the Sonoff ZBminiL2 and had no issues as of yet but if I do I read elsewhere that people were trying this alternative and it does not have the relay click. It works and wires similar to the ZBminiL2 so I bought two of these to use in my other bathrooms and laundry room to operate dual switch fan & llights. You can get them with 1,2,3 or 4 load configuration with no neutral needed. So far they have been OK. One caveat is they will work with either a maintained or momentary switch input. I am using maintained switches on these but the sometimes it will work as if the switch is momentary. It is a minor annoyance which only shows up if youtoggle the switch quickly. They are the same small size as the Sonoff ZBmini but I only used one to operate both switch loads.

Here is thread mentioning more info on using these lesser expensive alternatives

Checking in if anyone else has these successfully working. I am replacing the Shelly Dimmer2 which worked very well for a number of years but was recently tapped out. I have purchased 2 Sonoff ZBminiL2's and they would be exactly what I need IF i could get them to work.

I've had HE for years, but am still stumbling around a bit. These units are simple and drop into pairing on first power up. They were seen by the hub but as other mentioned come up was a "Device" device. Unfortunately switching this to 'Generic Zigbee Switch' did change the buttons up to include on and off, but even after the hub had found the device, and been switched to GZD the ZBmini continues to flash as if it's pairing. And I have had the rare occurrence where changing the state with the software buttons worked a couple of state changes but then quickly stopped working. Seems oh so close.

I have see this same behavior with both units after at least 6 attempts with each unit.

I should mention I am on a C8 hub (that I recently migrated from a C7 mostly for the additional range - the migration process was very smooth and the responsiveness of many of my devices improved quite a bit).

Not having a neutral wire is a huge pain, but I don't really have many options so am willing to push on these ZDMiniL2's more if anyone has any ideas.

I have been known to make some silly mistakes in my attempts like this, so I hope I am just missing something. Thanks for any help.

A couple of other thoughts.

I don't see them in the zigbee ChildAndRouteInfo screen at all. I did leave one running for a couple of days to see if there was some type of delay.

I have added a zigbee repeater about 3 feet from the switch to see if that helps, and the switch is only about 15 feet away through walls or 20 feet around a hall. No real way to get the hub closer without bending spacetime.

I have about 10 of these in my house, 6 of them are controlling bathroom lights on a ring at the far end of my house from the Hub and another on the same ring controlling my extractor fan, They connect very easily and only occasionally will one of them remain on when all the other lights have turned off (or vice versa). I suspect there is a setting in Room Lighting I can use to help group them together but whenever I have experimented with this it makes it worse not better so I have left it as it is.

I've had them connected to both a C7 and a C8 Hub.

I'm about to install 4 more behind light switches that my wife wont let me replace as it would mean we would have cheap looking smart switches rather than the nice brass ones. Sadly they are double switches so I will have to artificially drill out a very deep section behind the switch to fit the 2 modules in with all the wires to connect them to the switches.

I have some of the older Sonoff modules, I think there are two other no neutral ones... I had one which would randomly turn on/off which I eventually replaced and was fine. All the others work the same as each other.

I have 2 in place and they have never shown up in that screen. I have numerous devices that don't ever appear. I'm running a C7 on using the generic zigbee switch driver.

Just to check, when you changed the driver, did you hit the "Configure" button afterwards?

Edit: Strikethrough, It does occasionally pop up directly connected to the hub. My assumption is that when it routes through a repeater, it does not show up. It routes the majority of the time.

Thanks user4286, that is a very extensive deployment. Happy to hear that is working well.

CAZ, not as a rule, although I have just tried that now, and it hasn't changed results. Steps were: initial pair, with 'Device' as device type. Changed to 'generic zigbee device', hit configure, then save device.

It will pair and work for 5-6 on/off cycles of digital control and then it freezes. Repairing resets this. As it sits now the device can manually toggle the light, but hitting off or on in the device configuration screen has no effect. I'm kind of hoping it's a zigbee mesh configuration issue and it magically come fully online soon?

The only other thing I can suggest is to change the Zigbee channel number, but I don't know for certain that would work and don't know the wider implications of this on your wider network. I'm not an expert on such things and others may have more specific guidance.

It does sound more like this is an issue. I know you said you have a repeater in place but not all devices play nice with all repeaters. As @user4286 pointed out a channel change might help if it's interference. If you can't control it at all from the device page it has likely "fallen off". My zigbee channel is 20. I ended up on this channel due to issues I was having many, many moons ago, long before I picked up the mini's.

FYI, I edited my previous post about it never showing up. So it likes my repeaters. Either older Samsung Smarthings outlet or the Iris ones. Both made by a manufacturer that went out business who's name I cannot remember, sorry. They were very popular. I picked up a bunch on ebay a while back as they were highly recommended by everyone.

TLDR: I'm chicken to reset the zibee channel - afraid of zigbee mayhem. Wondering if I got 2 bad units?

full story...

Yes, thanks for the comment. I will consider a channel change, but looking at a wifi analyzer (not sure that is the right tool) it seems all my other traffic is down the lower end of the scale - below 14? And after doing some reading on the slightly hit and miss process of the devices finding the new channel, given I have 25+ zigbee devices including repeaters, I am kind of hoping for another solution to pop up.

Another strange occurrence: About 40% of the time when I have installed either/both of the devices inline the manual switch functions to operate the light. The other 60% not. And just now, while trying a trick to put the device into pairing that I read about on reddit by 5 up/down switch flips, it did go into pairing, but stopped functioning to actually turn the lights on/off. Seems very flakey.

Any chance I got 2! bad units from amazon? 3rd time lucky?

I have quite a few of the ZBmini OG units around working fine with HE.

No matter what I try these things are completely unreliable.

Last week I hooked up a Sonoff ZbDongle-P to my HomeAssistant to start building a zigbee mesh off of it. Forgot about these two devices as they're just doing my son's closets. Wednesday night my wifi went down so I was going to the house tearing out all the remaining Wi-Fi devices I have while cursing myself for trying to save the $10 using them instead of zigbee/Z-Wave.

I then remembered about these two ZBmini-L I have in my kids room. Removed them from HE and flipped the light switch six times to put them in pairing mode. Searched for them via homeassistant and they popped right up and configured. So far every time I try them they work 100%. Not as fast as all my other devices I have on the dongle but they do work 100% of the time so far.

This is with Zigbee ZHA. They will remain on my homeassistant for right now.