Another Tuya Toy fails to stay connected with C8

@kkossev

I just bought one more Tuya Human Presence Sensor:

This one pairs with C8 (maybe pairing is not even 100% complete because
right red led is still blinking when C8 says it is paired) but not staying connected
with C8 any single second after pairing was complete (if it was).
So, this is one more Zigbee Toy which is not C8 friendly (at least at this time).

The same device is very happy with the C7. Connection seems to be very solid
(need more time to make sure it is a case). All configuration parameters are
instantly accepted. The response time is very fast.

Just in case here is what 4-in-1 driver is showing on the device page:
image

image

image

There are some Zigbee devices that will not stay connected to C-8, there are others that will not stay connected to C-7… I don’t think that there is something that can be done on a custom driver level, these connectivity issues should be investigated on HE platform level.

1 Like

If you search the web for the device model TS0601 you will find a wide variety of devices using that model number. I presume that the TS0601 refers to the chip in the device. However, that does not mean that the device is fully compliant with the Zigbee 3.0 standard.

This is/was exactly the reason for my message.

1 Like

I have had issues with non-standard Aqara Zigbee devices staying connected. Generally, devices listed as Zigbee 3.0 compliant will work. I did not see any reference as to whether the Tuya Human Presence Motion Sensor is Zigbee 3,0 complaint. It is suspicious in that it mentions WiFI. While WiFi and Zigbee devices use the same RF spectrum, they are not compatible.

The listing indicates that it works with the Tuya app, but it does not say that it works with Smartthings, Hubitat, Alexa or other Zigbee hubs.

There are 4 different devices under the same listing. First - there are wall mounted and ceiling
mounted version. And in addition each one could be either WiFi or Zigbee.
I am talking about Wall Mounted Zigbee Sensor.

I would be interested to know specifically about devices that do not remain connected on either Hub version where there are no routers involved, meaning all devices are directly connected.

Any issues like this we may be able to track down, we can't however control what an intermediate router decides to do with its children.

1 Like

this :+1:

@vitaliy_kh can you try to pair this device to C-8, selecting the "Pair while trying to avoid Zigbee 3.0 repeaters" option?

See also this report :

I will try this but unfortunately this will not be easy. The device is already a part of many
automations. Also on C8 I cannot shut down all Zigbee repeaters. First - there are many
of these toys. Second - I am not sure if I have Zigbee 3 repeaters. So far I simply did not pay
any attention on versions because everything works very well.

After testing on the C-8 hub, you can pair the sensor back to the old hub where your automations are already configured. All should continue to work.

You don’t have to power off all your Zigbee 3.0 routers on the C-8 hub. Just select the option “Pair while trying to avoid Zigbee 3.0 repeaters”, then hold the device pairing button for 5 seconds.

If possible, pair the problematic device close to the C-8 hub.

This worked now, when I tried pairing to my C-8 the two most problematic Tuya UK plug and XENON power plug extension !!!

:+1: :champagne:

Ok, I tried to pair sensor the way you suggested with C8. Unfortunately it did not change a picture.
I guess, pairing with C8 did not even finished because right side red led continued blinking even
after C8 said it paired this new device. I tried this process 3 times.

I had a BIG problem re-pairing this toy back to C7. The re-pairing finally complete after C7 was
shut down and power to C7 was recycled. Until I did this the device did not want to re-pair with C7.
I guess, the problem was on C7 side. Of course by doing this the device itself was factory reset.
I had to restore all my configuration parameters because driver is not saving preferences but
rather reading all settings from the device itself. This was not a problem and BTW, I like this idea.
I am back in business.

PS.
By any chance did you have a time to update a profile for the Cat Eye sensor?

I know that the non-standard Aqara devices are very picky about the repeater devices in the network. It sounds like these Tuya devices might have some similar quirkiness.

It is unlikely that the Hubitat staff is going to spend a lot of time trying to get non-standard devices to work with the Hubitat hubs. Since they cannot control which repeaters you have in your mesh, it is an exercise in futility for them.

BTW: I had a couple of Aqara devices that I got working on my C-7 hub after I replaced some older Smartthings and Centralite smartplugs from my Smartthings platform. However, when I migrated to the C-8 hub, they did not work. I decided it was not worth trying to mess around trying to get non-standard devices working. I replaced them with Zigbee 3.0 standard devices.

1 Like

@vitaliy_kh I am really sorry for the troubles you had following my advice… Myself, I stopped making such experiments some months ago because of the exactly the same troubles, but yesterday I was too much excited after the successful pairing of the two devices that I wasn’t able to pair to Hubitat for a very long time.

Obviously, the pairing issues with the XENON extension and the mmWave sensor are different.

Sorry, not yet, hopefully, will finish the update this week.
The 'Cat Eye' is the existing TS0601_YXZBRB58_RADAR profile, your device will be another new profile, I don't have an idea how to name it, rather than a trivial TS0610_SXM7L9XA_RADAR.

No problems.
I am a bit confused with these names.
"Cat Eye" sensor in the State Variables presented as " * deviceProfile : TS0601_TUYA_RADAR"
and in Data field it is " * manufacturer: _TZE204_sooucan5"
Currently the assigned profile is: "Tuya Human Presence mmWave Radar".
Sensor is working but but "detectionDelay" and "fadingTime" parameters are changing randomly
on its own. This is very strange behavior because the driver simple reads this values from
sensor itself.

The other sensor (flat white box) is : " * deviceProfile : TS0601_YXZBRB58_RADAR"
and " * manufacturer: _TZE204_sxm7l9xa"
This one already has an assigned profile "Tuya YXZBRB58 Radar".
It works very well. All configuration parameters are stable.

Both the above sensors refused to connect to the C8 hub but have no problem connecting
to the C7.

I don't have a "TS0610_SXM7L9XA_RADAR" device. I don't know what it is.

PS.
As of now I am absolutely unhappy with my two FP2 sensors. Both updated to the 1.1.9 firmware
but their reporting is very unstable and therefore these toys cannot be used in automations.

I am confused with all these different models too, that’s why I need to be concentrated fully and have enough time to summarise and double-check all, before I make any changes.

Additional confusion comes from the fact, that one and the same device firmware is put in different boxes. So what I call ‘Cat eye’ because of the specific sensor enclosure, may not unambiguously denote the specific model.

This weekend my wife is visiting her mother in another town, so it will be the perfect time to make changes in the driver! :grin:

Agree 100%. There is a BIG mess with different models/names/versions.

Unfortunately, that is the situation with Tuya. They develop the chips for devices, but they do not manufacture the hardware devices in which they are used. This can lead to some problems and much confusion.

Always look for Zigbee 3.0 certification.

Speaking of which, is there Zigbee certification (of any vintage) for the C-8, or any Hubitat device?

I can't seem to find it...

Certified Products Search | IOT - CSA-IOT

2 Likes

I hope that someday I will have the time to prepare a write-up with my understanding of why the widespread expectations that a device labeled by the seller as "Zigbee 3.0" will work with Hubitat are generally wrong.

Just use the CSA link above and search for Aqara, Ikea, Tuya, etc... - you will find a lot of Zigbee devices that do NOT work with Hubitat as being certified by CSA.

These Zigbee devices are certified as 'Zigbee 3.0' compliant, BUT - they do NOT follow strictly the more important standard - Zigbee Home Automation 1.2, which all home automation systems relay on. These CSA certified devices use manufacturer specific clusters and commands, which is allowed by the Zigbee 3.0 standard!

Aqara H1 Double Rocker is there 'certified' - this is the same problematic device that will switch on/off all of your Zigbee plugs and bulbs in the house when paired without a proper custom driver to Hubitat (or to SmartThings or to Homey, or to any other HA system, different from Aqara own hub). There is still NO driver for this device in Hubitat.

So, this "Zigbee 3.0" certification is generally useless for us as end users.

1 Like