Ambient Weather Not Refreshing

That could be a possibility. Not knowing the app was going to do it also. But I don't remember exactly. There is no virtual device with a assigned number in my list though just the one made by the app.

I just checked my WS logs and I don't see the error.

dev:19322019-04-10 01:54:07.839 pm debugWeather: [dateutc:1554929400000, winddir:254, windspeedmph:1.6, windgustmph:3.4, maxdailygust:15.9, tempf:55.4, hourlyrainin:0, eventrainin:0.52, dailyrainin:0, weeklyrainin:0.8, monthlyrainin:1.18, totalrainin:4.03, baromrelin:30.18, baromabsin:28.12, humidity:45, tempinf:69.3, humidityin:33, uv:2, solarradiation:265.47, feelsLike:55.4, dewPoint:34.42, lastRain:2019-04-09T22:35:00.000Z, date:2019-04-10T20:50:00.000Z]

That means you have 2 devices with the same DNI.

You can't have two Ambient Weather devices. Did you look at the other one that I posted?

That is the one I am using. He has added more child devices and it all works except for the refresh.

I believe I did the same thing when I installed it, I realized this after I kept looking at the device I created and didn't see the data coming through, then I noticed the device was automatically created by the app, and all the data was there, so I deleted the second device I created that was using the same driver, and always used the one the app created.

@razorwing needs to be asking this in the the original post and not this way.

Not what way?

Did you get the error I posted above and if you did how did you fix it? thanks

You are asking for support with a DH that is supported in another thread. Ask for help in THAT thread not by making a whole new post that the developer will most likely never read.

Please delete all the devices and apps for Ambient Weather. Make sure you have the latest code. Reinstall the app. It will create a child device. It should work after that.

I noticed the second device and removed the first before I checked for the errors, but @thomas.c.howard is the devoloper of this app, take his advice in the post above.

@thomas.c.howard I deleted the virtual device, deleted the App, I upgraded the app and device code. Re-installed the App. It created a child device. I watched for over a couple of minutes but I did not see any changes in any of the values.

Can you post the (past) logs for the app and device? When it initializes, it will tell a lot of information that is relevant to your issue.

@thomas.c.howard It still shows the same error that I posted up at the top of this thread. I cannot find any devices with a duplicate DNI.

app:14292019-04-10 04:06:25.853 pm errorjava.lang.IllegalArgumentException: A device with the same device network ID exists, Please use a different DNI on line 93 (updated)

app:14292019-04-10 04:06:25.810 pm debugInstalled

app:14292019-04-10 04:06:25.799 pm debugUpdated

app:14292019-04-10 04:06:22.030 pm debugGot stations: [[macAddress:EC:FA:BC:07:F8:91, lastData:[dateutc:1554933900000, winddir:319, windspeedmph:4, windgustmph:9.2, maxdailygust:13.6, tempf:28.9, hourlyrainin:0, dailyrainin:0.14, weeklyrainin:0.14, monthlyrainin:0.14, totalrainin:20.72, baromrelin:29.57, baromabsin:24.65, humidity:98, tempinf:69.4, humidityin:32, uv:1, solarradiation:106.19, feelsLike:24.5, dewPoint:28.41, lastRain:2019-04-10T20:59:00.000Z, date:2019-04-10T22:05:00.000Z], info:[location:Home, name: South]]]

I was able to reproduce this by installing the app if the child device (called Ambient Weather Device) still exists. The way the code works is this:

  1. When it initializes, it creates and associates a child device
  2. The Network ID is coded to be AWTILE-

The error being thrown indicates that there is still a device in your system with that Network ID (i.e it was not deleted properly).

Take a look at all your devices and verify there is no child device with that Network ID.

If it is still broken, something is amiss in Hubitat.

A possible band-aid to get it working:

  1. Under Advanced go to the “<> Apps Code”
  2. Select “Ambient Weather API”
  3. On line 93, change

addChildDevice("CordMaster", "Ambient Weather Device", "AWTILE-$station", null, [completedSetup: true]);

to

addChildDevice("CordMaster", "Ambient Weather Device", "AWTILE2-$station", null, [completedSetup: true]);

Note: This will not fix the underlying problem; a rouge device that is not deleted properly

Tried all that but no change. I now see a new error.

app:14292019-04-10 05:02:23.144 pm errorgroovyx.net.http.HttpResponseException: Too Many Requests on line 130 (updated)

app:14292019-04-10 05:02:22.733 pm debugSet CHRON schedule with m: 0/1 and h: *

app:14292019-04-10 05:02:22.127 pm debugInstalled

app:14292019-04-10 05:02:22.118 pm debugUpdated

app:14292019-04-10 05:02:19.596 pm debugGot stations: [[macAddress:EC:FA:BC:07:F8:91, lastData:[dateutc:1554937260000, winddir:49, windspeedmph:5.4, windgustmph:9.2, maxdailygust:13.6, tempf:26.6, hourlyrainin:0, dailyrainin:0.14, weeklyrainin:0.14, monthlyrainin:0.14, totalrainin:20.72, baromrelin:29.61, baromabsin:24.69, humidity:98, tempinf:68.5, humidityin:32, uv:0, solarradiation:72.79, feelsLike:20.34, dewPoint:26.11, lastRain:2019-04-10T20:59:00.000Z, date:2019-04-10T23:01:00.000Z], info:[location:Home, name:Brighton South]]]

Ok, we’re getting there. Just watch it an see if it updates in the next three minutes without an error. That last error is because the Ambient weather API has a max requests per minute.

Also, with debugging off, the best place to look for updates is on the device (not app) page. Look at the events. The time stamps should correlate to one update per minute.

Well I have tried everything I can, rinse, repeat, repeat, rinse, and everything in between and it still does not refresh. If I create a rule I can get it to refresh.

EDIT: Error seems to have gone away. Don't see any refresh still.

@thomas.c.howard I wanted to let you know that the error has gone away. The refresh seems to be working but it is at a 5 min. interval and not the 1 min. it is set to.

1 Like

Good to hear. This could be a limitation of the Ambient Weather device. Example: wind updates every 5 seconds (per configuration) but temperature updates every five minutes...

Download the Hubitat app