Amazon Alexa control reporting issues

I just updated my Hubitat this week, and since that time the group bulb dimmers I have Sengled white bulbs added (using Generic Zigbee Bulb drivers) to seem to not be communicating with Alexa completely.

The groups are joined to Alexa using the Amazon Echo App. When I ask Alexa to turn them off / on by name, the lights perform the command as expected but Alexa reports, " isn't responding. Please check it's network connection and power supply." This happens whether I turn them on or off.

The connected groups are "Group-2.0"

I had that issue once. I have two bulbs in my dining room grouped in HE. What seemed to solve it for me was to create a group in the Alexa mobile app. Name the group the same as the HE group dimmer, and include the group dimmer and the individual bulbs in that Alexa group. Boy that sounds confusing!:grinning:

See if that works for you.

1 Like

This feels like a similar issue to Groups App - inconsistent master/slave behavior for dimmer groups?

This is a variation of what I do. I'll run down the combo, then I'll test what I think is the difference between what you're showing.

Hubitat has added from a single ceiling light fixture:
"Kitchen 1" (sengeled white bulb - Generic Zigbee Bulb driver)
"Kitchen 2" (sengeled white bulb - Generic Zigbee Bulb driver)
These both are added to "Kitchen" group-2.0 (Group Bulb Dimmer).

The Kitchen Hubitat group is added is added to Amazon Echo App in Hubitat.

My Alexa app sees this group from Hubitat, and adds it under Devices when I searched for "others".

In Alexa, I have a group made named "Kitchen". This group has the Hubitat group named "Kitchen" added to it, as well as the echo dot in that room. I found that if the names were all the same you can use that dedicated echo to say "turn on lights" and it would rather than forcing you to specify exactly which lights for every command.

This works fine, whether I say either "Turn on Lights" or "Turn on Kitchen" in the example... the difference being after this last update, Alexa complains after every request, as noted.

The difference between what you're showing is that you appear to also have each individual light added to alexa. I will do that and see if there's a difference.

Potentially. I have been toying with setting the lights to dim in a "warning blink" when bedtime is near... the lights are great with on/off, but the built-in dimming is dicey at best. I would be more inclined to agree that these are related if it didn't work so well last week.

I'm guessing a recent update (or combo) from Alexa / Hubitat simply introduced a lack of response or failure to interpret success response in the Alexa app. I was hoping others had the same experience to help troubleshoot.

So to continue the previous update, I added the individual bulbs to Alexa; first in Hubitat Amazon Echo App, then in Alexa. Found them without issue, added them all to the same Alexa Group.

Same experience. Using the app to change any setting from my phone gives a "Device Unresponsive" error. Voice control still works the same, with successful action but the warning. :frowning:

Interestingly, it shows the color set to "custom" in the Alexa app despite them being white-only bulbs.

I was having the same problem before the update. Devices were showing as unresponsive in the Alexa app, Alexa would complain, but would control the devices. I deleted the skill in HE and disconnected HE in Alexa, then reinstalled and it was a little better. A few days later the update was released and for whatever reason it fixed my issue completely. Most of my rooms have grouped bulbs (Sylvania rgbws), using zigbee group messaging. Some have zwave plus dimmers and some have Hue lights. I have added the individual bulbs into some of the Alexa rooms as well as the Hue groups and HE groups. It doesn’t seem to make a difference.

Deleted the app in HE, deleted the devices in Alexa and set it back up... same issue. :frowning:

Deleted the Amazon Echo App in HE, forgot all of the associated light dimmer groups in Alexa, and reset them up through the Amazon Echo Skill per the instructions.

So far the issue appears to have been resolved by this. I will update in a week or two with whether it's consistent or not.

I just tried this and it didn't help.
Every command issued to Alexa is successful, but she returns "XXX is not responsive, please check the network connection and power supply.

Did anyone find a solution to this? I have a similar set of issues.

My set up is standard halogen Ceiling can spots in the Kitchen with GE/Jasco z-wave plus dimmer switches. 4 switches controlling 11 can Lights. I am using Botched1’s port of the SmartThings driver by nuttytree. This supports the native double tap of the switch and allows the setting of transition speed. This worked very well on ST and works very well in HE when using the physical switch or HE to turn the switch on and off. Transition and double tap both work flawlessly. Also the setting for the indicator light on the switch to be on when the switch is off works perfectly. I have set these switches up in a Group 2.0 group names Kitchen.

I have tried the Alexa Skill. I have added the HE group only, the individual switches only, and all of them to an Alexa group named Kitchen along with the Echo Show v2 in the Room.

When using Alexa skill the following happens:

  1. in the Amazon Alexa App the he devices and group show up as Lights not switches. The old ST devices showed up as Switches.

  2. when using the Amazon app and pressing the group Kitchen Group on the devices screen all Switches and lights turn on. When pressing it again only some of the light switches turn off. It is further strange that if you look at the physical switches, the indicator led lights reflect that the switch is off but the lights remain on. The only thing that will turn them of is pressing the physical switch.

  3. using voice commands I get the same results

  4. also in any scenario above when the lights do turn on or off there is no transition. They are instant on and instant off.

Any help would be appreciated


in the Amazon Alexa App the he devices and group show up as Lights not switches. The old ST devices showed up as Switches.

Groups showing up as lights makes sense as all groups in HE use the DTH "Group Bulb Dimmer" regardless of what is in the group. That tends to throw off Alexa and GH. Especially when you only have switches in the group.

However, I still have switches, that are actually switches, that don't support dimming, show up as lights in Alexa. For instance, I have a few Sonoff Basic switches. They aren't dimmers and the driver I use specifies the Actuator, Switch, Momentary, Polling, and Refresh capabilities. Yet, Alexa sees them as lights. My Harmony child switches, which specifies Switch, Sensor, Actuator, and RelaySwitch capabilities, show up as switches.

As for these, I'm willing to bet it is the On/Off optimizations in the group definition. If you go into the group, try turning off on/off optimization. You might also want to turn off group device indication as well and then give it a try from Alexa again. I've had the same issues as you on some of my larger groups and turning off on/off optimizations solved it.


Thanks for the reply, I have tried it with On/Off Optimization Disabled and with Group device indicator disabled and I get the same results.

Further observations suggest to me the failure to turn of the one switch (though the led indicator light reflects the switch is off) may be a driver issue because the one switch which doesn't turn off is a 3-way switch. The primary switch of this 3-way switch is identical to the other three switches, but it has a GE/Jasco 3-way Remote Switch wired as well. This worked fine in ST but is having a problem here so I suspect that is a driver issue. I am not sure if the instant on symptom is a driver issue too but i will be posting this in that thread as well.

Any further thoughts from anyone would be welcomed. Thanks,



Hmmmm, I would agree with that. Are you using the built-in DTH or a custom one?

I am using Botched1’s port of the SmartThings driver by nuttytree. This supports the native double tap of the switch and allows the setting of transition speed. This worked very well on ST and works very well in HE when using the physical switch or HE to turn the switch on and off. Transition and double tap both work flawlessly.

Yeah, I'd agree that it might be in the driver itself. One more thing to try to isolate the driver might be to turn on debugging on the 3 way switch (and possibly other switches using the same driver) and see what's being thrown out when using Alexa to control the devices.

I've seen some random issues with the driver, but nothing like what you are describing. You might also want to reach out to @mike.maxwell to see if there is anything that jumps out at him.

Just additional testing. I have an identical switch running the same driver on the dining room chandelier and it is not a 3-way setup. It is also not in an HE Group, just a stand-alone dimmer switch. When using Alexa to turn it on and off it exhibits the same behavior. When asking alexa to turn it on it comes on instantly without the fade in transition. When asking Alexa to turn it off the light stays on but the led on the switch reflects that the switch is off. So the problem doesn't appear to be related to the 3-way setup.

What is strange is that all 4 of these dimmer switches are identical models and firmware version numbers. but two of them are exhibiting this strange off behavior. All of them are exhibiting the instant on/off behavior with no fade in or out. These behaviors only happen when trying to control them with Alexa.

Wow, this is strange. I am about to start diving into the logs right now.

1 Like

To be honest, I've never had good experiences with Z-Wave+ paddle switches. I used to have about 6 of them and ditched them a couple of years ago for Zigbee ones. To be fair though, I've never had a good Z-Wave mesh setup either. My entire smart home is pretty much Zigbee, aside from a few Z-Wave+ outlets here and there.

My experience is just the opposite. I have about 25 z-wave plus paddles and only two zigbee. All worked flawlessly on Smartthings. I am in the process of migrating to HE and am now running across these issues. have you been on HE the whole time? Perhaps zigbee is a better solution for HE? That would be disheartening since I really like most aspects of HE.

I've been on HE for about a year now and came over from ST. I had tons of Z-Wave issues on ST. My small Z-Wave network on HE has been pretty solid though. Zigbee, on the other hand, has always been strong on both platforms.

As for Zigbee being better? That's a loaded question. LOL. My answer is always YMMV. Some people have REALLY strong Z-Wave meshes and some don't. That could be due to construction materials in the house or just choice in devices/manufacturers. For me, Zigbee has always performed better than Z-Wave, but I also have everything strategically placed to give me the strongest mesh possible.