All z-wave devices disappeared

Hub: C7 running

All z-wave devices disappeared from the z-wave details page (but still show on the Devices page).

Things I've tried that didn't help:

  • rebooting
  • rebuilding database
  • unplug power for 30 sec (seemed to help someone else in a similarly-titled thread)

Z-wave details page:

Z-wave logs:

Scrolling back through the logs, this is when things stopped worked:

On the Devices page, I count 29 z-wave devices. Sorting by Last Activity, only wifi devices have activity more recent than 5/4. None of my z-wave devices are Star Wars themed, so I see why they'd disappear on that date.

Any advice greatly appreciated!

Do you have Hub Protect? Can you restore a Hub Protect backup?

I don't know what Hub Protect is, so I'm going to guess I don't have it.

.140 corrected a z-wave issue in 2.3.8, as I recall.
Could going back to the last 2.2.7 maybe bring it back?
Or, is the radio info just dead and he's SOL?

I had the same thing happen to me when I attempted to upgrade the Zwave firmware using the β€˜/hub/advanced/installZipgateway718’ endpoint while running on a C7 hub. I rolled back to previous Zwave firmware by using the β€˜/hub/advanced/installZipgateway715’ script and all my Zwave devices reappeared on the Z-Wave Details page.

I had to hit the 718 endpoint multiple times before the upgrade finally stuck and my Zwave devices showed on the details page after the upgrade to version 7.18.3

Hope that helps.

1 Like

Interesting idea. I tried /hub/advanced/installZipgateway715, it said success, please reboot. After a reboot, no change.

I then tried /hub/advanced/installZipgateway718 ... same thing.

According to /hub/zwaveVersion I'm on 7.18 now, but still no z-wave devices :frowning:

Run the 718 endpoint until it says it’s already installed. Sometimes takes multiple tries. Then shut down and unplug for 30 seconds after that.

Check the location and hub tabs in the logs to see if it says anything about zwave crashing

Ok, worth trying.

Hit /hub/advanced/installZipgateway718 again and it says "already running v7.18.3".

But I hadn't pulled power since installing. After that, Z-wave details still show no devices.

The Location events has several entries for zwaveCrashed on 5/4, but since then only sunset and sunrise entries.

Did you do any updates around then? Otherwise it seems like maybe the zwave radio just died…

Maybe @support_team can check the engineering logs for more clues.

1 Like

Or, some freak event wiped the zwave radio db. @theamigo - can you try pairing a new zwave device to your C-7?


I was able to connect a new zwave switch. It's now the only device on the z-wave details page.

Clicking Z-wave repair took >3 hours (I went to bed and it finished by morning). It shows "Completed Nodes: 06" which is the one test device that I just paired yesterday.

Anything else I can try or am I done?

1 Like

Unfortunately, it looks like the z-wave radio db is toast. Not only is your new device the only device listed, but it has a node id of 0x06. Memory says that 0x00-0x05 are reserved in the C-7 and C-8, so the z-wave radio literally thinks the new device is the first node to be paired to it.

I don't know how old your C-7 is, but this could be an indication of more failures in the future. Therefore, I would do the following:

  1. Reset the z-wave radio.
  2. Exclude all your devices and pair them again.
  3. Fix all your rules and apps.
  4. Get a Hub Protect subscription so that online backups that include z-radio data are saved. Should your hub fail while the Hub Protect subscription is active, it will make it easy to be back up and running again with a new warranty-replacement hub.

It would be interesting to see what's happened to the automations - should we assume that all the references to the lost Z-Wave devices are borked so Swapp Apps Device isn't an option?

1 Like

It will work for those devices that support it. So no child devices.

1 Like if @theamigo wants to he could create virtual devices and swap them into the automations to replace the missing real devices, and re-swap when he re-joins his devices. That should save time if devices are used in multiple automations.

Just so you guys know .. this happened to me also 5-9-24
Was doing some stuff with removing z-wave switches and replacing them with zigbee.
I also lost ALL Z-Wave devices nothing showing in settings / z-wave.
Tis happened after I did a " soft reset " to clear everything.
I was able to get everything working again because of cloud backups.
Was weird because a " soft reset " Is Not to touch the Z-wave and zigee radios :frowning:

Did you report this when it happened? I don't remember...a soft reset should never affect the radios AFAIK.

If you see anything like this again, make sure you report it to @support_team. If you haven't yet, you should PM them your hub UID so they can investigate.

1 Like

No I did not .. I got it working again .. so I didn't report it.
Took a few trys to get stuff working .. also weird ..
seems like it was re-adding the devices I was removing back automatically
Also .. as I was removing z-wave devices. it seemed to making ghost devices.
Took awhile to get rid of them all so I had a clean z-wave.

Also the log does not show I did a restore. ( I do not think anyway )
Also just noticed it to me over 2hrs to do it :frowning:

OK - go ahead and PM hub UID to support team w/description and links back to this topic. Important to report in case a new issue is emerging that needs attention (vs. some one-off issue). :slight_smile:


You missed a critical step. Since the old "device" entries are still in the hub, the DNI of each one should be renamed and add _OLD to them (also add OLD to the name). This will prevent new inclusions from assuming the old devices which may not have been the same device being included. It will create a GIANT mess if you do not do this.

Once new devices are included you can use Swap Apps to move the automations over, then remove the old devices entries after swapping.