All backups failing

My C8 Pro (now on has been failing for both local and cloud backups, whether manual or schedule for a few weeks now. I have been watching the threads of others with the issue and assumed I was suffering similar issues that were attempting to be addressed through recent releases. However, after a couple of builds not helping, I'm getting desperate. I've been running for some time with no such issues. Last scheduled back successful was 3/4. I've done shutdown and interrupt power load several times, I think I did the purge events log I saw on one thread. Nothing changed.

Yesterday I applied, and I now see (and have downloaded) a local backup at about that same time. I guess the release update does a manual backup and it worked ? But gain at 3:01am both local and cloud backups failed, and I still cannot do either manually.

I have not done reboot with rebuild database, out of fear of not having a database if that fails.

Any advice is appreciated.

Looks like the first fail is the database which leads me to believe it needs to be rebuilt. How far back is your last good backup?

1 Like

Last automated good one was 3/4. And I did a lot of work since then. But yesterday when I applied a manual backup showed up, which I've downloaded. So assuming that is good it was yesterday.

Okay, let's try a reboot with database rebuild then. If it errors out we can do a soft reset followed by a restore from the back up you downloaded.

Thanks. It's going now, fingers crossed.

Well, it didn't fail. But it didn't fix the problem. Immediately after reboot with rebuild I tried cloud backup with exact same results.

Also, I now have a new local backup from today with the timestamp of when I was doing the reboot with rebuild. So backups seems to be working when part of an update and/or rebuild. But not when initiated by me or scheduled.

Did you try a manual local backup? That is different from a cloud backup.

Also, set your timing of your automatic local and cloud backups apart from each other as a test. The local backup only does the hub database, the cloud also adds z-wave and zigbee. It could be the z-wave part that is causing the failure, it has been an ongoing issue. Possibly if they were both running at the same time the cloud failure was also causing the local failure is my idea anyway.

The manual local doesn't give a fail error, but I don't get a backup file. I get an .html file. Also, I will change the times of the scheduled ones, but I they don't both run every day. Scheduled local still fails on days when the scheduled cloud backup doesn't run.

Actually I don't see a way to change the times for the backups independently. There is only one input for backup time. Then I can the frequency for local and cloud (currently daily and every three days, respectively).

You're not alone. I'm having the exact same issues with C8 after updating to .128.

I've been having it since .122 or before. I was being patient. But I saw a post for at least one person who said .128 fixed the issue. Not for me. At least I see I can do a rebuild and somehow got a recent local backup and downloaded.

Ok that might the case, I dont have hub protect so I was not sure if the times could be set for both.

This is a bad sign. There is at least 1 other case of this in the past might be able to find it with a search. First thing I would do is try a different browser and try an incognito window as well to make sure no browser plugins or cookies are causing an issue.

Can you post a screenshot of your backups page showing the history with the file sizes?

I am thinking that if you can get a good backup downloaded, you may need to do a soft reset and restore to fix this. Not sure why the rebuild did not fix it. I want to see the file sizes as that might be a hint as to if the backups are any good or not.

@support_team @bobbyD any other ideas? We now have two people with same issue.

1 Like

I have tried multiple browsers and devices on the manual backup, with similar results, unfortunately. Saw those threads too. I do have a couple of manual backups that showed up (one during .128 upgrade yesterday and one during rebuild today) and I have downloaded.

I upgraded from .118 to .128 yesterday so that's why it's new to me.

Notice the jump in file size on 3/4, with .122. Then back down with .125 and .128. And the 3:02 am backups before are the last time backups worked right.

Could you please send me a private message along with your hub id so we can further investigate?

Yep. I see evidence it was the .118 to .122 update where it started for me.

The file sizes are small, which could just mean you dont have a lot on your hub, but mine are all 4mb. I do not have a TON of stuff but it might depend a lot on your state history.

Do you have the Hub Info Driver v3 where you can see your database size? In comparison mine is around 7Mb right now and my backups are 4Mb.

@zerosum74 You should use the diagnostic tool to revert to the prior firmware and see if it fixes it. @bcfl22 you could try the same if you have an older 2.3.8 build in your diag tool still.

EDIT: I see Bobby replied, so you might want to send him what he asked and wait for him to check things before reverting firmware just yet.

1 Like

I don't have that on here. I beleive I am in the hundred or so devices range by now (44 coming in through Kasa integration alone) many zigbee and zwave directy on hubitat. And few smaller integrations.