Alexa Routines stopped working

It seems that Hubitat cannot trigger Alexa Routines any more. Alexa can see my Hubitat devices and control them, but when a contact sensor opens, or motion sensor detects motion it show correctly in the Alexa app, but does not trigger the Alexa Routine. Voice Activated and time based routines work correctly, its just Routines using Hubatat smart devices don't work any more (all of them). They all stopped working June 16 evening.

1 Like

That would indicate the issue is with Alexa, and not Hubitat. FWIW, a test notification routine using a virtual contact sensor worked fine for me.

2 Likes

Aaiyar, You and I have talked about this to death. The problem is with Hubitat Alexa skill NOT Alexa. Why? The EXACT same sensors work perfectly fine when we ran them through smarthings / smarthings Alexa skill. (Literally the only difference). since I've switched back over to Smarthings, the sensors now work perfectly to activate my Alexa routines. (Motion/ no motion detected)

We already ruled out the hubitat hub was working fine, we also assumed at one point it could of been Alexa (perhaps on a slow AWS server or something) that proved not to be the case, the finger points directly at the hubitat Alexa skill.

I posted my issue here June 18th after wrestling with this a few days. What he's saying matches up with what I'm saying timeline wise and I don't think that's a coincidence. It's not an issue with Alexa, if their was AWS resource strain, I'd expect similar problems to happen with other skills like smarthings but no, it works fine. Alexa isn't just picking on hubitat here it's the hubitat Alexa skill.

Hubitat support isn't looking into this as a problem. I've reported this to support and got no help. I also reported this to amazon Alexa support and they were just as helpful.

I believe at one point during testing you also experience what I did. Subsequent testing hasn't necessarily matched but Regardless if you experience it to the same degree it shows there's inconsistency with the skill. Others in my post also had issues getting motion to trigger routines or the lack of motion.

I can see the temp readings on the Alexa app from the contact sensors I have on my doors but I cannot see the contact sensors themselves — therefore no routines can be established. I have had this issue for a while. They work on ST but not when I have the contacts set up through HE. I have tried all the delete and install, reinstall several time and I just can’t see anything but the temp readings. Odd.

I think my issue is that I added the Alexa Skill app in Hubitat then added the Hubitat skill in Alexa app. You are only supposed to add the Hubitat Skill in Alexa and it automatically adds the Alexa Skill app in Hubitat. At one point I had 2 instances of the Alexa Skill app in Hubitat and I probably deleted the wrong one.

So I had to remove all of the Hubitat devices in Alexa app. Disable the skill in Alexa app, then remove the app from Hubitat. I then added the Hubitat Skill in Alexa app and then did a discover devices. It automatically added the Alexa Skill app in Hubitat. I then did discover devices in Alexa and it found them all. I was then able to use those devices with Routines.

3 Likes

When you added the Alexa Skill app in Hubitat did you do it through Hubitat (that's the wrong way)? I think you are only supposed to add the Alexa Skill app in Hubitat by adding the Hubitat skill in Alexa. This automatically adds the Alexa Skill app in Hubitat and allows it to work correctly.

Try deleting all of the HE devices in Alexa (easiest/fastest way is through alexa.amazon.com). Then remove the Hubitat skill in Alexa, then remove the Alexa Skill app in Hubitat. Make sure your Alexa app is up to date, then add the Hubitat skill to Alexa and then discover devices. You shouldn't have to do anything in Hubitat.

my system was working fine and next day Alexa stop working on all devices. Amazon changed something because tuya devices stop work couple days before. Tried to reload skill able connect but now it states server is not responsive.

I am so thankful I found this thread. I could not understand why my contact sensor shows the correct open and closures in the Alexa app but my routine based on it won't fire. It was working, but I added the skill to my wife's phone (separate Amazon account and separate Hubitat account) and I think that's when it stopped working.

So I deleted everything on both sides. Added the skill to my Alexa app and chose devices. The app automatically added to my hub. Added the skill to my wife's Alexa app. The devices I previously selected where already ticked off. No dice.

So I deleted everything again and just added to my phone, not my wife's account, and it's still not working. Any thoughts? Echo Speaks seems cool, but it seems like overkill for the one and only routine I need Alexa to speak.

Download the Hubitat app