After C8 upgrade, Jasco ZWave Plus Switch Not Working Well

I have a Honeywell UltraPro Z Wave Plus Switch that's not behaving as expected: Any physical commands such as taps, doubletaps, etc are not coming through while any digital commands do.
What I have done is ensure it has been excluded, air gapped, cut power from breaker, and also factory reset via the three up taps followed by three bottom taps.
When I go to Z-wave include, it asks me whether to include w security or not and I choose no security. It then appears as a Jasco Dual Outlet but then I switch it to the 'Device' driver and delete the child devices. Then I switch it to the Enbrighten switch that my other switches are also on (and this one was on w the C4).

Please let me know if there anymore I can do to figure this out and get it working like my old C4 setup...

After you change the driver Type and click SAVE, have you clicked CONFIGURE? This is necessary after manually changing the driver Type.

1 Like

Yes, I have always hit the configure button and waited a few moments...

Update1: One thing I just noticed is that this ZW4008 is on FW 5.53 and there is a 5.54 available. I will try this update and let you know..

1 Like

Hopefully the FW update might jog something loose...I only have GE/Honeywell (all Jasco) switches and have never had to update the FW on any of them to get them to pair/work reliably.

Just to be sure I get what you're saying - I assume the switch controls the light as expected, but nothing you do on the switch is getting reported on your hub, correct? So you turn the switch on and the Device page and device Events (button at the top of the switch's Device page) also show nothing happening? Logs for the switch are also not appearing when you turn the switch on or off?

1 Like

Yes, @danabw , that is correct. I should also note that I had rebooted the C8 hub and repaired ZWave and waited for a while for it to get feedback from the switch but no joy....the fw update is going slow (at 17% from time of last post).

I'm hoping this isn't another Jasco quality fiasco but it's been working so well with my C4 I'm wondering what is going on now...

1 Like

Yeah, I suspect the switch is fine, since it worked on the C4 normally and it's not like you removed it from the wall or anything. All of my switches/dimmers came across on the C8 migration so I haven't paired any to the C8 yet. Everything else I've tried to pair (Zigbee or Z-Wave) has worked so I appear to be in the group of users not experiencing some of these odder issues.

Have you tried a "Refresh" on the device page after making a change on the switch, to see if the change is then reported?

If you can let things ride for a few days your Z-wave mesh/communication may resolve on its own. Hard to predict, but something to try. In the short term you may be able to set some of your automations to "force" switch changes so they work for you even when a switch isn't reporting the truth.

1 Like

This seems kind of weird to me.
It's almost as if the switch was actually behaving as an outlet.
The other switches were discovered okay?
When you say you delete the child devices, you just didn't switch the driver to the Enbrighten switch? And then configure?

I have a house full of the Jasco zwave plus toggle switches and they've been great and also migrated with no problemsn.

Supposedly a known issue w Hubitat.

When the switch gets added, it shows up like the thread linked above mentions. What I do is change over to the 'Device' driver, then hit 'Delete child devices' and then switch over to the Enbrighten Smart Switch driver, then hit configure. I wait a couple of moments and then I turn on and off the switch via the Hub and it works. But when I physically press the switch, the C8 gets no feedback at all. Yes, I do hit refresh on my Events page to ensure that I have the latest info from the Hub.

I used to use this switch in a double tap scene on my C4 so just need to get this working again...

I've been using @JasonJoel 's drivers exclusively with good luck, but that shouldn't make a difference.

I never had to add anything after i migrated from c7 to c8.

Whether or not it made a difference, I think you're operating on old info there with older switches.

1 Like

It looks like a fingerprint issue - the hub has the switch's info incorrectly mapped to the outlet driver. Can happend, less so over time as HE has consistently updated their driver mapping when issues are reported. I tagged HE's Z-wave lead (Bryan) on the last reporting of this just recently. Should get updated "soon." But in the meantime doesn't cause any real issues as long as you delete the children using, change to the correct driver, and hit Configure.

i just had a zwave dual jasco plug die.. got alert that the device was making the hub too busy.. would not turn on off.. seemed to be cycling itself.. unplugged and plugged in.. and it would not work manually either..

swapped it out.. first (ie not switch) plug that i have had die on me..

I also had one die, and also the only plug I ever had that died. In its defense, I had it outside for two-three years, and it's not rated for outdoor use, so I felt I had to forgive it.

Hopefully Bryan will have time to look at the fingerprint info and fix the incorrect association of the dual plug driver w/the switch.

mine got the correct driver.. probably different device than yours jasco dual with usb as well as outlet each can be controlled independently

The firmware update didn't go through. Spent a lot of time on it but no joy. Dont know what else to do at this point. Maybe I'll try excluding and waiting a day or so before including.

So, I guess you have to re-include the device after firmware upgrade. I did a factory reset on it before including it again though. Now, it shows up as a "Generic Smart Scene Dimmer" and when I switch to the Enbrighten driver (may not need to), all functions work along with proper reporting.

Phew...this was an adventure I do not want to repeat but over all a great success :slight_smile:


Good to hear...odd that a FW update would be required, I've never seen a Jasco switch that didn't work out of the box. Must have jiggled something loose that was blocking reporting. But good new is good news! :slight_smile:

My guess is that it didn’t include properly the first time and the exclusion/reinclusion is what fixed it. I had a few Ring motion sensors out in the garage and couldn’t get saved parameters to have any effect. I excluded and reincluded them and now they’re working perfectly. They are the farthest devices from the hub and I probably shouldn’t have paired them in place, but they are directly connected at 100k now. Freakin awesome z-wave experience on the C-8 (zigbee as well).
ps don’t be a hater @danabw

1 Like

IDK...I probably went through half a dozen include and excludes before even attempting to update the FW.

I dont know what the exact fix was as it's all voodoo magic to


:point_up:t2: Me too


I had the same issue with 4 Honeywell/Jasco ZW4008 paddle switches running FW 5.53. They worked fine on ST, switched over to HE C8 a couple of days ago and the switches showed up as 'Jasco Z-Wave Dual Outlet' that resulted in 2 switches for each ('Generic Component Switch'). Tried multiple exclusions, resets, power off, re-inclusions, etc.

Did a search yesterday and found this post. I updated to FW 5.54 with Device Firmware Updater (each switch took a long time to update.) After the FW update, I excluded each switch, reset and re-included. Switches now show up as 'Generic Z-Wave Plus Scene Switch' and work like they are supposed to through the hub.

It's great to have all of the experience of others here or the switch over to HE would not have been as easy as it has been so far--I have 3 Schlage non-plus ZW BE469 deadbolts that were easy to add with all of the tips I found here. So far the lock code manager and auto lock apps are working flawlessly and so much faster with the local hub.

1 Like

You actually didn't have to go through all that. You Could have simply changed the driver to Generic z-wave plus switch and then clicked configure and all would have been good. (Not that updating the firmware is bad)