Aeotec Z-Wave eTRV issues

Hello everyone,

I installed some Aeotec Radiator Thermostats (Aeotec eTRV by Scruffy-Sjb driver) so I can control the temperature in each room and I have some issues I was hoping someone with more experience (it's my first time using z-wave) can help me out. I will number the issues so they are easier to reference.

  1. One of the eTRVs (the first one installed out of a total of 3) has S2 Authenticated active while the other have none. One possible issue might be that the installation process was not clean for the last two: HE attempted to show a dialog when it detected them during inclusion but it was an empty HTML element. Eventually I refreshed the page and the eTRVs was there. The same thing happened to the last one. Since I have a small apartment they all connect directly to the bridge and I don't seem to have any connection issues.

Is there any way to switch on S2 without running the inclusion process again? Maybe Authenticated if possible?

  1. I was thinking of upgrading the firmware and found a driver that can do that but I can't find any firmware on the official website (they are discontinued). Is there a safe third-party firmware repository? Alternatively I guess I'll just contact Aeotec.

  2. They don't seem to update. I waited over night and there was no update to the reported temperatures in HE. Is this normal? I was expecting HE to receive updates so I can let the boiler know when to turn heating off (if no thermostat needs to heat a room the boiler should not be running - I replaced the "dumb" house thermostat with a Shelly1 to turn heating on and off from HE). To fix this I created an rule in RM that sends a refresh command every 5 minutes (might increase it to 30 minutes).

Is this normal and is refreshing from HE the right approach?

  1. I've created a rule in RE to turn the boiler on when a room needs to be heated:

Trigger events:
Heat setpoint of Living Room Radiator(25.0) reports > Living Room Radiator(26.71)
Heat setpoint of Bedroom Radiator(25.0) reports > Bedroom Radiator(26.16)

Actions to run:
On: Boiler Shelly1 switch

This rule doesn't seem to run but works if I click the "Run Actions" button.
What am I doing wrong?

Sorry if these are stupid questions or if I'm doing stupid mistakes but I can't think of any other solutions.

Thank you.

If you want them to have S2, you will need to remove them from Hubitat and re-pair them. You should also do a reset if you can, just to be sure. Is there a reason why you want them to have S2? I have spent a bit of time of late to remove S2 on devices that didn’t really need it.

I can’t answer your first question, but have found Aeotec to be quite responsive in the past. I would definitively go that route.

Are all 3 having this problem, or just some of them? If you look at the devices’ event screen - is there anything in there?

Your trigger is asking for the rule to run when the setpoint temperature is greater than the radiator temperature - is that intentional? Seems you would want the opposite, unless the radiator temperature detects the temperature of the room and not that of the radiator?

You will also want to add an off command - I would recommend a Wait until the temperature is where it needs to be for X minutes, then turn off your Boiler Shelly1 switch.

  1. I was just thinking that S2 should be enabled by default. Is there a reason it shouldn't?

  2. I've sent a message to Aeotec support regarding the availability of updated firmware.

  3. If I send a command the devices will reply back and update a bunch of values but I don't think I've seen them send updated unless I "conctacted" them first. The driver has a refresh rate preference but it doesn't seem to help. RM was the only solution I found.

  4. The numeric values listed above was just what I had in RM at the time and they are dynamic so in that case the rule should not have run bun once the comparison becomes true I expect the rule to run. So if the thermostat is set to S and that S is higher than the actual temperature value T, Shelly should turn on the boiler.

I do have an off rule which is the reverse of the above but I think I'll change it a bit to have everything in a single rule. I was thinking something like: if S > T turn boiler on for 10 minutes, if boiler is off. That way the boiler should default to off and turn on when needed, every 10 minutes.

S2 creates a bit more traffic, though not as bad as S0. There are also sometimes issues when using security that can be avoided without.

See:

Z-Wave Plus devices should not need to be polled - they should provide their updates to the hub. I am not familiar with the Aeotec eTRV or why they wouldn’t send unprompted updated - would also be a good question for them unless someone in the community knows more about those devices.

I don’t know enough about how a boiler works, but as a general rule, I would want to keep the heat on until the room is a bit warmer than what I set it to, so I would do a wait until temperature in the room > set temperature for maybe 5 minutes, then turn off the boiler - but requirements might be different with a boiler…

1 Like

My biggest problem right now is that the rules don't trigger at all and I'm not sure how to debug that. I'll play around with RM more.

If you haven’t already, try enabling all the debug options of your rule, but especially the trigger one. You should also enable logging of those triggers to ensure that the events do actually occur.

The Refresh Rate in the driver is designed to get the eTRV's current values, but really it's a mechanism to get the device to Check-in so that if it has not reported changed values we can monitor if it's alive or not.

You should see Event's being logged in the Device Events like this:

Check
image

In the above case I have my eTRV to automatically report to HE any temperature change of half a degree C or more.

Also check
image

And Enable them.

The driver should work for you....... Scruffy-Sjb

1 Like

That did it. The push notifications were disabled. Thank you.

I've also set the rule to turn the boiler on/off on a time trigger (every 15 minutes):

IF (
    Heat setpoint of Bedroom Radiator is > Bedroom Radiator OR
    Heat setpoint of Living Room Radiator is > Living Room Radiator
) THEN
    Log: 'Turning on'
    On: Shelly1 Switch
ELSE
    Log: 'Turning off'
    Off: Shelly1 Switch
END-IF
2 Likes

In case someone will stumble upon this thread and wonder about the firmware, I got the official answer from Aeotec:

Version 0.16 is the only and last version.

Download the Hubitat app