Aeotec Smart Switch Gen 5

anyone used one of these yet? It is found asa device and I have tried just about all the different switch types, and no control yet.

I'm in a similar fix.

I was told that the generic z-wave smart switch driver was the way to go, but no luck.

Does anyone have one of these working and if so, what driver did you use?


I'm using the Aeotec Smart Switch 6 (not 5) and I'm using the Dome On/Off Powerplug driver. No idea if that helps or not :frowning:

nope, was told not supported. I didn't try past that.


I'll give that a go and report back!

No luck, unfortunately.

Sad face.

Compatible switches seem few and far between in Australia!

I own couple of these and have them working except no power usage monitoring. Would be good to have them fully working.

Would you mind outlining how you have them setup?
Which driver are you using?
It would be great to get them working.

I just held the button on the side until the light started flashing and then ran Hubitat scanner and it found the outlet. I don't remember the driver I am using but try Aeotec Smart Switch 6 or Generic Outlet driver. I will check the driver once I get home.

That would be awesome, thanks.

I've tried both of those drivers, but they don't seem to work for me.

I have just checked and I am using Aeon Outlet driver. The hub also receives the value for the power consumption when the outlet is turned on/off but otherwise there are no updates. The value of the energy on the dashboard tile does update at all for me.

TP-link outlet works perfectly with Hubitat. Have you tried that?


I'll give that a go when I get home.

I don't think I've tried that one.

I've tried the Aeon Outlet driver, but nothing has changed.

Smart Switch is paired, and says ACTIVE under settings, but I don't seem to have any ability to control the switch. It's just on, no matter what.

Weird that it works for you.

You definitiely have Aeotec Smart Switch Gen 5 do you?

This is the one I bought.

Have you tried removing it and pairing it again?

Yep. That's the one I have too.

I've tried reboots, removing, repairing, swapping USB dongles between ports, not using the USB extension cable, basically everything I can think of.

The fact that you have these things working though gives me hope.

Either I am consistently doing something wrong or my hardware is defective.

At least now I have a confirmed working driver, however, so I will continue to troubleshoot.

Maybe a hub factory reset is next?

Thanks for your help!

I am getting concerned now. I am planning to reset my Hubitat in couple of months, hopefully I won't have any troubles after that.
I have another one which I haven't paired yet so will try that and let you know.

I've tried a factory reset, but no change.

I can pair the switches, but just can't get them to work.

I now just see the 3 switches listed as "Status UNKNOWN" with the Aeon Outlet driver, so I've actually gone backwards! I've found other internet forums where people report success with this driver, so it seems to be just me.

Are you using the built in z-wave US transmitter or the AU dongle attached to the short USB cable provided?

I'm trying to use AU plugs with the AU dongle, so there shouldn't be a frequency issue.

Does it matter which dongle is on the USB extension or which USB port they are plugged into? I think I've tried all the combos so I'm now completely at a loss!

They do work, I am in Oz and currently have 2 working no problems.

I would try working with one at a time. delete/exclude all of them and then try a discover again. Make sure you wait for it to setup then press Save. Go into the driver page , name and select the driver Aeon Outlet driver again, re-save and see if it works then...

I have just tried another one I had and could pair it first time but it didn't work properly so I force removed it but then couldn't pair it again. So, I am in the boat as you now :slight_smile:

I am using whatever came in the box. I have ZigBee(using USB cable) and Z-wave dongles plugged in from left to right.

I don't think it really matters. iirc, I matched the colour of the dongle with the USB.