AEOTEC Recessed Door Sensor Gen5

As part of my slow migration from Vera to Hubitat I am left with the last sensor which does not seem to be providing the status if not the battery level.
I been reading a few threads but not got to a solution myself.
I have added the Sensor Using the Gen7 option and obviously not working.
I have added it a generic ZWave device, still no joy as I do not even see the battery level.
Any advise

I think the Aeotec recessed door sensors prior to Gen 7 just use the Generic Z-Wave Contact Sensor. You can manually select this from the device page under the drop down labeled "Type".

Did you hit the "Configure" button after changing the driver to the Generic?

@Eric.C.Miller I have used the generic ZWave and Contact Sensor, but nothing happens.
I have also pressed on configure but nothings happens after I pressed configure.

Did you get it resolved with the recessed contact sensor? Working alright? I have 2 that I'm going to bring over from ST.

Same issue here, the gen7 driver doesnt work for my gen5 and the generic contact sensor only provides an open/ closed state.

On top of that, the device is capable of firmware updating (OTA). I made a summary of updating zwave firmware here;

But now i have the hex file, but no driver support. Anyone else had any luck porting a functional driver from ST or finding a custom one? Responses would be appreciated!

EDIT: i found that @krlaframboise wrote a deiver for the gen5 siren (which i also have). Kevin, would you be able to open up some functionality on the gen5 recessed door sensor?

I've been using the Gen 5 for a long time

using the built-in Generic Z-Wave Contact Sensor.

Screenshot 2023-01-03 at 11.43.14 AM

1 Like


Hmmm so what are we doing wrong then? Bridge ( and zwave (7.18) are both updated.

(Besides from the fact that this will not solve my firmware update issue probably, but all steps are welcome)

The battery Attribute exists in the driver. But the physical device must send a battery report to cause the display to show.

It's a battery device so you can wake them, stick a something in the tiny hole for 6 seconds I believe and it stays awake for 2 mins ?? (those numbers are from memory, don't trust 'm)

While awake, click Configure in the driver. Otherwise you might wait a day for it to wake. The config just waits otherwise.

Screenshot 2023-01-03 at 12.12.43 PM

1 Like


I tried opening and closing and i tried activating by pushing the button via the pinhole to no resort.

So now im down to waiting a few days and see what happens.

well.. you could try what I suggested:

I just tried it on one of mine.. the manual says 6 seconds, mine seem to be 8... but the led blinks to tell you to stop pressing. Then it comes on solid for that extra time. In that time, click Configure on the driver info page.

1 Like

@csteele EDIT: that last sequence you described did it!

Hitting the configure button during the awake state!


Thx for the hints and tips! Much appreciated :muscle:t3:
Now on to the firmware update thing (which isnt available for now using the generic driver…)

1 Like

By enabling debug and having the log page ope too, I captured that there are messages pending that get send when awake... ONLY

Aeon does not supply their firmware to Hubitat to include in the update feature. I have one ZWave USB stick as a secondary controller for each of my 3 ZWave hubs. Therefore it's easy for me to use my virtual Windows PC to do a firmware upgrade. If I didn't have that I'd probably dredge up the Community Driver that does upgrades.

Screenshot 2023-01-03 at 12.41.55 PM

It can be found in HPM.. search for "firmware"


Well my gen5 siren supports it from within Hubitat and Aeon provides firmware updates for a lot of devices (referring to my post earlier).

I was able to extract the .hex data from the available .exe firmware update 1.15

But the geberic driver doesnt support the update option from the Zwave device frimware updater.

Two screenshots as referral

Again, it's a battery device and it will NOT respond if it's asleep.

It's likely that you'll have to be doing the 'press-for-6-seconds' gimmick 3-6 times per update.

I'll repeat... Aeon does not give the extracted firmware to Hubitat (which implied permission to distribute) to use.

Battery devices are a PITA to update, you need to wake it up. Its a shame the app is not setup to detect a battery device and then wait for it to wake up instead of just sending the command into a black hole.


I heard you :yum:, it just isnt easy to post and configure at the same time… :sunglasses:

EDIT: ok getting closer! Using the built in firmware updater AND putting the device in awake moder im able to at least pull the current version information and point to the hex file i made earlier today.

And there it currently stops … me sitting besides an open door in the cold…

and the darn developer is just letting this beautiful tool lie around in the rain, getting rusty. :smiley: :smiley:


I second that…

But look…. :scream:

Thx again for your patience @csteele