Aeotec Multisensor 7

I bought a Aeotec multisensor 7, six-in-one. It says it Contains Monitor Motion, Temperature, Light, Humidity, UV, and Vibration. When i set it up in Hubitat and try to create a new Notification with it, it does not show when I choose the Vibration Sensor as the type of device. It will show up if I choose Temperature, Humidity, Motion. Any suggestions?


Physically cause a vibration then see what event it registers as in the Events for the device. The driver might know it by some other name like acceleration

Has anyone noticed that the built in driver for this new device doesnt seem to have the sensor capability? This is causing issues in how other features and such see it and what they want you to be able to do with it. How does someone report this as a potential bug?

1 Like

I'd send an email to support.

Support no longer monitors email.

Tagging @bcopeland since he maintains Zwave drivers.

1 Like

Try selecting your Multisensor 1 as device, then use attribute in rule setting or dashboard. This should access UV value and perhaps others of interest.

I just bought two of these sensors and they worked well.. For about 2 weeks, until one ran out of battery and the other behaved strangely. Put in New batteries and they both now work again, but I am worried they will stop working again quickly and last time I didn't receive a battery notification.

Can the driver be amended to include battery and vibration? One feature I also like from other motion sensor drivers is a way to enable motion for testing.
@bcopeland any thoughts on this?

I am back, this time one of my Multisensor 7 sensors ran out of battery again. This time it only took 9 days.

My question to @Hubitat_Staff, could there be some thing wrong with the built-in driver, i.e. in terms of it trying to talk too much to the device and waking it up? I have a multisensor 6 which has worked perfectly well for now for more than a year on batteries and using CSteele's Multisensor 6 driver.

I checked the logs for the multisensor 7 and this is how the low battery warning played out:

At 13:13 I recieved the first warning (notice it was 100% just 15 minutes earlier)

Then the final notifications 20 minutes later and it was dead:

My Multisensor 6 still shows 100%, but obviously I don´t know if that is still the case (after 1 year, I doubt it), but at least it didn´t die after only 6 days.

I have 2 of these Multisensor 7 devices (as mentioned earlier), and I did update the firmware of both of them, but I doubt that a reputable company like Aeotec would either put out a lesser device or firmware which is so catastropically bad as to make the device run out of batteries after 6 days.

Then the really weird part is that it came online again a few hours later, now reporting 1% battery.

The sensor is located in my Bathroom, so it is activated quite frequently. I don't think that my preferences are anything out of the ordinary and would encourage high battery drain:

Any thoughts on this?

There is a issue with the built in driver. In home assistant it works fine, do a reset and add to hubitat, and I get constant issues.