Aeotec illumino Dimmer Switch

I've got a C7 running version 2.3.8.123.

I want to create a setup that gradually turns the lights on from off to full brightness. Trying a variety of Apps hasn't worked. I'm having an issue getting the basic driver to command the lights to on with a specific brightness level.

I have the built in ramp set to instant to when I use the switch manually it goes to on/off without any delay. I can't figure out any way to set the brightness through a zwave command and have it actually output at that level, it simply goes to full brightness.

Has anyone had success at doing this?

Here's the zwave info:

  • deviceId: 37
  • deviceType: 259
  • firmwareVersion: 1.5
  • hardwareVersion: 1
  • inClusters: 0x5E,0x26,0x70,0x5B,0x85,0x8E,0x59,0x55,0x86,0x72,0x5A,0x87,0x2B,0x2C,0x73,0x9F,0x6C,0x7A
  • manufacturer: 881
  • protocolVersion: 7.13
  • serialNumber: 0C4314FFFEA9BB38
  • zwNodeInfo: D3 9C 00 04 11 00 5E 26 70 5B 85 5C 8E 59 55 86 72 5A 87 2B 2C 73 9F 6C 7A 68 23

This is what the "Set Level" command should do. What happens when you try it directly from the device detail page? If that works, it should work from an app too--just a matter of finding the right one and getting the right configuration. Sharing what you have tried or more about exsvtly what you want to do (e.g., what you want to "trigger" it) may help.

My goal is to have the lights fade up at a certain time (a visual alarm to wake up). Using the Basic Rules app, I can get it to turn on at the correct time. The fading doesn't work though.

Using the controls on the device page, I am able to set the output level, but the duration setting has no effect.

Most Z-Wave devices should work with a duration, but maybe there is something odd about this particular device (I don't have one and am not familiar with it personally). What if you start at level 1, then go up to 99 with some duration? The duration, as you may know, is in seconds, so 10 would be 10 seconds in your example. (Z-Wave technically maxes out at 99, though many drivers handle conversion down from 100 automatically; you may still want to try 99 instead of 100 to see if it changes anything.)

If nothing else, Rule Machine should be able to do this, but you'll need the "Fade dimmer over time" action rather than the "Set dimmer level" action. The former chunks up repeated "Set Level" calls over time (using the difference between the current/start level and the desired/end level, plus your desired steps) rather than doing it all in one as the actual command or Basic Rule would do. While I think another approach is best whenever possible, sometimes you need this for devices that don't support a particularly long duration you might be going for or for devices that don't work well with this command for other reasons (I'd be surprised if this is one, but again, I don't know it...).

I tried using 99 and different durations, but it always went to the set value with no transition.

Using RM did work. :slight_smile: Its not a smooth fade, but since the smallest time delta is 1 second over a 1 minute span, that's the best I can get for now. If I can figure out how to use the builtin dimming, I know it can do a smooth fade.

Here's what I have for now:

I'd like to have it be enabled every other Friday, but I will search around and see if I can figure that out before posting a new question.

Thanks for the help! Much appreciated.

@antamiga
This works for me from the device page however I am using JTP's Zooz ZEN driver (because I set parameter 133 to different levels at night and that is the only driver that allows me to do that via RM). I had to do a Set Level to 5 first and then do a Set Level to 100 with a duration because it was already at 100 - it was just switched off.

@Wounded Can you give me a link to a page with all the settings for that device?
Does my driver work for everything else correctly?

Hi @jtp10181
Illumino dimmer paramters

Everything I have tried has worked.

@jtp10181 @bertabcd1234
To get smooth diming, would a device driver need to set parameter 125, then set the brightness level? I assume this would work using the Basic Rules app or others, versus RM sending multiple commands to get a similar effect (though less smooth).

image

@Wounded
Which of the drivers did you pick from the Zooz ZEN? There's multiple Dimmer drivers.

In your RM setup, does it specify 2 actions? The first sends the level setting and on, then the second sets the duration and ramp time?

They are using my custom driver which would be the user driver Zooz Zen Dimmer Advanced.

If your device firmware has the command classes implemented correctly, it should take the duration in the setLevel command for at least up to 127 seconds. So it may possibly just work using my driver. If you turn on debug logging I think I have a log entry in there that shows you exactly what it is sending to the device.

If that does not work then yes you would probably need to set that parameter first then set it back after. There could be a delay so you may need to delay your level command by a second or two.

You would need to use RM, and first set the parameter, then a short delay, then set the level. Then another delay and set the parameter back to where you normally have it.

BTW if my driver works well for that dimmer I was considering adding all of the settings to it as a custom version, thats why I asked for the settings docs. Or anyone could do it, its pretty simple to modify the settings in the driver the way I have it setup.

Yes, I am using the Zooz ZEN Dimmer Advanced driver.
I am using it differently. I wanted the light to come on dimmer at night when you hit the up paddle. I have a rule that sets the level in the dimmer's single tap behavior parameter to 40 at 8PM, 15 at 11PM and then back to 90 at 7AM. That parameter is 18 for the ZEN 77 dimmer, 133 for the Aeotec Illumino dimmer.

@antamiga

Please Test this driver and give feedback. It should discover all the settings for the Aeotec Dimmer

I will be able to test later tomorrow and will give you feedback on how its working.

I installed the new Dimmer driver and it works. Here are the things I noticed:

  • It shows - deviceModel: UNK00
  • When running Query Device, the status scans but then it gets stuck on Syncing Settings from Device...
  • The start Level Change does a smooth fade up, but the time seems to only partially work. Using 30 seconds looks about the same as picking 5.

I thought I saw buttons on the device page right after I first installed it, that said pick simple query if having an issue. I can't figure out why it disappeared.

There's also some issues listed in the log. Apologies for not having more info. I can turn on debug logs and pay attention to what I'm clicking, to get you more info if you would like.

Should be way at the bottom, if the device settings loaded it will be below all of those. Possibly the errors are breaking the settings display and nothing is showing.

Parameter Scan Type
Try basic scans if the full scan won't complete

I will check into those errors later today and figure out what the issue is.