Aeotec Heavy Duty Switch Gen 5 (ZW078-A) Reporting Issues

Plenty of threads talking about this device and problems, but no answers on the issue I'm having (that I've found). I'm using this driver. Below are the z-wave details from the device page and from the hub Z-Wave details page.

I'm trying to use the thing for some basic power reporting to know when the dryer has stopped running. My plan was to start by running a test cycle and adjust reporting down to the minimum I need. The problem is that after a cycle starts, I get ~4-5 accurate power reports, then a report of 0W, and then nothing else. While the dryer is still running. If I use the poll function of the driver, the temp and voltage attributes update, but nothing else. The odd part is if I either turn the dryer off and back on or toggle the switch off/on, I'll start getting the power reporting again, but it's the same cycle.

I have a USB stick on the way to re-pair it unsecure (no option for no security when pairing with HE), but am looking for other ideas if anyone has any.


Welp...have it paired unsecure now, but no change. Still get ~5 power reports and then it drops to 0 and stops frustrating.

Cross-posted from the driver thread.

I finally got this fixed. The "fix" was to swap the hot legs around on the appliance side of the switch. Once I did that, I started getting consistent power reports. I had previously swapped the legs around on the input side with no change.

Now that it's fixed, I think I see a trail to what the problem is.

###Pretty much everything below here is an assumption###

With 240V, there's two hot legs. Dryers are cyclic where they will toggle the heating element on and off. It would appear that the plug is checking one of the legs for power. If power is there, then it checks the other leg. If there is no power on the first leg, then it doesn't check the other one at all.

The reason I assume this is that, now that I'm getting the power reports, I can see that when I was getting a report of 0W before, I should have been getting ~470W. The dryer bounces between that and ~5100W when the heating element kicks back on. I assume the dryer only pulls power on one leg when the heating element is off. If that leg isn't the one the switch is set to check first, then you get a report of 0W.

Wonder if this is what's going on with my GE/Enbrighten/Jasco 40-amp switch. The symptoms seem to be consistent exactly with your assumption above.

When I do test runs with an empty dryer, the smart sensor in the dryer reduces the time to 1 minute and indicates a cool down period. My Rule plays an announcement then, even though the dryer keeps running for a good 5 minutes longer.

Gonna swap the dryer-side hot legs and see what happens.

That was exactly the issue. Swapped red and black hots on the load (appliance) side of the switch and everything's working. Wattage, amperage, everything. So glad I ran across this old post.

1 Like