Aeotec Garage door controller issues


I've successfully paired my ZW-062 Aeon Garage Door Controller, which is listed as a compatible device using the generic zwave garage door opener driver. I have buttons for open and close, but cant do anything with them. there's no current states or state variables visible.

I thought it could be something to do with locks/garage doors being enabled for secure join, as the manual for the device doesnt show a way to secure join it. Not sure if theres a way to disable secure join on the hubitat.

Any help would be greatly appreciated.


Bump. Anyone have any advice where to from here?

Locks and garage door controllers always secure join. No way to disable. In the device details, under the Data section, you should see 0x72 in the InClusters if you have secure pairing. Or was it 0x73? :thinking:

Anyway, it you don't see that, it didn't join securely and isn't going to work properly as a result. Might try moving the hub closer with a long Ethernet cable and see if that helps. If it does, then perhaps it's too far from the hub and you will need to add a repeater to get it to work normally.

thanks for the reply, heres what i see:

  • deviceType: 515
  • inClusters: 0x5E,0x25,0x70,0x85,0x59,0x72,0x86,0x7A,0x73,0x98,0x66,0x71
  • outClusters: 0x22,0x5A,0x82
  • deviceId: 62
  • manufacturer: 134

problem is, i dont think the aeon garage controller can be joined securely, theres nothing in the manual about doing it.

it worked great with my Vera in normal joining, so thats why i suspect that thats my issue.

How many times have you tried joining it? Have you tried with the hub close? It should also say * zwaveSecurePairingComplete: true just below the device type. I think you're going to need to get that for it to work correctly. Others have reported issue with locks and not getting the secure pairing to show up. They kept trying (exclude and re-join) and when they finally got that to show up, the lock worked correctly.

Cluster 0x98 is the security cluster, and it didnt pair securely, and without that it's not going to work.

1 Like

ok, good to know guys and will try again and keep an eye on it.

does the garage controller device have to support secure pairing for it to secure join, or will any zwave plus device secure join as long as hub supports it?

Thanks for the correction Mike. Wow, that was really wrong :upside_down_face:

When it joins correctly, it will secure join.

Why is it that we sometimes get the Secure cluster showing in the data field, but still don’t get a secure join?

so i excluded and rejoined and getting this:

  • deviceType: 515
  • inClusters: 0x5E,0x25,0x70,0x85,0x59,0x72,0x86,0x7A,0x73,0x98,0x66,0x71
  • outClusters: 0x22,0x5A,0x82
  • deviceId: 62
  • manufacturer: 134

Looks exactly the same to me. 0x98 is in the inClusters field, so i dont know what else to look for.

You want to see something like this:

  • zwaveSecurePairingComplete: true
1 Like

You need to see something like this (my Yale YRD256 lock)

  • deviceType: 32770
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x72,0x98,0x5A,0x73,0x86
  • deviceId: 1536
  • manufacturer: 297

How far is the hub when pairing? Is there a repeater in-between?

ive put it right next to the hub, like less than half a metre.

takes a little longer than usual to initialize, but gets detected where i can hit the save button and does come up as generic zwave garage opener.

Heres the manual and there's no mention of secure pairing:

Looks like im having similar issue with my Schlage le162 front door lock, it does pair, just not securely and detected as type: Device. When changing driver to Generic zwave lock it makes no difference, cant lock or unlock with buttons in the device page.

This Schlage lock is quite old now, at least 6 yrs, but worked fine with my Vera Edge. But it wont have zwave plus.

Not having much luck with secure pairing :frowning:

Didn't realize you were in Australia. Do wish we had a way to check out what country someone is from, even when they don't disclose their city. Makes a big difference with the answers we offer.

Are you able to pair other Z-Wave devices? Wondering if you have a faulty Z-Wave adapter.

Yes im in Melbourne, australia, but how is that relevant :slight_smile: and how did you know lol

Yes i've paired heaps of devices so far. got 3 aeotec multisensors, aeotec nano dimmers, aeotec micro dual relays, and aeotec door contact sensors (the triangle ones) all working perfectly.

Just struggling with these last few devices to fully move away from Vera.

Having trouble with this garage controller, schlage le162 lock, the old aeotec motion sensors, and none of my fibaro fgk-101 door window sensors are working either. all are pairing, just not showing any current states so cant do anything with them.

Im thinking because hubitat is a lot newer hub then vera, it doesnt have the support for some of these devices, which i've had floating around for years.

From your post of the manual. It describes resetting with either a Z-Stick or a Minimote. Do you have either of those, and if so is that what you used to reset it before attempting to pair with HE?

Also you said less than a meter, so that immediately told me you're not in the US.

Sounds like @njanda, another Australian user, is also not having success with those fibaro sensors.

To answer your previous question, it's relevant because you have different devices than are available in the US and Canada, you have a different Z-Wave radio frequency and you have a massively different time zone, so I can tell that you're awake and have rested since it's just after 3pm. :wink:

I haven't reset it yet. I thought an exclude from vera should have been enough. And didn't want to reprogram all the user codes again. I'll have to give that a go and try it again tomorrow.

1 Like