Aeon Z-Sick with Hubitat?

In another topic (tried to reply) @kilowatts mentions the following about using Aeon Z-Stick stick for Inclusion. My question is, once the device are "Included" using the Z-Stick how do you then get the Z-Wave devices working with Hubitat?

Continuing the discussion from Inclusion, Exclusion, and Factory Reset procedures:

I'll add a question. Easiest way to include the Z-Stick INTO the HE hub as a device/secondary controller?

Easy one first:

But the simple answer is, you join a ZWave stick the same as any other ZWave device. Put Hubitat into pairing (Inclusion) and get the ZWave stick to pair. For Aeon, just click the big button once.

As to including ONLY with a ZStick and then having the hub see the device.. well.. that's somewhat automatic, but incomplete.

When the ZStick is doing the Inclusion, it FIRST converses with the SIS/SUC (the Hubitat Hub) to get the next Node Number... which it then passes on to the target device. When complete, the Hub knows the Node was assigned but will not have initialized yet. On the ZWave Details page, a Device should appear with a Discover button. No Automatic Assignment of driver occurs using this method.

1 Like

I must be doing something wrong then... when I click the big button the z-stick it turns it on. If I have Hubitat in inclusion never picks up anything.

1 Like

@csteele, I tried basically the exact same thing, except using a Minimote instead of a Z-Stick. The Minimote included the other device, but when I checked the Z-Wave Details page, there's no sign of any un-initialized devices. Has something changed in Hubitat's UI? Or is there some other way/place that I should be looking for the invisible device?

ps. I did confirm that the Z-Wave Node IDs were being incremented, so the devices were definitely being added to the Z-Wave network.

I don't have a modern answer... about 10-11 months ago I had about 65 devices shared between 4 hubs.. they were all joined to each other in one ZWave network. When I got Hubitat, I joined it the same way and had 5 hubs all on the same ZWave network. Hubitat became my favorite and I factory reset it and started over with a migration. I moved devices, one room at a time from the 4 non-Hubitat hubs to Hubitat. At that time, all of what I described, worked that way. I haven't had need since and I do know that much of what I used in those days no longer appears directly. For example, we don't see those 'discover' buttons on the ZWave Details page any more.

I honestly don't know how it works in the current Firmware. I would guess it's a Hubitat staff question, maybe @chuck.schwer.

1 Like

@csteele I am having the same issue as @jrfarrar - doesn't look like he was ever answered.

I have a new z-stick gen 5. I used it to OTA upgrade a couple of multisensors. After I was done doing that (was not joined to Hubitat network), I did a factory reset on the z-stick.

I want to add the z-stick to my Hubitat network. I go to Devices - Discover Devices - Z-Wave - Start Z-Wave Inclusion and then I press the button on z-stick and nothing gets discovered.

I tried again but longer press (blue flashing on z-stick) and still nothing happens.

I haven’t backed up my Z wave radios in a while because I haven’t added any new devices recently. I’ll give it a try again and see if I can get more specific instructions but I can’t do it tonight, it’s :jack_o_lantern:

1 Like

It is? Plus there's a 49ers game!

I noticed the Z-Stick is NOT on the Compatible Devices page - that seems interesting.