Advanced RGBW zigbee driver

I upgraded and this has no bearing on what I am seeing. It was a long shot that someone said fixed an issue for them.

What I am seeing in is when certain devices using the advanced zigbee RGBW driver are turned on in Room Lighting, the on/off state is not updated and the device turns on but the switch state still shows it as being off. I tried hitting configure and the lights flash all of their colors and the switch state shows on. From the driver page I can then turn the light on/off, set color, etc and the switch state will show correctly. As soon as I use Room Lighting to turn on the light, the switch state does not update to on. This issue does not exist in firmware so it's definitely something that was changed with the advanced zigbee RGBW driver between .125 and .134. Maybe it has something to do with the way Room Lighting is turning on the lights? I am attaching a screenshot of a Room Lighting for your reference. Also, my testing was in no way thorough so there may indeed be issues from the driver page or using other apps.


I have also discovered that when I go back to .125, I have to hit configure to get things working again otherwise the switch state still doesn't work.

I tried using the Generic Zigbee RGBW driver but that driver will not change the level of my lights. Why, I don't know.

The devices that I have so far noticed that are affected are my Ledvance RGBW strips and my Sengled RGBW bulbs. Other users have mentioned other devices that are affected.

I have once again reverted back to .125 to keep the bride happy but can gather additional data. Just let me know if you need anything else.

1 Like

Similar issue here. Room lighting stopped turning off my Segled bulbs using the advanced zigbee drivers so I rolled back to .125 and all is good again. Thought about updating and giving the generic bulb drivers a try in the next few days if a fix doesnt come out

I didn't test the Sengled with the generic driver because the LEDVANCE didn't work and I need both in the kitchen.

I think @mike.maxwell changed the driver to accommodate other users devices who the driver didn't work for. Maybe he can just add the unmodified driver back into the mix as a driver for Sengled, LEDVANCE and whatever other devices need it and call it a day.

I don't think I need .134 over .125 so I'll just hang out on .125 until fixed. I might recreate my room lightning rule in Rule Machine just to see if it's an issue with the two of them combined.

It's so great that the HE can move between firmware versions so easily so we can test things without too much trouble.


The only changes to that driver were the implementation of the refresh command, this alone would not effect normal behavior.
If someone can give me a specific example of a specific room lighting rule not working with a specific device/driver combination I can look into that.

I sent you details and a video of the advanced driver misbehaving at Possible bug: Advanced Zigbee RGBW Bulb driver no longer going "on" after SetColorTemperature - #12 by jlv (my issue is reproducable without RL).


Tell me how and I will send you a RL rule? It's either a driver issue or a RL issue but I didn't see any mention of Bruce making any changes to RL. Another easy way to check if it's the driver would be to send me the unmodified driver to try on .134. Or it's something else that was changed between .125 and .134 that is affecting quite a few of us but I have no idea how to even try and troubleshoot that.

It seems that if you send a white temp and level or colour and level rather than a "ON" you get the issue.

Currently on my RM rules I just have put a ON before the colour or temperature command and that fixes the issue. Basically the driver is not updating the ON settings when the device is turned on via a level.

This obviously can't be done in RL

1 Like

Thank you @BorrisTheCat !

I just looked at the events using .125 and it shows the RL rule sending a command-setColorTemperature and the the driver then is sending a switch on. When I looked at the events last night using .134 I saw the command-setColorTemperarture but no corresponding entry where the driver sends a switch on command.

Now I know that I can work around the issue, if needed, by recreating the RL rule in RM. I will wait for @mike.maxwell before going to all of the trouble of doing that.

ok, thanks for the video, i see what its doing, or rather not doing...



Wondering if the advanced Zigbee driver will be changed to work like it did before?

If not, I'll start the arduous task of rewriting the affected Room Lighting in Rule Machine so I can upgrade the firmware on the hub. Thanks

Please look at advanced zigbee ct bulb driver because i had to change to the generic because it seems to be doing the same thing as the rgbw

thats the plan
the other advanced drivers will be changed to follow


Thanks @mike.maxwell

I installed .138 and the drivers aren't fixed yet. Rolled back. Waiting for next release.

The release notes will include a list of updates, save you some time:

You can set the Release Notes section to "Watching" so you get notified when new release notes are posted...



Thanks @danabw .

I did read the release notes but have at times seen things fixed/changed but not make it into the notes. I figured since I was sitting on my a$$ doing nothing I would check.


LOL...been there, done that. :wink:

1 Like

Yepp, still not good...

Hi, I'm keeping an eye on this thread because I have the behavior reported on many bulbs.
Do you have any estimate of when this issue will be resolved?

I was told in release 2.3.9